キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

11月30日(土)16時から19時(日本時間)の間に、ライセンスサーバーメンテナンスを実施する予定です。

期間中、ライセンス関連の操作(ライセンスキーのアップロード、ダウンロード、アップデート、SSAの確認、ライセンスプールへのアクセス、GSID認証)が、約2時間ほど、正常に機能しない可能性があります。

ご不便をおかけしますが、ご理解の程、よろしくお願い申し上げます。

WindowsでPLNファイルをダブルクリックしてもARCHICAD23で開くことができない

Michitaka Kiriki
Graphisoft
Graphisoft

影響のあるバージョン: ARCHICAD 23 | 重要度: 対応策あり | ID: 267213, 267874


問題


WindowsにARCHICAD23をインストールすると、そのままではファイル種類で関連付けが行われません。ファイルをダブルクリックしても、互換性のあるアプリケーションが表示されない、もしくは以前にインストールしたARCHICADのバージョンでファイルが起動します。



原因


インストール中に問題があり、ARCHICAD23ではファイル種類で互換性のあるアプリケーションとしてレジストリに登録されません。結果として、ARCHICAD23はシステムから新しいうろグラムを開くことができるプログラムとしては認識されず、デフォルトとして設定したり、開く一覧のアプリケーション一覧に追加されません。


対応方法


コンピュータ上でARCHICADプロジェクトを検索し、そのファイルを右クリックしてプロパティのダイアログを開きます。全般タブから変更ボタンをクリックして、このファイル種類をデフォルトで選択されるアプリケーションのリストを開きます。 もしARCHICAD23がそのリスト内に、その他のアプリをクリックして、スクロールしてこのPCで別のアプリを探すを選択します。ARCHICAD23のインストールされたフォルダからARCHICAD 23 Starter.exe選択し、開くをクリックしてプロパティダイアログに戻ります。変更するためにOKをクリックして確定します。ARCHICADと関連付けたい全てのファイル種類で実行する必要があります。



上記の方法が機能しない場合は、レジストリで必要な変更を行うための外部アプリケーションが必要になります。この操作を行うことができるアプリケーションの1つにDefaults Programs Editorがあります。ダウンロードし、解凍して実行し、下記の手順に従ってください:


  1. File Type Settingsの選択
    select-file-type-settings.png
  2. ダイアログ下部のChange Open with programsを開きます。
    select-change-open-with-programs.png
  3. 変更する拡張子を選択します。複数選択が可能です。検索フィールドを使用してARCHICADが含まれるファイル拡張子を検索できます。
    select-extensions.png
  4. 選択したファイル拡張子に他のARCHICADがあれば全て削除します。
  5. Add…ボタンをクリックして、ARCHICADインストールフォル内のARCHICAD Starter.exeを参照します。
    select-open-with-items.png
  6. Save Open with Listボタン右の矢印ボタンをクリックしてSave to Registryを選択します。
    select-save-to-registry.png
  7. 選択したファイル拡張子がARCHICAD23への関連付けが完了しますので、アプリケーションを閉じます。


それから、編集したファイル種類のいずれかのファイルをダブルクリックすると、Windowsからこのファイルをどのアプリで開きますか?が表示され、ARCHICAD23がデフォルトアプリケーションとして選択できます。この設定は、ユーザー別となるため、こちらで選択する必要があり、システム全体の設定としては保存できません。


対応方法


インストール中にファイルの関連付けが失敗する原因となる不具合は、アップデートにて修正予定です。それまでは、上記の手順に従ってARCHICAD23を設定し、プロジェクトファイルを開いてください。


2つ目の対応方法が行う必要がある場合、この問題の修正を含むアップデートをインストール後に、デフォルトのアプリケーションを再度選択する必要があります。これは、先ほどのアプリケーションとGRAPHISOFT製品がファイルの関連付けを行う方法に違いがあるためです。しかし結果的には同じ結果になります。


上記の対応方法で解決しない場合、最寄りのGRAPHISOFTサポートまでお問い合わせください。

バージョン履歴
最終更新日:
‎2019-11-15 12:43 AM
更新者:

回答が見つかりませんでしたか?

このフォーラムで
他の記事をチェック

フォーラムへ戻る

最新の解決策をチェック

採用された解決策

新しいディスカッションを始める

投稿する