キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

ご意見をお聞かせください!
Archicad 28のホーム画面とツールチップ/クイックチュートリアルに関するアンケートにご協力ください。

hotfix のインストールに関する問題のトラブルシューティング

Michitaka Kiriki
Graphisoft
Graphisoft

Macでのアクセス許可の問題のトラブルシューティング

問題:
ホットフィックスのインストーラが提供するArchicadでは、## ホットフィックス ## がArchicadフォルダ内のファイル/フォルダにアクセスできません、とメッセージが表示さされます。
解決方法:
最初のステップとして、管理者ユーザーとしてログインしていることを確認してください。システム環境設定、ユーザーとグループでは、どのユーザーが管理者権限を持っているかを確認することができます。
それでも問題が残る場合は、Archicadフォルダの権限を修正してください。
  • Finderを開きます
  • Archicad の各バージョンのフォルダ(デフォルトでは /Applications/Graphisoft内)に移動します
  • ロックをクリックして認証して設定を変更します
  • 歯車のアイコンをクリックして、選択された項目に適用...を選択します。
  • これが終わったら、ホットフィックスを再度インストールしてみてください。
getinfo.png
上記の手順で解決策が得られない場合
  • Application/Graphisoftフォルダ内のArchicadフォルダを探してください。
  • 右(ctrl)クリックしてコンテキストメニューを開きます
  • フォルダを複製いします。
  • それが終わったら、元のフォルダを削除します
  • 新しいものを元の名前に変更します
  • 再度ホットフィックスを適用します



MacでHotfixを適用すると警告メッセージが表示される

問題

Mac に ホットフィックス をインストールすると、次のようなエラーメッセージが表示されます(Archicad 15 Hotfix 2 build 3602 に関連して最も多く報告されています)。
hotfixmac.png

原因

GRAPHISOFT の調査によると、ホットフィックス を適用したユーザー以外のユーザーが Archicad をインストールした場合にこのような現象が発生する可能性があります。

解決方法

Archicadのフォルダの所有者を変更することが、最も簡単な解決方法です:
再インストール:
  • Archicadをアンインストールします
  • 現在のユーザーで再度インストールします
  • 同じユーザーアカウントを使用してホットフィックスを適用します
Archicadフォルダを複製します:
  • ファインダーでArchicadファルダを複製します
  • 元のArchicadフォルダを削除します
  • 新しいフォルダに元の名前に変更します
  • ホットフィックスを適用します
ターミナルコマンドで所有者を変更:
  • アプリケーション > ユーティリティ からターミナルを開きます
  • "短縮した"ユーザー名を決めます - 'whoami' コマンドを入力して、Mac OS があなたのために使用する内部ユーザー名 (おそらくログイン名とは異なる) を指定します (その後に 'return' キーを入力します)。:
whoami
  • 次のコマンドを実行します
sudo chown -R $user /Applications/Graphisoft/Archicad 15
_! $user は前のステップで取得した johnsmith のような短いユーザー名です。 コマンドを完了させるために、(管理者アカウントの)パスワードの入力を求められます。表示されているように、'Archicad' の後には前方のスラッシュではなく、バックスラッシュを入力するように注意してください。
インストーラが Archicad のアップグレードが完了していると表示し、ホットフィックス を再適用できない場合。
  • Archicad フォルダの中に ProductVersion.xml を見つけてください。
  • テキストエディタで開きます
  • 製造番号を 3269 に戻す (新しいビルドよりも小さい番号を選択)
  • 保存します
  • 再度ホットフィックスのインストーラを実行します
<productversion>
  <buildnumber>3269</buildnumber>



BIMサーバーでHotfixを適用すると、teamwork.server.event.client.dllが見つからなくなる

問題: 何かがこのファイルのインストールをブロックしているため、結果としてファイルが欠落してしまいます。(Windowsのみの問題)
解決方法:
実行中のBIMサーバサービスをすべて停止します:
  • スタートメニューをクリックし、実行/検索フィールドにservices.mscと入力します
  • Graphisoft BIM Serverのすべてのプロセスを1つずつ選択し、停止をクリックして、インストールされているすべてのBIM Serverモジュール(14.0, 15.0, 16.0)のプロセスを停止します。
    • Graphisoft BIM Server <version number>
    • Graphisoft BIM Server Monitor <version number>
    • Graphisoft Teamwork Messaging Server <version number>
services.png
BIM Serverフォルダ内のProductVersion.xmlを探し、xmlエディタ(もしくはメモ帳など)で開きます。
  • ファイルのデフォルトの場所です。C:Graffisoft\Program Files\BIM Server\Server Modules\<module version>Gt\TeamworkServerProductVersion.xml
  • 製造番号をファイルに表示されている製造番号よりも低い値に変更してファイルを保存してください(例:製造番号が4038の場合は4037に設定してください)。この製造番号がローカライズ用に公開されている製造番号よりも低い場合は、Hotfixが実行されない可能性があります。
  • この結果、Hotfixを再適用できるようになります。
Hotfixパッケージを再度実行してください。いくつかのエラーメッセージが表示されることがありますが、無視して構いません。その後、停止していたのと同じ方法ですべてのサービスを再起動するか、コンピュータを再起動し、BIM Server Control Centerを開き、[スタート]をクリックします。

回答が見つかりませんでしたか?

このフォーラムで
他の記事をチェック

フォーラムへ戻る

最新の解決策をチェック

採用された解決策

新しいディスカッションを始める

投稿する