BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Archicad AI Visualizer
Discussions about Archicad AI Visualizer.

AI Visualizer Technical questions

Illes Papp
Graphisoft
Graphisoft

We know that taking part in an experiment can be challenging from time to time. Do you have issues with installing or running the Archicad AI Visualizer Add-on? This is your place to ask your questions and initiate discussion with others about technical difficulties you may experience while trying to install or run the experimental add-on, or generate images.

Illés Papp
GRAPHISOFT Senior Product Manager
128 REPLIES 128

Hi, everything is working fine when in Low VRAM mode. Results are very interesting so far and render times are decent (about 1 minute).

Oosh
Booster

I have installed home-brew and executed the commands in Terminal per the installation instructions. I have copied the sd.webui folder to the Archicad 27 Apple Silicon folder and copied the AI visualizer folder into the extras folder within the add-ons folder.

 

Archicad is not showing the AI visualizer as a palette and when I open the add on manager it says: "The file is an outdated Add-On that cannot be used with this Archicad version."

 

What am I doing wrong? Do I need to install the latest AC27 update for the visualizer to work?

Screenshot 2023-11-18 at 8.50.39 AM.png

AC26 5004 | MacBook Pro (16-inch, 2023) | Sonoma 14.0 | Apple M2 Max | 32 GB RAM

I can’t even get the commands to run in Terminal. It just returns an error saying the URL cannot be found. 

Lee Hankins
ArchiCAD 4.5 - Archicad 27UKI Apple Silicon 27.2.0
macOS Sonoma (14.4.1)
Patrick120772
Booster

I followed the installation instructions for windows but when I try to generate it give me an error that the AI server is not available.

 

error.png

Installed and the engine seems to be running.

 

However, I keep running into to errors that are explained by a very generic pop-up (see image).

It also refers to the technical documentation but I haven't been able to find that anywhere 😄

 

Error message.png

 

Erik Bjornhage : SwedishChef, ETTELVA Arkitekter, Gothenburg, Sweden
Architect : Digital Development : Graphisoft Cert. BIM-Manager
ETTELVA Arkitekter : Eriks LinkedIn
DELL Precision 5570; i7-12700H; 64 GB; RTX A2000 [8GB] : AC12 - future

Patrick
I had similar errors - but I think it was because I tried to generate images before the engine was properly loaded. Once I waited (more than one minute) it stopped that error (and started giving me other ones).

Erik Bjornhage : SwedishChef, ETTELVA Arkitekter, Gothenburg, Sweden
Architect : Digital Development : Graphisoft Cert. BIM-Manager
ETTELVA Arkitekter : Eriks LinkedIn
DELL Precision 5570; i7-12700H; 64 GB; RTX A2000 [8GB] : AC12 - future

Hi Erik

 

I waited for 5 minutes...just to make sure and I had the same error.

Peter Dobrosi
Contributor

Dear Illés! Hi everyone!

My setup: Ryzen 5 5600X; 16GB RAM; 500GB SSD; Radeon RX570 8GB VRAM; WIN11

I've read the install/user guides. I've pasted the sd.webui to the C:/root and the Add-on files to the AC library. (Already renamed them as Hungarian version)

The palette works fine, I unchecked the „Start in High VRAM mode" and when I try to Generate I get this message: Image generation failed.(screenshot attached)
Then I tried to click on Start AI Engine and I get this message: see in screenshot.

Can you please explain exactly what should I do step by step?
Thank you!

 

Image generation failed.png

 

Start AI Engine.png

I would guess the problem is that you don't have an NVIDIA graphics card. You could check the system requirements to see if this is necessary.

 

Regards, Paul

Thank you, but I think it's not the case. There is nothing about the graphics card manufacturer in system requirements. Even though it should work on weaker configs too:
https://community.graphisoft.com/t5/Archicad-AI-Visualizer/TIP-to-run-Stable-in-computers-with-4-6GB...

 

I think I should make some changes in the command lines, and that's where I'm stuck. 

 

System Requirements.png

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!