Archicad AI Visualizer
Discussions about Archicad AI Visualizer.

AI doesn't work

Martin_S
Participant

The AI for Archicad 27 isn't functioning on my MacBook Pro M1. I'm encountering the following error message: RuntimeError: MPS backend out of memory (MPS allocated: 16.84 GB, other allocations: 1.30 GB, max allowed: 18.13 GB). Tried to allocate 10.00 MB on private pool. Use PYTORCH_MPS_HIGH_WATERMARK_RATIO=0.0 to disable upper limit for memory allocations (may cause system failure).

 

Bildschirmfoto 2023-11-17 um 22.45.38.png

 

12 REPLIES 12
lopezfigueroa
Enthusiast

same error in windows 10

Alfredo1
Participant

Same error, I tried on Windows and Mac 

edseiber
Participant

Installed last Friday on my MacBook Pro M1 Max 64 GB Memory. Seemed to work fine initially, but now I get the attached error message. Any advice?

 

Not aware that I changed any base parameters, but could have by accident.

 

Screenshot 2023-11-21 at 9.59.36 AM (1).png

 

Illes Papp
Graphisoft
Graphisoft

Can you please provide a screenshot of your command prompt?

Illés Papp
GRAPHISOFT Senior Product Manager

Do you remember making any manual changes on your JSON file, mentioned in the error message?

Illés Papp
GRAPHISOFT Senior Product Manager

Is this what you're looking for?

 

Screenshot 2023-11-24 at 9.13.07 AM.png

I have been getting the same issue: 

Screenshot 2023-12-21 093409.png

 

My GPU: memory:

wilson0083_0-1703115435108.png

From my reading, my laptop selects which GPU to use based on a performance level (Windows 11: System>Display>Graphics). I have tried changing the performance setting from 'Let Windows Decide' to high performance for ArchiCAD 27 and Python (from C:\sd.webui\system\python) but still get the same prompt./

13th Gen Intel(R) Core(TM) i9-13900HX 2.20 GHz, 64 GB RAM, Nvidia GeForce 4050 Laptop GPU 32GB, 2 TB PCIe 4.0 NVMe SSD
1X32" (3840x2160), WIN11 PRO ENG, AC9-AC27

Hi edseiber,

 

I remember you had this issue previously and wrote this: 

"My issue is now resolved. I discovered I had the JSON Config Template nested within the AI Visualizer folder under the Extras folder. Once I removed the JSON Config Template from the AI Visualizer folder and placed it directly in Extras, images generated fine"

 

Can you please check this again?

 

Have a Happy New Year!

 

Kind regards,

Norbert Kucsma

Technical Support Engineer

Hi wilson0083,

 

Please note that the minimum system requirement to use the Add-on is: 8 GB of VRAM on Windows and 16 GB of RAM on Apple Silicon.
For the detailed requirements read the system requirements.

 

Have a Happy New Year!

 

Kind regards,

Norbert Kucsma

Technical Support Engineer

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!