BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Archicad AI Visualizer
Discussions about Archicad AI Visualizer.

AI tool not working on Mac

Aldo de Sa
Beginner

Screenshot 2023-11-22 at 22.53.13.pngScreenshot 2023-11-22 at 22.53.43.png

 

Well, the AI Visualizer opens, and the code seems to be running fine on the terminal (at least following the user guide looks like it was supposed to be working)

Im using the Archicad 27 (Brazilian version if that matters) and a MacBook M2 Pro.

Any tips? Kinda new to archicad, been using it for a couple of months only

18 REPLIES 18
Aixtreme
Booster

Meanwhile, I got a new MacBook Pro with Sonoma. Made a clean install of AC 27 and the AI add-on. It's working fine now (see some examples below).

 

My wishlist now:

- A complete description of the prompt structure. (how to say what in which order)

- More control of the generating process. 

- Usage of special Library elements

- Upload of my own material, scans, background images

- Create bigger resolutions

- Rendering cue on the same machine. For example: store the cue and let the Mac render overnight.

 

And: take a look here for reference:

https://veras.evolvelab.io/

https://architectai.app/architect-ai

 

 

Best regards,

Aixtreme.

 

21-0125.Render1.png

 

21-0125.Render2.png

 

21-0125.Render3.png

They look cool.

I have only just installed AC27 and the AI visualiser today, so not sure what is going wrong.

I would like to avoid a re-install as I have just sorted out my work environment and installed all of the other add-ons.

I suspect it is something to do with the location of the AI engine.

Aixtreme
Booster

Well as there is no debugging mode for users, we can only suspect. 

 

I will install it on another Mac (M1 iMac) to see, if I can render over the network (no good description). If this is working, I will try to set up a render server (on windows). So I can send the render job into a queue.

 

Concerning the hardware: my MBP has 32 GB RAM and the AI add-on is not using it completely and also its not using the CPU cores. Would be niche to add this, so the rendering would be faster. Now its about 7 IT/S (Iteration per second).

Hi there, I tested the AI too too......

 

On first installation it worked (What are your settings with a house you made?, because it made a second house with my settings !!???

 

..... When I want to restart AC 27 with AI Tool, it doesn't find the file.

The RUN file open macOS with Xcode and don't find the right connection...... 

 

AI_27_Test_0030.png

 

AI-Start Problem 01.png

 

AI-Start Problem 02 Xcode.png

  

ArchiCAD v6.5 - 27 / macOS / Windows
Switzerland (Schweiz)

Hi there, it works now.

 

I forgot the button "Start AI Engine", after some seconds AI generate starts.....

ArchiCAD v6.5 - 27 / macOS / Windows
Switzerland (Schweiz)
AndyP
Participant

I have been having difficulty getting the Terminal prompts to work, I am getting a cannot activate Python error message in Terminal, when I try to use run.sh. 

AndyP
Participant

Got it working after a bit of messing around in Terminal. It is pretty impressive.

Andreas81ch
Booster

Hi there, I wanted to download the AI Vis Add-On for Windows, always comes this;

 

/AI_Visualizer/AI_Visualizer_Add-on-27-INT-install_package-WIN.zip not found

 

......... on INT Homepage, or German Homepage.....

Where can I find a link that works? (GER vers.) ???

 

Thx for help.

ArchiCAD v6.5 - 27 / macOS / Windows
Switzerland (Schweiz)

Hi Andreas81ch,

 

We are sorry to hear about the issue, the download link works for us and we did not hear similar feedback. 

Please try to download the Add-on again, and make sure that your internet connection is stable.

 

There are no localized versions, the Add-on works on the GER language version of Archicad too (the AI palette is in English only).

 

Kind regards,

Norbert Kucsma

Technical Support Engineer

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!