Archicad AI Visualizer
Discussions about Archicad AI Visualizer.

ERROR: python3-venv is not installed, aborting

Sindre
Contributor

After dragging run.sh it to the Terminal window and hit Enter, this message shows up in HomeBrew / Terminal.

 

I have moved the AI Visualizer folder from Add-ons into Archicad 27 folder > Add-ons > Extra.

And i have moved the sd.webui folder into Archicad 27 folder.

 

Skjermbilde 2023-11-17 kl. 22.02.39.png

 

54 REPLIES 54
Niranarch
Participant

Mine looks like stuck at some point. This is after dragging RUN.sh into terminal. how to go from here?

Not sure this is done or not! its like this for a long time and when i close it will ask if i want to abort the process !Not sure this is done or not! its like this for a long time and when i close it will ask if i want to abort the process !


@Niranarch wrote:

Mine looks like stuck at some point. This is after dragging RUN.sh into terminal. how to go from here?

 



When you see in log an IP address like 127.0.0.1:7860 or 0.0.0.0:7860 (where '127.0.0.1' is a local address and '7860' is a port), this means that the AI server is fully loaded and running, so you could run AI Visualiser add-on in Archicad and use it.

George

Niranarch_0-1700378997195.png

trying to render a simple cuboid with minimum prompt. I am not able to generate ayting till now. Only error messages!

Niranarch_1-1700379098467.png

 

Could you please provide complete log above this strigs:

Error: command buffer exited with error status.

 

If there are many strings, save to file and attach it here.

 

It seems that server is working, but there are some issues related to ANE (Apple Neural Engine). It could be PyTorch framework compatibility issue.

 

How many RAM do you have on your M2 Pro?

George
Eric Graas
Contributor

Mine has the same issues. It shows an error when run.sh is dropped into the terminal. Is there any further advice regarding this issue?

 

Screenshot 2023-11-22 at 10.10.22 AM.png


@Eric Graas wrote:

It shows an error when run.sh is dropped into the terminal. Is there any further advice regarding this issue?


Eric, did you follow the installation instructions?

Have you installed the brew package manager?

Did you install all required packages?

brew install cmake protobuf rust python@3.10 git wget

Your terminal log shows that you didn't install python.

Script checks a simple command (`python -c 'import venv') and it fails in your case, so I have to conclude that you have a broken Python installation or you missed package installation steps with brew.

George
iggiv
Booster

I followed the instructions of @Eric Graas but I still got stuck at the same step. still can't pass beyond this point. 

Sorry not Eric, I followed George's instructions but still stuck

If you need a more detailed manual, I could create one.

With command examples and sample output at each step.

George

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!