Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 
Collaborate forum

ARCHICAD crashes on gaming laptop with dual graphics cards.


Dear community members,


I am writing to discuss an issue that I have been experiencing with ARCHICAD on my gaming laptop []. Specifically, I have found that the program crashes frequently, and I believe that this issue may be related to the dual graphics cards in my laptop.

ARCHICAD is a powerful design and drafting tool that requires high-end hardware to run effectively. However, many gaming laptops, including mine, are equipped with dual graphics cards, which can cause compatibility issues with certain software applications.

I have tried updating my graphics drivers, adjusting the graphics settings in ARCHICAD, and even disabling one of my graphics cards, but these measures have not resolved the issue.

Based on my observations and research, I believe that the issue may be related to the way that ARCHICAD interacts with the dual graphics cards in my laptop. Specifically, it may be that the program is not optimized to work with this configuration, or that there is a compatibility issue with the graphics drivers.

I would like to suggest that the developers and support team behind ARCHICAD take a closer look at this issue and work to address it in a future update. Specifically, it would be helpful to have better support for dual graphics cards, including the ability to adjust graphics settings and optimize performance.

In the meantime, I would encourage other users who are experiencing similar issues to report them to ARCHICAD support or to share their experiences and suggestions in this forum. Together, we can work to improve the usability and effectiveness of this valuable design tool.


Thank you for your attention and support.





David O

Hi Judy

Are you using windows? I use a gaming laptop & had the same problem, I fixed it & no longer get this problem, in Win 10 I went to settings, Display, Graphics settings, select Archicad, click options & select high performance as the default option this forces it to use your  NVIDIA or AMD

graphics, I do this for any CAD or graphics programs.

I hope it helps.




Settings to force Archicad to use high performance graphics only.jpg

By dual I believe you mean integrated and dedicated. 

I have only ever used gaming laptops. I never had crashes but I hate the auto switching of graphics so I actually had to use a program my laptop came with to turn off the integrated card so that my laptop only uses the dedicated card.


Windows 11 makes it hard to force ArchiCAD to use the dedicated graphics. Basically you can't control it with out a third party program that can disable the integrated card. At least that's been my experience when I was monitoring loads.


I have an msi laptop that comes with a program specifically for this. Not sure if the one you have has something similar.

David O

Hi Yes

I do mean integrated and dedicated, I can also access which card  to use in the graphics driver mine is the NVIDIA driver, you just have to right click on the desktop & choose NVIDIA then when the panel opens you can access the settings for which graphics board to use with with each program  in my case NVIDIA, I set all graphics & CAD apps to use NVIDIA

Believe it or not the NVIDIA control panel gets overwritten by windows. I thought that worked too but when I  ran load tests my machine was still switch between cards while using ArchiCAD.  After some further reading and research I found that the only way is to completely disable the integrated card, but doing through the device manager will cause ArchiCAD not to run.

Maybe your machine is different but it's been the same on all three of my computers.


This is for windows 11 that it's an issue. Windows 10 still lets NVIDIA control the graphics 

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!