Collaborate forum
cancel
Showing results for 
Search instead for 
Did you mean: 

CADImage Tools / CI Tools - macOS Catalina

Michael Scott
Newcomer
Does anyone else have issues with CADImage Tools / CI Tools on ArchiCAD 24 and macOS Catalina?

I recently got a new Mac running the latest version of macOS Catalina (10.15.6). I installed ArchiCAD 24, checked for updates and installed the RFA_and_RVT_Geometry_Exchange-24-Technology_Preview-INT-3900-1.2. So everything is running the latest version. When I launch ArchiCAD 24 get a dialogue box to activate my license on the computer. When I do I get a message, "An error has occurred trying to connect to the CI Tools activation website, the site could be overloaded, please try again later". It never works no matter when I try.

So basically none of the CADImage Tools / CI Tools work even though I am a subscriber. Anyone have this same issue or any ideas? In the past I have installed CADImage Tools / CI Tools on ArchiCAD 24 on a Mac running macOS High Sierra without issue.

4 REPLIES 4

Ralph Wessel
Mentor
Michael wrote:
So basically none of the CADImage Tools / CI Tools work even though I am a subscriber. Anyone have this same issue or any ideas? In the past I have installed CADImage Tools / CI Tools on ArchiCAD 24 on a Mac running macOS High Sierra without issue.
I'm not aware of any problems of that kind on any AC24 platform to date. I'm using the same configuration at the moment with no problems.

I recommend contacting the support team at <nz.support@centralinnovation.com>. The activation process creates a local log file reporting any problems or errors encountered, and the support team will walk you through the process of providing that info for analysis. Hopefully that data will pinpoint the cause of the problem.

As a general rule, the best way to get a solution to a CI Tools problem is to contact our support team.
Ralph Wessel BArch

Michael Scott
Newcomer
Ralph,

I already tried contacting the support team directly. They pretty much offered no suggestions other than to use the latest installer which I was already doing. They then wanted me to install some software called TeamViewer so they could screen share and control my computer. I try to avoid installing software I am not familiar with on my work computers when ever possible and because of the change in time zones I am usually in the field when they are available. Also I am not sure that doing this should be the first line of support. Any request for other suggestions was simply ignored.

I actually sent them the log file text on my own and they just completely ignored it without acknowledgement. So my experience with CI support has not met my expectations. That is why I am reaching out here as maybe other users have resolved the same issue.

This is the log text I get when I try to activate ArchiCAD 24 (On the same machine CI Tools for ArchiCAD 23 work but ArchiCAD 24 doesn't):

2020-09-03 18:57:28.655063 Starting activation for Doors + Windows v6.25 build 115, serial = XXXXXXX
2020-09-03 18:57:28.655129 License type = Keyplug
2020-09-03 18:57:28.655184 Net license, count=1
2020-09-03 18:57:28.657872 No local license found
2020-09-03 18:57:28.658404 Requesting user activation
2020-09-03 18:57:32.750418 ------ RegistrationDialog::ActivateHandler ------
2020-09-03 18:57:41.708229 Login successful
2020-09-03 18:57:41.708298 ------- requestRegistration --------
2020-09-03 18:57:41.708466 Post request registration
2020-09-03 18:57:42.500406 Response error code: -1
2020-09-03 18:57:42.500477 The server returned an error: "Incorrect code"
2020-09-03 19:02:34.437121 Failed
2020-09-03 19:02:34.437200 ------- requestRegistration --------
2020-09-03 19:02:34.437245 Failed
2020-09-03 19:02:34.437278 ------ RegistrationDialog::ActivateHandler ------

henrypootel
Newcomer
Hi Michael

Thanks for the log - that's very helpful.

We're working on diagnosing the problem still, so we'll be in touch via the support ticket.

Teamviewer is a remote support application that essentially lets us go troubleshooting on problems as if we were with you at your computer - we find it's often that fastest and easiest way to find system anomalies or unexpected conditions that can cause problems, which is why we were suggesting to use it.

However, as it seems that's not an option for you, we'll just continue with the process without that.

Thanks for your patience
Josh Osborne - Central Innovation

HP Zbook Studio G4 - Windows 10 Pro, Intel i7 7820HQ, 32Gb RAM, Quadro M1200

Michael Scott
Newcomer
Following up on this issue, I was able to figure out a way to make it work. So I am sharing it.

I noticed that my built-in ethernet port on my new iMac wasn't working. I didn't think much of it since I was connected via WiFi and an ethernet port on my Thunderbolt 3 hub. This weekend I was trouble shooting the issue which I discovered was somewhat common on iMacs. It was almost as if the drivers for the built-in ethernet didn't load or the built-in ethernet wasn't found. I tried a bunch of things to make it work and I finally got it working by booting off an external drive with a fresh copy of Catalina. Doing this brought the port to life and once I returned to the system on my internal drive the built-in ethernet port was still working. I then tried to authorize the CI Tools and it worked.

I am not sure why the two were linked because I had an internet connection the whole time. But they are. Even more strange is that it worked on ArchiCAD 23 but not 24. So there is some link between the internal ethernet port loading properly and being able to authorize the CI tools. So if this happens to you check if the internal ethernet port loaded properly.

In an follow up from CI they sent me the following:

"Our tools do look at the MAC address of the interface you are registering it on, so they can match up the activation to any existing activations on the same hardware. It sounds like our system was looking for the LAN address, but was receiving the wifi one, so that was killing it."

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!