Collaborate forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Can I change Sketchup export to millimetres ?

Anonymous
Not applicable
Does anyone have the same issue? Whenever I :

1. Export my Archicad model (that is in millimetres) to SketchUp
2. SketchUp opens it in Imperial Feet.

My ArchiCad model is all in millimetres, I NEVER used inches. I need to export many times a day for my colleagues who unfortunately work in Sketchup, so this extra opening every time, click-click changing-units and then downgrading the SU file is a bit annoying.

Is there a button I'm missing? Thanks.
8 REPLIES 8

Barry Kelly
Moderator
There seems to be no options in Archicad when saving as a Sketchup file.

toniski wrote:
... so this extra opening every time, click-click changing-units and then downgrading the SU file is a bit annoying.

Are you saying that they have to adjust the settings in Sketchup and then open (download?) the file?
If so then it sounds like there must be default unit settings in Sketchup itself.
I don't know as I don't have it.
If they just start Sketchup with a new blank file - what units do they have?

If on the other hand their Sketchup opens a new blank file in metric, but when they open the file from Archicad in Sketchup and then have to change the units, I am not sure why this would be.

I would be looking for a default setting in Sketchup.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
In SketchUp, the units a file uses are set inside that file. You have to change the units after you have opened the file, because every file uses its own intrinsic units.

So if the file is set to use millimeters, Sketchup will use millimeters. Whenever I open any file that is newly exported from Archicad, these always open in imperial inches, which means that Archicad by default sets the units inside the SU file to inches. After I have set the units inside the file, it opens fine next time. Until I export a new one. Sometimes we export tens of them a day. ..... Trouble.

Anyone has encountered this issue? Any clue how to get rid of this annoyance? Is it a feature request, as there seems no way to set this in Archicad right now? Or is there?

Barry Kelly
Moderator
When you start a new file from scratch in Sketchup, what units is it in?
Do you have any options that you can set when you open the Archicad file?
I don't have Sketchup so I don't know what your options are.

I am pretty sure that Archicad works internally in meters so I would expect it to open in metric as a default.
I am pretty sure there will be a setting in Sketchup (which if it is USA based software?, will probably default to Imperial) which you need to change - but as I say I don't have it so can't say where it is.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
When you start a new file from scratch in Sketchup, what units is it in?
- Millimeters.

Do you have any options that you can set when you open the Archicad file?
- In Sketchup? I can only use .skp files to open in Sketchup and the files open without options.

I don't have Sketchup so I don't know what your options are.
- Sorry, you need to have experience in Archicad- SketchUp conversion to effectively answer this problem.

I am pretty sure that Archicad works internally in meters so I would expect it to open in metric as a default.
- I suppose it does, but somehow it exports in inches on my PC.

I am pretty sure there will be a setting in Sketchup which you need to change - but as I say I don't have it so can't say where it is.
- Changed. No result. One needs to have Sketchup to solve this issue. Sketchup also has a free version

Anonymous
Not applicable
PCloud link to a test file, exported from Archicad 23 to SketchUp version 8:
https://u.pcloud.link/publink/show?code=XZTBFHXZzuHXME4DEqhIEcPeqHuWeR00kIgX

Laszlo Nagy
Community Admin
Community Admin
The free version of SketchUp is available to all on the web:

https://app.sketchup.com/app?hl=en
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Barry Kelly
Moderator
I will download Sketchup and experiment this weekend.
Unless someone has an answer in the mean time.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Barry Kelly
Moderator
It seems the free version of Sketchup is not a download but a web based program.
So I tried toniski's file and it is indeed imperial (when I had the default Sketchup template set to metric).
It had to be changed in the model info.

So I saved my own test file - definitely using metric in Archicad.
That also came in as Imperial.

And no there are no options for units when saving from Archicad.
So either Archicad does work internally as Imperials (which I am pretty sure it doesn't) or the 'Save As' options are hard coded to save as Imperial.

The only way to save as a Sketchup file that I know of is to 'Save As' from the 3D window and change the file type to 'Sketchup'.
I have not seen any other converters (add-ons) that can be installed that might give more options.
But as I have said I don't use Sketchup so have not really been looking out for anything.

So unless someone else has any info, it looks like you are stuck adjusting the units once you open the file.
Luckily it is only 2 clicks.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!