cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Collaborate forum

DWG Import - Scale Appears Fixed

Anonymous
Not applicable
Scenario: dwg from japanese architect in metric imports at the same scale (or no scale) regardless of any settings in the translator or the scale set in ArchiCAD before import.

Question: is if possible for a dwg to act like a figure/drawing that comes in at the same size? Or am I missing something new in AC10? I have always been able to match the scale either in the translator settings or in ArchiCAD, but I was told that the dwg was produced at no scale. Since I am autocadphobic, I don't understand how this is possible.

I know I can just resize the drawing elements in ArchiCAD or drop it in as a drawing, but I would prefer to import or merge it.
15 REPLIES 15

Anonymous
Not applicable
It sounds like the drawing is in model space (1:1 scale) without a defined scale factor. (As you know I am not a great AutoCAD expert either so this is half educated guesswork.)

Since you say you want to merge the drawing, the simplest way to do it may be to go ahead and place it as a drawing. You can then adjust the scale to what you want and explode it to get editable entities. This will place all the elements on the layer that the drawing is on, which is either a bug or a feature depending on what you want.

Anonymous
Not applicable
Resizing an exploded drawing in ArchiCAD would be an inefficient workaround, given the translation capabilities of AC10. Translations back & forth need to be seemless. The question is: Can you set up a translator for an autocad 1:1 drawing? If not, I would think the solution is to save out the dwg in whatever space would make it importable at the correct scale.

Anonymous
Not applicable
You can resize the drawing without exploding it.

Drawings in model space will always import at 1:1 when placed in a model view. I have seen some AutoCAD users draw to scale in model space. If this is the problem you may have to get them to correct it at their end or be faced with annoying reprocessing on your end.

Otherwise, if the elements are not the correct size this is due to the drawing units selected in the translator. If the drawing unit is one mm but the translator is set to one inch then the drawing will be 25.4 times the correct size

Thomas Holm
Booster
If the drawing is produced in Autocad at "no scale" I'd assume it's done in "model space", that is drawn in "real" units, 1:1 - an item one metre long is drawn one metre long, (or an entity one inch long is drawn one inch long).

In autocad there is a DWGUNIT (drawing unit) that determines dimensions in a drawing. In architectural drawings in my country, where we use metric, the usual setting is 1 DWGUNIT= 1 mm (millimetre). For bigger objects, like site plans, it's often set to 1 dwgunit= 1m (metre). (I understand that a common "imperial" setting in the U.S. is 1 dwgunit = 1 inch)

When you import a dwg into Archicad, you have to know what the dwgunit is set to to get dimensions right. You set it in the translator to the unit of the imported dwg before importing. This is regardless of the units/dimensions of the Archicad file you import into. If the dwg is metric, for example 1 dwgunit = 1mm, you set it like that, even if your Archicad file uses imperial dimensions. This way the translator will give you a correctly sized import.

If you don't know how the dwgunit is set, you either have to ask, or have to guess, test-import and then measure some item of previously known size to check. If there is no such item, you simply have no other option than to ask what drawing unit they use when they draw.

When you import a model space dwg that is drawn 1:1 as it should, scale in effect has no meaning other than for text. If you know what scale the original dwg was intended to be plotted at, you should set Archicad's view scale (lower left corner of any view) to that scale. Then text will look right (the same relative size as it was in Autocad. But drawing entities won't change size because of this scale setting. Size of those is determined by the drawing unit setting!
AC4.1-AC24SWE-25INT; OSX11.5; MP5,1+MBP16,1

Erika Epstein
Booster
Set the DXF-DWG translator { File, file special ] to "for editable input"
Erika
Architect, Consultant
MacBook Pro Retina, 15-inch Yosemite 2.8 GHz Intel Core i7 16 GB 1600 MHz DDR3
Mac OSX 10.11.1
AC5-18
Onuma System

"Implementing Successful Building Information Modeling"

Anonymous
Not applicable
Thomas wrote:
When you import a model space dwg that is drawn 1:1 as it should, scale in effect has no meaning other than for text. If you know what scale the original dwg was intended to be plotted at, you should set Archicad's view scale (lower left corner of any view) to that scale. Then text will look right (the same relative size as it was in Autocad. But drawing entities won't change size because of this scale setting. Size of those is determined by the drawing unit setting!
Thomas, thanks for explaining & confirming that this is typical of the way some firms work. I did get the text to appear at the correct scale, but could not get the drawing elements to change. I have never run into this issue in the US. Would it be too much to ask our japanese partner to save out files for us so that I can set up a translator? If not, we can likely do that here in autocad before placing in ArchiCAD. I would like to set up translators back & forth that will be as automatic as possible, since the ArchiCAD team will grow and this process will be ongoing.

Anonymous
Not applicable
Mabe wrote:
Would it be too much to ask our japanese partner to save out files for us so that I can set up a translator?
If your partner is drawing at 1:1 in model space all you need to know is their drawing unit.

If they are drawing to scale in model space (which is strange and bad - but not unknown) then they will either have to change their practice (and probably learn to use paper space) or the files will need to be rescaled either by them or by you in AutoCAD or ArchiCAD. If it comes down to this you could probably set up an autolisp routine to speed up the process, but this seems quite a pain for an ongoing process. In this case they would also have problems with your DWGs at 1:1.

Thomas Holm
Booster
OK, here's the short version:

DRAWING UNIT or DWGUNIT. It's in Autocad. Ask your Japanese friend what length this unit represents!
He/she must know, or they wouldn't be able to output anything meaningful from their Autocad. If they don't know, ask them to ask their reseller or the person who installed their Autocad.

Then post back and I'll tell you what to do!
AC4.1-AC24SWE-25INT; OSX11.5; MP5,1+MBP16,1

Anonymous
Not applicable
Thomas, the Japanese team is in town and I will do my best to get this info from them or our japanese speaking staff architect who dialogues with them. Our autocad manager who understands the autocad end is also working on this with me, but because you understand both programs, I am hopeful you can help me figure this out. I really want to better understand autocad & what needs to happen since this is our firm's first project in ArchiCAD and seamless interaction is important. (Meeting all day today followed by dinner, so I will post back tomorrow.)

BTW, since you are in Stockholm, do you know my ArchiBud Stig Bengtssen? (He will attest that I'm not as stupid as I may sound.)

Thanks!
Mabe

Thomas Holm
Booster
Mabe wrote:
BTW, since you are in Stockholm, do you know my ArchiBud Stig Bengtssen? (He will attest that I'm not as stupid as I may sound.)
Mabe, you overestimate me. I've never USED Autocad. I've just had to put up with numerous translation issues, first from/to Microstation, then Archicad.

And I know Stig Bengtsson. He doesn't post often, but I think he's a frequent lurcher in ths forum

Finally, I don't think you're stupid either. But we frequent posters sometimes don't express ourselves clearly enough, because we often see more than one possible reason for the troubles people tell about, and try to cover everything in one breath. In your second (I think) post I got the impression that you hadn't got the dwgunit setting from your Jap friend, and since that is crucial, I thought I should stress it. You might however be able to solve this if you can measure something with a known size (use the dimensioning tools) right after a translation test - provided you know what drawing unit setting you used in the translator!
AC4.1-AC24SWE-25INT; OSX11.5; MP5,1+MBP16,1

Anonymous
Not applicable
Thomas, your explanations are quite clear, thank you; I did not provide much detail thinking the issue was simple. My preference is to just place the dwgs as drawings (so I can control the layers). There are several buildings, the tallest is 42 stories, and in the dwg file all plans are on one story (or i guess it's the model space). To make them useful underlays, I like to minimize the necessary drawing elements, put them in a layer, then stack each floor in the appropriate story (to see if the structure really aligns.)

Setting my AC scale at 1:500, I can merge the dwg (or place as a drawing); then resize down by a factor of 1000 to get to the correct scale. There is no translator that I have been able to set that automates the resize. It's really not that big of a deal, but I was perplexed by the fixed scale.

As the design develops and the ArchiCAD plans establish control, this issue should go away (and we'll see what new issues surface.)

So, I will check with our partners and get back to you.

Thomas Holm
Booster
OK. to dig into this issue, the first thing to do is to import the dwg into a clean (empty) Archicad file.
- first create an empty project
- use the layer manager to remove all layers (except the Archicad layer, it won't go)
- use the File > Open command to select the the dwg file. Don't double click or Open it yet
- with the file still selected, select a Translator with the drop-down menu below the file list. I'd start with KEEP INDEX NUMBER
- Now click the Settings... button to the right of the translator name
You get a new dialog. Click Create New - this will let you save your translator as a new list without changing the default settings.
- Call it Test Translator or whatever' and Save
- Now start checking the translator settings. Drawing unit is the first one in the list. Select it, right-click Help, and in Archicad Help, navigate to Index>D>DXF/DWG CONVERSION>Drawing Unit.
Read it.
you can go on like this.
- When you've set all settings you want, click Save Settings & Close, and you'll be back to the file list.
- NOW, click Open.
Try dimensioning something known to check if it's right or scaled. If you did this right, and the japs really drew in 1:1, you should get a correct dimension. Arrowheads and text may be wrong, but their size is set by the scale factor, which should not change the drawing elements.

When you're done, save the file. I would save it as a .mod (module file) and Hot-link it into my project. You can at any time go back and edit this module. When you open the main project again, you should check that the module''s correctly updated if you do.
AC4.1-AC24SWE-25INT; OSX11.5; MP5,1+MBP16,1

Anonymous
Not applicable
Thomas, Thanks for this procedure, but I am pretty familiar with setting up custom translators so that exhanges back & forth can be seamless. I thought there might be some secret handshake that would fix all. For some reason, after re-opening with the drawing unit set to 1mm, the imported elements have decided to change with changes in the scale. I had been having memory issues, so the only difference is that I rebooted. All is well and I thank you for taking the time to elaborate.

Thomas Holm
Booster
Mabe wrote:
All is well and I thank you for taking the time to elaborate.
You're welcome. I'm sorry if I get too excited. But do come back and tell us how you resolved this issue with the Japanese file!
AC4.1-AC24SWE-25INT; OSX11.5; MP5,1+MBP16,1

Anonymous
Not applicable
I have no idea how the issue resolved itself. I have since opened other dwg files and the drawing elements scale correctly. But I have a slightly better understanding of autocad. Of course, I have yet to send any files to Japan....

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!