Collaborate forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Door/Window Scheduling Issues

Anonymous
Not applicable
Hello,

For some reason my NEW windows/doors, being in NEW walls, will not show up in my schedule.

Regardless of the many different parameters I have tried to set for my schedule, I cannot get my new windows/doors to show up. Even just trying the only criteria being Element is Window still hides all new windows.

What do I need to change to fix this issue? Thanks

1 ACCEPTED SOLUTION

Solution
Barry Kelly
Moderator
I am assuming you have created a view for the schedule.
Open the settings for that view and see if it is set to use a renovation filter that shows new elements.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

View solution in original post

10 REPLIES 10

Solution
Barry Kelly
Moderator
I am assuming you have created a view for the schedule.
Open the settings for that view and see if it is set to use a renovation filter that shows new elements.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

View solution in original post

Anonymous
Not applicable
Barry wrote:
I am assuming you have created a view for the schedule.
Open the settings for that view and see if it is set to use a renovation filter that shows new elements.


Barry.
Oh boy did not think of that at all, was just using an old template, must have set up that view incorrectly in the past. Thank you this solves my issue!

Laszlo Nagy
Community Admin
Community Admin
I have experimented with this a little bit and I am pretty certain that there is a bug in AC24 (build 4007 INT FULL).
In the attached ZIP file there is an MP4 video that shows me activating each default Renovation Filter while in the Schedule Viewpoint.
It can be seen that the "04 Change Plan" filter does not display Demo elements, whereas it should display them overridden. It seems that it gives the same result as the "05" New Construction" filter.
Also, after activating the "05" New Construction" filter, which shows New elements overridden, if I then activate the "06 Planned Status" filter, it gives the same result as the "05" New Construction" filter.

This happens both in case I generate a Schedule, then switch from one Reno Filter to another in the Reno Filter Palette or the Quick Options Palette, or if I save Views of the Schedule with each separate Reno Filter applied and then activating those Views one after the other. The bug is occurring in both cases.
I will report this to GRAPHISOFT.

....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
LaszloNagy wrote:
I have experimented with this a little bit and I am pretty certain that there is a bug in AC24 (build 4007 INT FULL).
In the attached ZIP file there is an MP4 video that shows me activating each default Renovation Filter while in the Schedule Viewpoint.
It can be seen that the "04 Change Plan" filter does not display Demo elements, whereas it should display them overridden. It seems that it gives the same result as the "05" New Construction" filter.
Also, after activating the "05" New Construction" filter, which shows New elements overridden, if I then activate the "06 Planned Status" filter, it gives the same result as the "05" New Construction" filter.

This happens both in case I generate a Schedule, then switch from one Reno Filter to another in the Reno Filter Palette or the Quick Options Palette, or if I save Views of the Schedule with each separate Reno Filter applied and then activating those Views one after the other. The bug is occurring in both cases.
I will report this to GRAPHISOFT.


RenovationFilterBugInSchedule.zip
Hey Laci,

Thank you very much for your detailed report!

Here is what I found after testing around with the renovation filters. On tests are done on Archicad 24 INT 4018, so let's assume that this is the default setup coming from the template:

1. 04 Change Plan (or 04 New Construction in previous Archicad version) has Hide Door/Window/Skylight/Opening Symbol enable. This option will hide openings in floor plan. Since it is not there, the schedule thinks that the doors/windows do not exist, thus does not list them. If we want to see the To be demolished doors/windows in the schedule with this filter, make sure to untick this option. I can test this in Archicad 21, which is the earliest version on my machine, but I think the same applies to previous versions as well.

2. After activating the 05 New Construction filter, which shows New elements as overridden, when we then activate the 06 Planned Status filter, it gives the same result as if New elements were overridden. From my experience, sometimes the schedule's data is "cached" somehow. If you do a Rebuild & Regenerate, the schedule will show the correct result with 06 Planned Status filter. I can reproduce it from time to time, but after some refresh, the issue no longer happens.

Please let me know if this explains the situation!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Laszlo Nagy
Community Admin
Community Admin
Hi Minh, I tried your suggestions.
1. In case I uncheck the "Hide Door/Window/Skylight/Opening Symbol" checkbox, the situation is indeed better as the "04 Change Plan" Reno Filter now correctly shows demolished items, correctly overridden in color. This is the case with the "00 Show All Elements" filter as well since the checkbox is checked there as well by default. However, override issues still remain even after I make sure that no Reno Filters have the "Hide Door/Window/Skylight/Opening Symbol" checkbox checked.
2. I still have issues with elements staying randomly overridden after I activate a filter in which a Demo/New element Override is active, then activate another filter in which it should not be, but the override color sticks.
So I think there is more to this. I do not see how it is possible to use the "Rebuild and Regenerate" command in a Schedule. I can only either close the Schedule Window and reopen it (the override stays) or click the Control button at the top left of the generated Schedule and use the "Rebuild Schedule" command (the override stays).
So, in such as case, the only way I can restore the correct operation is if I activate a Filter in which nothing is overridden AND which does not display elements that were previously overridden. So, for example, "05" New Construction" has New elements overridden. I have to now activate "01 Existing Plan" because it has no override and it does not display New elements, then I can activate "00 Show All Elements" and it will show correctly, with no override stuck on the New elements.

So, in summary, I still believe that this is something that should be looked at by development because users cannot be expected to be aware of such convoluted workarounds if the override gets stuck in a Schedule.
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Anonymous
Not applicable
We have been having an issue where the door numbers do not update in the schedule but do on plan. When opening the object it resets and shows correctly. The issue happens randomly, and was not an issue in AC 22 or earlier with the same plans.
We are a project builder and have 180+ master designs which are kept in v22 as we have external consultants we sometimes use who have not made the jump.
Does anyone have any ideas?
David

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
LaszloNagy wrote:
Hi Minh, I tried your suggestions.
1. In case I uncheck the "Hide Door/Window/Skylight/Opening Symbol" checkbox, the situation is indeed better as the "04 Change Plan" Reno Filter now correctly shows demolished items, correctly overridden in color. This is the case with the "00 Show All Elements" filter as well since the checkbox is checked there as well by default. However, override issues still remain even after I make sure that no Reno Filters have the "Hide Door/Window/Skylight/Opening Symbol" checkbox checked.
2. I still have issues with elements staying randomly overridden after I activate a filter in which a Demo/New element Override is active, then activate another filter in which it should not be, but the override color sticks.
So I think there is more to this. I do not see how it is possible to use the "Rebuild and Regenerate" command in a Schedule. I can only either close the Schedule Window and reopen it (the override stays) or click the Control button at the top left of the generated Schedule and use the "Rebuild Schedule" command (the override stays).
So, in such as case, the only way I can restore the correct operation is if I activate a Filter in which nothing is overridden AND which does not display elements that were previously overridden. So, for example, "05" New Construction" has New elements overridden. I have to now activate "01 Existing Plan" because it has no override and it does not display New elements, then I can activate "00 Show All Elements" and it will show correctly, with no override stuck on the New elements.

So, in summary, I still believe that this is something that should be looked at by development because users cannot be expected to be aware of such convoluted workarounds if the override gets stuck in a Schedule.
Hi Laci,

Thank you for the answer!

I tried to reproduce the issue with Graphic Override relating to Renovation in Archicad 22 and 24. It turned out that this issue has existed for a while now, but in my opinion, it's more like a glitch rather than an actual bug. Here is how I reproduce the issue:

1. Draw a wall with Existing status.
2. Add 3 windows with 3 different renovation statuses.
3. Set up 4 renovation filters showing: all windows with no override; only override To be Demolished; only override New; override both To be demolished and New.
4. Save 4 schedule views with 4 different renovation filters.
5. Save the file and reopen. Open all schedule views at least once.
6. Duplicate a To be demolished window.
7. Open the schedule views. They seem to be "wrong" now.

The correct override will be registered when we do a Rebuild & Regenerate (Ctrl+Alt+Shift+R, or available in View > Refresh while holding the Alt key). Placing these views into layouts will also give us the correct result.

I think that there might be a "cache" somehow within the file itself in case the elements in schedule are very similar, in order to speed up the generation process. When we do a Rebuild & Regenerate, the whole model is refreshed and rebuilt, thus the schedule views are corrected.

I attached a file made in AC22 that captures the incorrect state. Please let me know your opinion about this!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
DJ wrote:
We have been having an issue where the door numbers do not update in the schedule but do on plan. When opening the object it resets and shows correctly. The issue happens randomly, and was not an issue in AC 22 or earlier with the same plans.
We are a project builder and have 180+ master designs which are kept in v22 as we have external consultants we sometimes use who have not made the jump.
Does anyone have any ideas?
David
Hello David,

Thank you very much for the report and I am very sorry about the experience!

Could you help us with some screenshots showing what the problem is about? I'm not sure if it's similar, but maybe trying Rebuild & Regenerate will refresh and update the schedules to correct state?

To do a Rebuild & Regenerate, you can press Ctrl+Alt+Shift+R, or it is available in View > Refresh menu while holding the Alt key.

Looking forward to hearing from you!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Anonymous
Not applicable
Hi Minh,
I forgot to post a response. We had been scheduling our doors using the "Element ID" field and when the ID field on the door changed, it would not update in the schedule, or conversely when changed in the schedule it would not change in plan.
After some trial and error we discovered that if we changed the schedule to read the "Hotlink & Element ID" instead, then the numbering remained consistent between the two, even if we could no longer renumber the doors in the schedule (that field is now locked).
I hope this gives some insight to the issue.

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hello,

Thank you very much for the information!

I did a simple test with only 6 doors. All of them are updated correctly when I use the Element ID field to update the doors' IDs, or the schedule is updated according to the change in the plan.

I believe with a much larger file with lots of complex doors, the issue might happen if the update process goes wrong in a certain part. Unfortunately, I don't have such a file with me to test this. If you would like to investigate further, please let me know and we can look into the file to see what might have caused this.

Looking forward to hearing from you!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!