Collaborate forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Doors and Windows incorrectly showing in Revit IFC import to Archicad

Anonymous
Not applicable
Our office uses Archicad and are now working with a consultant who uses Revit. Our consultant is working on a separate building on our site and it would be great if we could get our buildings to read similarly. I'm currently importing her ifc file as a hotlink into our drawings but all her doors and windows are not reading as windows/doors (no jambs, sills, door swings etc). I've attached an image of what I'm seeing. Our consultant is exporting with the Archicad plugin for Revit. I've checked floor cut planes, model view options, tried hotlinking the revit file directly, saving first as a pln before hotlinking...and I'm out of ideas. Any thoughts?
3 REPLIES 3

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Dear Szelyn,

Thank you very much for the question!

I did some research in our database, but could not find anything similar. I will forward your question to our colleagues for further investigation. One thing I would like to ask: which Archicad version are you using?

Looking forward to hearing from you!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Anonymous
Not applicable
Thanks so much! Our office is using Archicad 23. Our consultant is using Revit 20.

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Dear Szelyn,

Sorry for the long wait It wasn't easy, but finally, we figured it out!

Basically, there are two ways to import IFC to Archicad. Parametric (General Translator) and BREP (Exact Geometry).

For the first method (parametric), it shouldn't be a problem, because Archicad should recognize the element as Window/Doors and present it accordingly. However, if we want to import as BREP for more geometrical precision, we can do the following:

1. In Revit, make sure that you tick the Export 2D Plan View Elements checkbox
2. In Archicad, make sure to import IFC Door / Window Footprints. This option can be found in the Import Translator settings, under the Model Filter settings.

I hope this will help you with the issue. Please let me know if you have any further questions!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!