cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Collaborate forum

Exporting to Excel changes certain values

B_E_A_T_
Enthusiast

Hi all,

 

I have an issue when saving a schedule to an XLS/XLSX file. In one column I have article numbers (e.g. "40.20.10."), but when opening the resulting spreadsheet in Excel (or Numbers) for that matter, the points (".") disappear (e.g. "402010"). As this happens in both Excel and Numbers, I assume it is happening in the translation Archicad makes of the schedule...

 

I couldn't find any setting to change this behavior though... 

I am working on a Mac, but opening the spreadsheet in a Windows-environment does not make a difference...

 

Exporting to TXT and importing this result into Excel works fine but is a bit cumbersome...

(òÓ,)_\,,/



www.studiov2.be

Archicad 23/24/25 BE

Rhino/Grasshopper for Mac
1 ACCEPTED SOLUTION

Solution

Hi all,

 

I managed to solve this issue. The ID's that I mentioned earlier were actually Classification ID's (adding a Classification as a Field, and checking "ID only" in the options/settings - the "..." button to the right of this field in the Scheme Settings).

 

I used a Custom Property:

<SPLITLEFT ( Classfication; " "; 1)>

As the classfication has a formatting where the first space in the name is always after the ID (no matter the length) this always works. Data Type is set to "String", so it is 'written' as a string to the Excel (I suppose)...

(òÓ,)_\,,/



www.studiov2.be

Archicad 23/24/25 BE

Rhino/Grasshopper for Mac

View solution in original post

3 REPLIES 3

Lee Hankins
Advisor

Does it make a difference and show the ‘.’ again if you change the format of the column of cells to ‘Text’. It may be excel trying to be clever. 

Lee Hankins
ArchiCAD 4.5 - ARCHICAD 26UKI Intel 3010 and Apple Silicon
macOS Monterey (12.5)

B_E_A_T_
Enthusiast

Hi Lee,

 

thanks for the quick reply. Unfortunately that does not make a difference. Was my first thought as well - also the reason I tested it in Numbers app as well. Even the (apple) preview shows the wrong formatting in the icon... Really strange...

(òÓ,)_\,,/



www.studiov2.be

Archicad 23/24/25 BE

Rhino/Grasshopper for Mac

Solution

Hi all,

 

I managed to solve this issue. The ID's that I mentioned earlier were actually Classification ID's (adding a Classification as a Field, and checking "ID only" in the options/settings - the "..." button to the right of this field in the Scheme Settings).

 

I used a Custom Property:

<SPLITLEFT ( Classfication; " "; 1)>

As the classfication has a formatting where the first space in the name is always after the ID (no matter the length) this always works. Data Type is set to "String", so it is 'written' as a string to the Excel (I suppose)...

(òÓ,)_\,,/



www.studiov2.be

Archicad 23/24/25 BE

Rhino/Grasshopper for Mac

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!