Collaborate forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Multiple units in schedule (imperial & metric)

Johann_P
Enthusiast
I've managed to display both metric and imperial Zone Areas on my plans, but I cant figure out how to show both m² & sq.feet in my schedules.

Can this be done?

ArchiCAD24 - since Nov 2020
Revit - 2005 to 2020
Windows 10 Pro
2 screens: nvidia quadro RTX 4000
1 ACCEPTED SOLUTION

Solution
RandyC
Booster
Definitely a Canadian problem where we have to use both Metric and Imperial.
You can convert Metric to Imperial using expressions then use the expression in your schedules
ArchiCAD 4.5 --- 25 , Win 10 , dual monitors, 64 gb ram,Nvidia GeforceRTX 2080 TI, I-9

View solution in original post

4 REPLIES 4

Solution
RandyC
Booster
Definitely a Canadian problem where we have to use both Metric and Imperial.
You can convert Metric to Imperial using expressions then use the expression in your schedules
ArchiCAD 4.5 --- 25 , Win 10 , dual monitors, 64 gb ram,Nvidia GeforceRTX 2080 TI, I-9

View solution in original post

Johann_P
Enthusiast
Thanks, and yes, a Canadian challenge.....

I can make my way to these menus, but get stuck.
Any change you could help with the next steps?

Thanks!

ArchiCAD24 - since Nov 2020
Revit - 2005 to 2020
Windows 10 Pro
2 screens: nvidia quadro RTX 4000

RandyC
Booster
Start small - try a simple expression like below --- Open property manager - select where you want to store
your expression - name it - ie: wall plates -
on right side enter data type (length)
use expression - add (length of reference line * 3
evaluate will tell you if you make a mistake.
set your classifications

These expressions will then be available for your schedules
Lots written in Archicad Talk about expressions- but I to find them a bit confusing - trial and error
seems to work best for me.
ArchiCAD 4.5 --- 25 , Win 10 , dual monitors, 64 gb ram,Nvidia GeforceRTX 2080 TI, I-9

Johann_P
Enthusiast
Thanks RandyC.

For other users, here the step by step process:

1) In plan view - select all zones.
2) With zones selected, open > Options > Property Manger

In Property Manager
3) Click "New" and give it a "Property Name"
4) Add to Group: should be ZONES
5) Click "Ok"

The new property should remain highlighted.
6) Change Data Type to "Number"
7) Change Default Value to "Expression"
8 ) An "Expression Editor should open.

In the Expression Editor
9) Click Parameters & Properties.
10) Select "ZONES" & "Measured Area" and click "Add"
11) Click the "fx" button and select "Operators" and "Divide". Click "Add"
12) Click the ruler button, select "m²". Click add.
13) Continue with these until it marches the screenshot earlier in the topic.
14) Add the brackets and numbers to match the same screenshot.

Under "Availability of Classifications"
15) Select "Custom", then "Edit" then "Space"
15.1) Under the "Space" tree you can select "Internal Space" and "External Space" and all the sub categories.
I select ALL the sub categories, ie. Access Space, Commercial Space, ect otherwise they don't seem to show in the newly created property

Click "OK" which closes the Property Manager.

Open the Area Schedule's "Scheme Settings" and add the newly created property to your FIELDS / ZONE LIST

NOTE:
Zones MUST be selected in plan when the new property is created.
ArchiCAD24 - since Nov 2020
Revit - 2005 to 2020
Windows 10 Pro
2 screens: nvidia quadro RTX 4000

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!