Collaborate forum
Showing results for 
Search instead for 
Did you mean: 

Problems importing Autocad objects as library parts

Not applicable
I have a problem opening DXF objects as library parts. This problem has existed since version 8. Version 7 did not have this same problem. The problem relates to the DXF object arriving in as a library object incorrectly and slightly jumbled.
I first noticed this problem in version 7.

I was advised to only bring the DXF object in as a "Binary 3D". this worked fine and the object arrived in clean and tidy.
However the same problem is occurring in version 8 and 8.1 despite ensuring the imports are set for "Binary 3D".

Version 7 used a different type of text based configuration file. Version 8 and 8.1 are using a new *.XML type translation file. It seems that the version 8 and 8.1 are ignoring the settings in the translation info box and trying to import the DXF with the GDL option no matter which option I set.
Can any one help????

David Larrew
One thing you might try is to make sure that the elements in AutoCAD are fairly close to the 0,0,0 world UCS origin. The farther away from the world origin the more problems you encounter when importing into ArchiCAD.
David Larrew, AIA, GDLA, GSRC

Architectural Technology Specialist

a r c h i S O L U T I O N S

WIN7-10/ OSX 10.15.7

AC 5.1-25 USA

Not applicable
Thanks for your advice. however the problem is not related to this issue. I am aware of the problems caused by the origin not being in the right place to start with.The object imports fine in version 7 AC so this rules out your suggestion. Once in as an AC object it can be opened by version 8. The problem only occurs if you try to import the exact same object into AC 8 Or AC 8.1. I think there is a fundamental flaw in the coding used by AC to activate the DXF/DWG translators. I think it happened because they changed the import coding for version 8 and 8.1. I have been met with ominous silence any time I have raised this issue with the local agent regarding ver 7 AC.

michael wrote:
I have a problem opening DXF objects as library parts. This problem has existed since version 8. Version 7 did not have this same problem. The problem relates to the DXF object arriving in as a library object incorrectly and slightly jumbled.
One of the problems might be the units; I had the problem if the units assumed in the DWG/DWF and the units set in ArchiCAD were not the same. So, the faces of the model sometimes can be too small, therefore lost in the translation.

Always check your units. The translators in 8/8.1 are more refined and therefore more sensitive than the ones in 7.

There is always the obvious workaround: open it in 7, use in 8/8.1


ArchiCAD since 4.55 ... 1995
HP Omen

Not applicable
That is an interesting suggestion.
I am using the workaround you suggested already but feel it should have been picked up as a problem by now and highlighted in the documentation two versions on .

However on recollection I did note that although the object opens correctly in Ver 7, it did post a dialoge box warning of a problem with units used and scaling. However The object arrived in to ver 7 as a 3D Binary OK after hitting the proceed button and it measures up correctly in AC.

Perhaps I need to experiment with this a little more. I am not sure How I can find out exactly what scaling was used on the original as it was a 3 D DXF object from a suppliers catalogue

Not applicable
I have checked the units issue a bit more closely and I do not think this is the issue. I think the basic problem is as I have suspected before. The problem is that the DXF/DWG translator in AC8 and 8.1 has a flaw in it. The Flaw is that despite two options being available in the translation dialog box (3D Binary and GDL ), the translator ignores the 3 D Binary option and insists on trying to convert a difficult object into GDL script unsuccessfully.
My evidence is in the fact that if I examine the 3 D script window in either translation option it displays miles of complex GDL script. This should not happen if I have selected "3D Binary"

Not applicable
Update on this problem is as follows; I have examined the autocad DXF object I was trying to open as a library part and noticed that it was a paper space object and not model space. I changed this setting in the translator. I then exploded the autocad DXF object before trying to open it in AC 8.1. This time It arrived as a reasonable approximation of the DXF 3D object. It was still not as good as the same object opened with AC 7 but it was useable. So there you have it. It seems the translator in 8 and 8.1 do not do as good a job as AC7 with this object. the next version really needs to have this matter addressed.

Not applicable
i work with Maya, and am trying to export DXF files into AC 8.1, The problem I am having is that some of my small files, will export into AC fine, and some WONT, with the same exact translator settings. i didn't have this problem with AC 8, just after a fresh install of 8.1.... that leads me to believe that it is a translator bug. . Part of my business is product visualization, I use Maya to model the objects, then export to AC 8.1 to create detail drawings, for the manufacturer to produce, so, i'm out in the cold til i find a work around...anyone figure this out?

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!