cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Collaborate forum

Running Archicad over an OSX network

Anonymous
Not applicable
We're having some problems running Archicad on a new Mac OSX network.

The network is setup so that users have roaming profiles. When Archicad loads, a window appears saying that the Cache Library cannot be loaded on a remote drive (it's currently set to the recommended default which is homes:user:library:caches:graphisoft). All permissions are set so that users can read and write to the library:caches:graphisoft folder.
We're also having autosave problems when the autosave folder is set as the default (... library:application support:graphisoft etc...).

Should the cache folder be set to be on the local machine? Does anyone know any unpleasant side effects that might happen if I do this?
9 REPLIES 9

Greg Kmethy
Graphisoft
Graphisoft
I'll have to check if we are using the right default settings on MAC, but AFAIK the cache and the autosave folders are supposed to be in a local directory, and should not be included in the roaming profile.

On Windows only the username/Application Data directory is affected by the roaming profile, which contains the ArchiCAD preferences folder, but does not contain the Autosave and cache folders.

In MAC terms, I think the userhome is carried over to the network, so instead of using the userhome/Library/caches folder, I believe we should use the HD/Library/Caches folder as a default location for cache files.

I'll log that
Gergely Kmethy
VP, Customer Success, Graphisoft

TomWaltz
Newcomer
I've been running Archicad on a Mac network for almost 4 years now, always using Network-based home directories and the default Archicad cache settings without amy problems.
Tom Waltz

Anonymous
Not applicable
We run ArchiCAD10 on a network of OSX Macintosh computers. We would like to configure Wibukey (WkConfig) to allow broadcasting over WAN.
I am able to access the WkConfig status via /serverIP/22347, however ArchiCAD at the remote site (home) cannot find wibukey and returns the error message 'Protection key not found or not valid. (1050017)'.

The instructions for configuration are not clear to me and I'm not entirely sure wibukey can be seen over a WAN with our particular Net3 dongles.

Are your offices allowing wibukey to broadcast over WAN (to specific external IPs?) to allow remote users to access wibukey?

Greg Kmethy
Graphisoft
Graphisoft
It is theoretically possible, if you open WIBU's port on the firewall. If you "see" the wibu server from home, but ArchiCAD can't connect to it, the problem is usually that you have not specified the server in WkConfig. If no server is specified, ArchiCAD will search the subnet for key servers. If you want to connect to a remote key server (not in the same subnet) you have to specify the server(s) in the "Ordered List of WkLAN Servers" in WkConfig. (or on PC, under the Network tab page in the WIBU control panel)
Gergely Kmethy
VP, Customer Success, Graphisoft

Anonymous
Not applicable
gkmethy,

Thanks for your comments. I have opened port 22347 on the firewall.
I have added the server IP (which is only a local IP address) to the WkLAN list of servers. Should this in fact be the 'static IP' as seen from outside our firewall? I am not sure whether 'Local' or 'WkLAN' should be selected.
Do I need to configure the remote computer so that it can see the IP/port? and if so, how do I do this?

If you could advise, it would be appreciated.
gkmethy wrote:
It is theoretically possible, if you open WIBU's port on the firewall. If you "see" the wibu server from home, but ArchiCAD can't connect to it, the problem is usually that you have not specified the server in WkConfig. If no server is specified, ArchiCAD will search the subnet for key servers. If you want to connect to a remote key server (not in the same subnet) you have to specify the server(s) in the "Ordered List of WkLAN Servers" in WkConfig. (or on PC, under the Network tab page in the WIBU control panel)

Greg Kmethy
Graphisoft
Graphisoft
You have to specify the server address in the WkConfig on all client machines. Of course this IP address needs to be the one that is valid and working outside the firewall. You don't have to change anything in the WkConfig of the key server machine.

The options "local" and "WkLAN" tell WIBU where to look for the key. On the server machine (where the key is plugged) this should be "local", as it should scan the USB ports to find the key. On the client machines it should be "WkLAN", since they have no keys attached, they need to browse the network. If you enable both "local" and "WkLAN" on all machines that is also fine.
Gergely Kmethy
VP, Customer Success, Graphisoft

Anonymous
Not applicable
gkmethy

Once again thanks for the clarification. So, in the case of our office network, where there is a server(with Wibukeys) and a few workstations, I did not require any configuration of the Wibukey for the workstations to see the wibukeys on the LAN. But you are saying, that in the case of a remote workstation outside the firewall, I need to load and run WkConfig and point to the IP (in this case the static IP) of our office server with appropriate corresponding ports open, and then the remote machine will see the wibukey? This seems logical, but I'm seeking your confirmation to ensure I have understood. Thanks very much.
gkmethy wrote:
You have to specify the server address in the WkConfig on all client machines. Of course this IP address needs to be the one that is valid and working outside the firewall. You don't have to change anything in the WkConfig of the key server machine.

The options "local" and "WkLAN" tell WIBU where to look for the key. On the server machine (where the key is plugged) this should be "local", as it should scan the USB ports to find the key. On the client machines it should be "WkLAN", since they have no keys attached, they need to browse the network. If you enable both "local" and "WkLAN" on all machines that is also fine.

Greg Kmethy
Graphisoft
Graphisoft
Exactly, you understand it right. This is because if no server is specified in the "List of WkLAN servers"on the client machines, then they will browse the whole subnet for available keys, and connect to any key available. This is very convenient, because you can easily move the key server to an other machine without in the office re-configuring the clients, or a change in the IP address of the server is not a problem. Therefore within the office (within one domain), it is recommended to leave the "List of WkLAN servers" empty.

But if the client machine is not in the same subnet than the server machine, then you will need to specify the address. If one address is specified, then the client will only search for available slots on that specific server. It will not browse the subnet for other keys. If there are more servers specified, then the client will searach for an available key in the order of list.
Gergely Kmethy
VP, Customer Success, Graphisoft

Anonymous
Not applicable
Tom wrote:
We're having some problems running Archicad on a new Mac OSX network.

The network is setup so that users have roaming profiles. When Archicad loads, a window appears saying that the Cache Library cannot be loaded on a remote drive (it's currently set to the recommended default which is homes:user:library:caches:graphisoft). All permissions are set so that users can read and write to the library:caches:graphisoft folder.
We're also having autosave problems when the autosave folder is set as the default (... library:application support:graphisoft etc...).

We are in the same situation. Happy to read we are not lonely (our local seller said we are!).
But we have a problem that seems to happen only by us: most of case, Archicad won't quit, and remains in dock with the little triangle. That let user not logout or reboot the computer. Even a root kill or shutdown don't take effect. The only way to not halt the computer with power button is a shutdown with -n flag (I'm not sure it works always, because I found it only few days ago, but in the case I used it, it worked)
Tom wrote:
Should the cache folder be set to be on the local machine? Does anyone know any unpleasant side effects that might happen if I do this?

I don't know in wich folder (temporany folder or cache folder) are stored autosaved files, but the risk is that if I doesn't reopen archicad after a crash, another user on the same machine will find my autosaved project (and possibly delete it), and if I re-open the project on another computer, I won't find my autosaved project.
Then there are permission issue with no administrative user...
In any case, I tried to put the folder on local disks, setting permissions to R/W for all, but the problem was not gone, so I reseated them back to default location.
This problem is really annoing, but seems nobody can help us if we don't change our office configuration.

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!