Collaborate forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Transparent walls in exported IFC with missing composite dimensions

Bennis123
Newcomer

I'm having a problem with all walls containing openings(doors or windows) turning transparent in exported IFC models. The same walls also lack the dimensions of the composites they contain. The composites of these walls are all listed as "0 mm" under "material" when I open the IFC in Solibri.

 

The project was started in AC21 and is now upgraded to AC25.

Transparent walls of IFC(the selected wall with no openings is displayed correctly):

image004.png

 

 Selected wall displays all composites of wall as 0mm:

image002.png

 

1 REPLY 1

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator

Hello,

 

Thank you very much for the question!

 

I looked into our database and this seems to be an issue on Solibri side. If you open this file in another IFC viewer, like BIMcollab for example, does it fix the issue?

 

If yes, then the following part may help you:

 

The walls shown as transparent are exported as BREP, because they have several cuts at their endings. Because of BREP they can’t have a MaterialLayersetUsage, but only a MaterialList which won’t tell the material of each wall layer. So for these elements we doesn’t have “real” material information and this is caused by the limitation of the IFC2x3 schema.

The appearance of these walls are still controlled by something which is called SurfaceStyleRendering and this information is correctly exported by Archicad.

So in the case of these walls each of them have several BREPs, representing the wall layers, and every BREP has the correct SurfaceStylerendering assigned to it. These contains the AC surface material names, properties like transparency, colour, etc.

Solibri is rendering each wall as one body and is shown with one SurfaceStyle, even in IFC they have more BREP bodies having different SurfaceStyles. In this case Solibri should choose on SurfaceStyle.

 

Possible solutions:

1. In IFC Export Translator, Geometry Conversion, switch the Material preservation mode (IFC2x3 only) to “Explode all elements into parts….”. In this way it will export BuildingElementParts and they will contain the correct materials.

2. Remove the transparent building material from the composites and/or don’t export in IFC the airgaps (turn on "Export only elements Participating in Collision Detection"). This last will “switch” to BuildingElementParts as well.

 

I hope this will give you an idea on how to solve this issue. If you have any further questions, feel free to let me know!

 

Best regards,

Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!