Choose your top Archicad wishes!

Read more
Collaboration with other software
About model and data exchange with 3rd party solutions: Revit, Solibri, dRofus, Bluebeam, structural analysis solutions, and IFC, BCF and DXF/DWG-based exchange, etc.
SOLVED!

IFC character encoding control?

furtonb
Advisor

Hi,

I'm wondering where to set the character encoding for exported IFC files.

An example that has all kinds of non-ASCII characters in it:

in the Floor property "Földszint" gets written as "F\ldszint", whereas in the layer "szerkesztő" gets written and read properly.

furtonb_0-1684850067637.png

furtonb_1-1684850132889.png

 

In the IFC file itself both values look gibberish:

furtonb_2-1684850213815.png

furtonb_3-1684850244992.png

I don't completely understand how to reliably work with it, I cannot find anything in the IFC Translator setup regarding this.

 

Any guidance would be welcome!

...not using special characters would be my last resort.

 

Thank you!

 

(I work with the INT version of AC, but with Hungarian language in many cases – I suspect it could be something with the localisation.)

odv.hu | actively using: AC25-27 INT | Rhino6-8 | macOS @ apple silicon / win10 x64
1 ACCEPTED SOLUTION

Accepted Solutions
Solution
furtonb
Advisor

I realised I haven't posted the solution for this.

Choosing ISO-8859-2 works for the Hungarian characters (Solibri: Settings / IFC Import Settings) :

furtonb_0-1709146681112.png

To look for your own set, this list might prove useful:

https://www.ibm.com/docs/es/aix/7.2?topic=converters-compatible-code-set-names

 

odv.hu | actively using: AC25-27 INT | Rhino6-8 | macOS @ apple silicon / win10 x64

View solution in original post

3 REPLIES 3
JSN
Enthusiast

Afaik there is no such settting. Actually the unicode characters in the IFC look correct. However there is a known issue within Solibri on IFC import. There is an import setting where you can change the character encoding. Should help if you still have those issues ...

Thanks, @JSN ! I’ll take a look at the Solibri import options.

odv.hu | actively using: AC25-27 INT | Rhino6-8 | macOS @ apple silicon / win10 x64
Solution
furtonb
Advisor

I realised I haven't posted the solution for this.

Choosing ISO-8859-2 works for the Hungarian characters (Solibri: Settings / IFC Import Settings) :

furtonb_0-1709146681112.png

To look for your own set, this list might prove useful:

https://www.ibm.com/docs/es/aix/7.2?topic=converters-compatible-code-set-names

 

odv.hu | actively using: AC25-27 INT | Rhino6-8 | macOS @ apple silicon / win10 x64