Collaboration with other software
About model and data exchange with 3rd party solutions: Revit, Solibri, dRofus, Bluebeam, structural analysis solutions, and IFC, BCF and DXF/DWG-based exchange, etc.

Line break in schedules

Karol Lozinski
Participant
Hi! I made a schedule for doors and I have a text field with additional info to each door. Issue is simple - the text is a simple string in which I simply cannot break the lines. Simple enter obviously doesn't work. I also tried \n, \r, \n\, alt + 013, paragraph symbol, all of them - none works. Is there any method to do so?
AC 26 Win 11
9 REPLIES 9
poco2013
Mentor
You did not say what "text/comment/note" field you used -- so can't help there.

However, expressions will accept returns/line breaks in strings and it will show,as such, in schedules. Just link its classification to "doors" for all doors or make a new classification for a specific door.
Gerry

Windows 11 - Visual Studio 2022; ArchiCAD 27
Anonymous
Not applicable
I too have the same problem with the wall schedule.
From the General section I have added a field (custom text) but cannot add line breaks.
I need to do this as I want to list one after another on separate lines each element that makes up the wall
I cannot find the option for "comment" or "note" when I press the "add fields" button
jl_lt
Mentor
Hi all. Same problem here. I added door and window info in the "model" space in IFC categories. The door and window schedule reads it, but presents it in one single line which is unusable. Any options for breaking text into many lines?
jl_lt
Mentor
Hi. I actually solved my issue. I just eliminated the field in the schedule, exited the edition window and then added it again. then in the actual schedule, on the edit text bar, i pressed "adjust text" and it worked like it always does.
JaseBee
Advocate

Just came across this problem (again, ugh) but finally came up with a possible (albeit dirty) workaround.

 

Just add a bunch of spaces... 😞

 

It's not pretty, but I write most things I need to schedule to dedicated properties that only get displayed on a schedule.  So in the properties expression if you just add a bunch of spaces it will stop adding them when it forces the text to the next line in the cell.

 

You could also have the expression recognise a certain character as a line break (and just add the spaces).

 

Just trialling it now, let me know if it works for you.

AC 24 5004 AUS
iMac OSX (10.13.6) 4.2ghz i7
8gb ram/8gb vram

How do you get a return/line break in an expression? Trying to do this inisde a CONCAT function, but did not succeed.

 

--- www.dtabach.com.br ---
AC 24 BR – MacBook Pro 2,9 GHz Intel Core i7 16GB RAM Mac OS 10.14
JaseBee
Advocate

I played around with this idea after my last post and I think I found it didn't work in some instances, but I can't remember what those instances were.

 

Anyway if you schedule a property with something like this... 

 

CONCAT ( "Text1", "                   ", "Text2" )

 

Then all the spaces push the text2 down onto the next line. Text wrap must be enabled in the schedule and the number of spaces needed must exceed the column width (extra spaces don't get added to the next line so go nuts 😛 ).

 

Like I said, real dirty workaround.

AC 24 5004 AUS
iMac OSX (10.13.6) 4.2ghz i7
8gb ram/8gb vram

Is line break enabled in the schedule?
Don't do it with a lot of space

AC27 on window 11
Ben-Abo
Contributor

Hi, I found the solution, if still anyone looking for it.

Just tick Wrap text, in Text style.

Screenshot 2022-07-21 110027.jpg

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!