cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Collaboration with other software
About model and data exchange with 3rd party solutions: Revit, Solibri, dRofus, Bluebeam, structural analysis solutions, and IFC, BCF and DXF/DWG-based exchange, etc.
SOLVED!

Problems importing 3D DWG in archicad, "inoperability > Merge" does not work

Frillex
Advocate

Hello everyone, 

 

A few times a year we receive 3D-DWG from clients. 

And some times when we open them, either as X-ref or inoperability > Merge, 3D objects won't work as they should. 

The same files gives the same problem when trying to open them with eDrawing. (I will attach a screenshot from eDrawings so you can see the problem).

 

Basically 3D-objects from autocad is shown as squares with some texts. The only solution I have figured out is to open the DWG-file in Autocad and "flatten" the file. Then export it again. 

 

I might add that I think it might have do to with some kind of renovation system in Autocad. But im not sure. 

 

Does anyone know how to import such files without using autocad? 

 

Thanks 

Felix 

 

Skärmavbild 2023-09-05 kl. 14.06.10.png

AC 26, OS MONTEREY
3 ACCEPTED SOLUTIONS

Accepted Solutions
Solution
Laszlo Nagy
Community Admin
Community Admin

As far as I know, the only way to bring in 3D DWG is to open it as a Library Part. The Merge command will only bring in its 2D part.

The reason some parts of the DWG do not appear may be that they were created by some AutoCAD 3rd-party Add-On. They can only be properly displayed if the Add-On is also installed in the receiving application (another AutoCAD copy with the same Add-On in it). I think this is why flattening "works" because the 2D/3D generated by the Add-On is converted to native DWG entities so any other application will be able to read it and handle it.

Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27

View solution in original post

Solution

In addition to what Laszlo says (about 3D DWG opening as a library part) ... You can probably use the convert-to-morph functionality to convert the result to morph faces if you need to either edit or assign layers to bits and pieces of it.... 

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

View solution in original post

Solution
Laszlo Nagy
Community Admin
Community Admin

You do not have to load the DWG into a Linked Library or the Embedded Library.

When you use the Open Object command, at the top, you will have the "Browse for File" option. Use that to select the DWG file from your file system.

 

OpenObject-BrowseFor ile.png

 

Also, it appears to me that the default DWG Translator used for import will not bring in 3D data.

So, make sure that you create such a DWG Translator (if no such translator exists, my Ac26 INT does not have one of these) and use that when opening the DWG file as Object.

Here is the important Open setting you need to set in the DWG Translator:

 

OpenObject-DWGOpensettings.png

 

I have not tried these settings because I do not have a 3D DWG file, but hopefully these are the settings that will make this work.

Let me know how it went.

Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27

View solution in original post

6 REPLIES 6
Solution
Laszlo Nagy
Community Admin
Community Admin

As far as I know, the only way to bring in 3D DWG is to open it as a Library Part. The Merge command will only bring in its 2D part.

The reason some parts of the DWG do not appear may be that they were created by some AutoCAD 3rd-party Add-On. They can only be properly displayed if the Add-On is also installed in the receiving application (another AutoCAD copy with the same Add-On in it). I think this is why flattening "works" because the 2D/3D generated by the Add-On is converted to native DWG entities so any other application will be able to read it and handle it.

Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
Solution

In addition to what Laszlo says (about 3D DWG opening as a library part) ... You can probably use the convert-to-morph functionality to convert the result to morph faces if you need to either edit or assign layers to bits and pieces of it.... 

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB
Frillex
Advocate

Thanks you very much Laszlo and Karl, I'm very grateful for your thorough replies! 

I will try this next time we receive a 3D-DWG. 

 

Regard

Felix 

AC 26, OS MONTEREY
Frillex
Advocate

Hello again, 

 

I might have misunderstood you, but I don't quite seem to be able to import it as an object. 

I tried to link the DWG to my library, thought I had done so before, but it doesn't show up in the library list. 

Then i tried the "open object" command (see attached picture). When i choose "open with Archicad" I got the same result as when I merged the DWG. 

 

Maybe I didn't do it right. 

 

Regards

Felix 

 

Skärmavbild 2023-09-26 kl. 10.56.03.png

AC 26, OS MONTEREY
Solution
Laszlo Nagy
Community Admin
Community Admin

You do not have to load the DWG into a Linked Library or the Embedded Library.

When you use the Open Object command, at the top, you will have the "Browse for File" option. Use that to select the DWG file from your file system.

 

OpenObject-BrowseFor ile.png

 

Also, it appears to me that the default DWG Translator used for import will not bring in 3D data.

So, make sure that you create such a DWG Translator (if no such translator exists, my Ac26 INT does not have one of these) and use that when opening the DWG file as Object.

Here is the important Open setting you need to set in the DWG Translator:

 

OpenObject-DWGOpensettings.png

 

I have not tried these settings because I do not have a 3D DWG file, but hopefully these are the settings that will make this work.

Let me know how it went.

Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
Xavi
Contributor

Hello.

 

Thanks to share this information. The settings that Laszlo gave, work.

Many thanks Laszlo.