Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

3D surfaces not aligning

Anonymous
Not applicable
Hi ARCHICAD Wizards,

I am having immense trouble trying to align 3D textures on different objects. In this particular example I have a vertical timber cladding surface. The selected object is a bulkhead element made using the Slab tool. There is a slab above which has the same external surface. You'll see that on the left hand side the timber surfaces are not aligning, but the right hand side it is.

I have tried resetting the origin, reset the texture, flipping the slabs, but nothing seems to work.

Any tips would be appreciated.

Thanks,
Ben
17 REPLIES 17

Barry Kelly
Moderator
When setting the origin you need to make sure you are choosing exactly the same origin position for both slabs (x, y and z position - although z is not so important for a vertical material).
You may have the same 'x' position so the front surfaces seem to line up but if you pick different 'y' position (i.e. further along the side of the slab) then those sides may not line up.

It is easiest if you select all elements you want to have aligning textures and set the origin for all of them at the same time.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
Barry wrote:
When setting the origin you need to make sure you are choosing exactly the same origin position for both slabs (x, y and z position - although z is not so important for a vertical material).
You may have the same 'x' position so the front surfaces seem to line up but if you pick different 'y' position (i.e. further along the side of the slab) then those sides may not line up.

It is easiest if you select all elements you want to have aligning textures and set the origin for all of them at the same time.

Barry.
Hi Barry

I am 100% sure I am selecting the exact same spot. See attached screenshot where I have isolated the two slabs in question. I am resetting both slab's origins at the same time clicking on the corner spot where the purple circle is. See attached.

Prior to that I reset both textures as well.

Barry Kelly
Moderator
It sounds like you are doing it correctly.
Is the element on to p a slab?
It seems to have a cut-out at the side which a slab can't have unless there is a Solid Element Operation in play or possibly a Priority Base Junction with a hidden element.

This is one of those situations where it is hard to say exactly without having the actual file.
If you want you can select those 2 elements in plan, go to the FILE menu > External Content > Save Selection As Module.
Then ZIP that MOD file and attach it to this post.
I should then be able to see exactly what you have.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
Barry wrote:
It sounds like you are doing it correctly.
Is the element on to p a slab?
It seems to have a cut-out at the side which a slab can't have unless there is a Solid Element Operation in play or possibly a Priority Base Junction with a hidden element.

This is one of those situations where it is hard to say exactly without having the actual file.
If you want you can select those 2 elements in plan, go to the FILE menu > External Content > Save Selection As Module.
Then ZIP that MOD file and attach it to this post.
I should then be able to see exactly what you have.

Barry.
Hi Barry,

Thanks that's very generous of you. I am unable to attach the module file to this post as it's larger than the allowed size. I have dropbox-ed it for you in this link:

https://www.dropbox.com/s/uqfhaifonfeq0ro/3D%20texture%20issue.zip?dl=0

Thanks,
Ben

Barry Kelly
Moderator
I don't have exactly the same texture as you but I did see the same problem.

What I notice is the direction of the texture in the plan surface is different for both slabs.
Changing the direction fixes the problem.
Select both slabs and use "Set Direction" by clicking on the underside (or top) of one of the slabs.

Barry.
align_texture.jpg

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
Barry wrote:
I don't have exactly the same texture as you but I did see the same problem.

What I notice is the direction of the texture in the plan surface is different for both slabs.
Changing the direction fixes the problem.
Select both slabs and use "Set Direction" by clicking on the underside (or top) of one of the slabs.

Barry.
Genius!!!!!!!!!! Thank you very much.
What on earth could be the reason for this? Surely the top surface should not affect the side surfaces and vice versa.

Anonymous
Not applicable
Barry wrote:
I don't have exactly the same texture as you but I did see the same problem.

What I notice is the direction of the texture in the plan surface is different for both slabs.
Changing the direction fixes the problem.
Select both slabs and use "Set Direction" by clicking on the underside (or top) of one of the slabs.

Barry.
Now that you have solved the issue of the two slabs, I'm wondering if you could shed any light on this one...which is that I cannot align the texture of the wall under the slab. See attached. There is no "top" surface as such for the wall so i'm not sure what I can do to make this align. I have tried resetting texture, setting the same origin with everything selected, flipping the wall, to no avail. I have also drop-boxed this here:

https://www.dropbox.com/s/d7ak9tcmqvzgwxc/3D%20textuer%20issue%202.zip?dl=0
I have included the jpeg of the texture for you.

Sorry - I should have included this query in the first post as well.
3D texture 3.jpg

Barry Kelly
Moderator
You can either rotate the wall texture by 180° or rotate the slab (all slabs) texture by 90°.

I am not sure why but it seems that the origin is moved slightly for different rotations - even though the same starting point is chosen.

Barry.
align_texture-2.jpg

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Barry Kelly
Moderator
I think the problem is exaggerated with your texture because the start and end planks are cut in half but are not exactly the same width.
So when the texture is aligned one way it will be in a slightly different position when rotated 180°.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
Barry wrote:
I think the problem is exaggerated with your texture because the start and end planks are cut in half but are not exactly the same width.
So when the texture is aligned one way it will be in a slightly different position when rotated 180°.

Barry.
Thanks Barry. I think I got to the bottom of it. I did a bit of photoshopping and painted a big red arrow on this specific JPEG texture then loaded it in and replaced it with the current timber cladding texture I have.

Lo and behold, the arrows are pointing in opposite directions on different walls, which surely would explain why I am having difficulty in aligning this texture.

What determines the direction in which the surfaces are painted on the walls and how can I make them all go the same way? Walls do not seem to be able to "set direction" for 3D surfaces.

EDIT: Nevermind - got it! I just had to reset the texture.

Anonymous
Not applicable

Also, I have had quite a few instances where I'm trying to paint an object with surface and this dialogue box appears. I have searched far and wide and have not been able to find any help on this. Any thoughts?

 

question 1.png

Barry Kelly
Moderator
benjamin_chan wrote:
What determines the direction in which the surfaces are painted on the walls and how can I make them all go the same way? Walls do not seem to be able to "set direction" for 3D surfaces.

EDIT: Nevermind - got it! I just had to reset the texture.
The textures should all be the same direction until you start playing with them.
Reset as you found should put them all back to standard.

You can set the direction for the wall surface.
You just have to click on the front or back wall surface (top and bottom of slab).

Unfortunately the rotate texture is not like rotating an element where you set a rotation base line and then rotate to the angle you want.
With the texture you just click twice (after choosing the surface) to define the angle. Left to right will give you 180° opposite as right to left.
Or you can type in the angle.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Barry Kelly
Moderator
benjamin_chan wrote:
Also, I have had quite a few instances where I'm trying to paint an object with surface and this dialogue box appears. I have searched far and wide and have not been able to find any help on this. Any thoughts?
It is a bit hard to find as there in no index item for 'Paint' or Surface Paint' - you have to know to look for 'Override Surfaces'.

It is just saying that you can TAB key to select all faces or just the one you clicked.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
Barry wrote:
benjamin_chan wrote:
Also, I have had quite a few instances where I'm trying to paint an object with surface and this dialogue box appears. I have searched far and wide and have not been able to find any help on this. Any thoughts?
It is a bit hard to find as there in no index item for 'Paint' or Surface Paint' - you have to know to look for 'Override Surfaces'.

It is just saying that you can TAB key to select all faces or just the one you clicked.

Barry.
Thanks Barry.

I don't seem to have much luck. After I see this little dialogue box pop up, I click to paint it, the new surface appears, but after I move my cursor away, it returns to the original surface.

Anonymous
Not applicable
But then how you deal with this problem?

Anonymous
Not applicable
Have a browse through this thread - may help - it involves building the wall & roof out of composites and using the building material strength
https://archicad-talk.graphisoft.com/viewtopic.php?f=20&t=58221&p=274035#p274035

Anonymous
Not applicable
I did and it did not help, therefore, I wrote the comment .

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!