Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

AC 22 - BUG? MAGIC WAND NOT WORKING PROPERLY WHEN CREATING CONTOUR ON MESH

John Stanford
Newcomer
Hi Everyone, i'm back again with yet another bug (i'll start numbering them from now on i guess)

I was trying to create a terrain model using mesh and adding contour lines onto it by using magic wand (specifically on the contour lines, not in between the lines).

The problems are:
1. in AC22 whenever i add new ridges using magic wand, it always create two ridge lines at the same time even if i only highlight one line at a time.

2. one or both of resulting ridge lines would then be a discontinued ridge line.

3. it makes modeling a terrain with a lot of contour lines (hundreds) even harder to work with

I tried using the same dwg file, same method, no difference whatsoever in AC21, and it worked just as it should, no problem whatsoever (I've been working using this method without any problem whatsoever since AC15)

any clue on how to fix this would be greatly appreciated, thanks in advance

-John
ARCHICAD 22 5009 INT
Rhino 5 SR14 64-bit

ARCHICAD 16-21 INT
Windows 10 Home
i7 6700HQ 2.6~3.4GHz
NVIDIA GTX 980M 4GB
32 GB RAM
1 ACCEPTED SOLUTION

Solution
John Stanford
Newcomer
Just another update on the issue:

The problem occurred specifically in AC 22 when you use magic wand to create ridge, but only if you're using trace & reference (e.g. the dwg is on worksheet, and you're working in floor plan view)

Current workaround is to put everything on the same view (e.g. place the dwg on the same floor plan that you're working on)

Things will get a bit confusing though, because oftentimes, the dwg will contain a lot of geometry, and you can't just hide everything instantly (e.g. using the trace & reference, you can just turn trace off, you don't have to worry about accidentally moving things around etc.)

Hope this quick follow up will be useful for anyone with the same problem, and for GRAPHISOFT to (hopefully) address the issue.

Cheers
-John
ARCHICAD 22 5009 INT
Rhino 5 SR14 64-bit

ARCHICAD 16-21 INT
Windows 10 Home
i7 6700HQ 2.6~3.4GHz
NVIDIA GTX 980M 4GB
32 GB RAM

View solution in original post

10 REPLIES 10

Barry Kelly
Moderator
It is hard to say without trying it on the same DWG file.
Any chance you could attach it here?

This is be an obvious question I know, but are the magic wand settings the same in both versions?

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

John Stanford
Newcomer
Barry wrote:
It is hard to say without trying it on the same DWG file.
Any chance you could attach it here?

This is be an obvious question I know, but are the magic wand settings the same in both versions?

Barry.
Yes, i've checked every possible setting i could think of that might cause the problem, including the magic wand settings, both AC versions were using the same magic wand settings.

I'll try to upload the dwg in a moment for anyone who might be interested in helping to resolve this issue

Thanks for your reply Barry

-John
ARCHICAD 22 5009 INT
Rhino 5 SR14 64-bit

ARCHICAD 16-21 INT
Windows 10 Home
i7 6700HQ 2.6~3.4GHz
NVIDIA GTX 980M 4GB
32 GB RAM

John Stanford
Newcomer
here's the dwg file that i was using in my original post

-john
ARCHICAD 22 5009 INT
Rhino 5 SR14 64-bit

ARCHICAD 16-21 INT
Windows 10 Home
i7 6700HQ 2.6~3.4GHz
NVIDIA GTX 980M 4GB
32 GB RAM

Solution
John Stanford
Newcomer
Just another update on the issue:

The problem occurred specifically in AC 22 when you use magic wand to create ridge, but only if you're using trace & reference (e.g. the dwg is on worksheet, and you're working in floor plan view)

Current workaround is to put everything on the same view (e.g. place the dwg on the same floor plan that you're working on)

Things will get a bit confusing though, because oftentimes, the dwg will contain a lot of geometry, and you can't just hide everything instantly (e.g. using the trace & reference, you can just turn trace off, you don't have to worry about accidentally moving things around etc.)

Hope this quick follow up will be useful for anyone with the same problem, and for GRAPHISOFT to (hopefully) address the issue.

Cheers
-John
ARCHICAD 22 5009 INT
Rhino 5 SR14 64-bit

ARCHICAD 16-21 INT
Windows 10 Home
i7 6700HQ 2.6~3.4GHz
NVIDIA GTX 980M 4GB
32 GB RAM

View solution in original post

A couple of things to try.
1) Run the lines through the line consolidation process (Edit>Reshape>Linework Consolidation), and see if you get a significant number of cleanups.

2) Use the magic wand tool settings so you don't get so many points. Try setting the distance between points to be much larger.

Also, 3) Update to the latest version (5009). May not help, but you never know.
Richard
--------------------------
Richard Morrison, Architect-Interior Designer
AC25 (since AC6.0), Win10

John Stanford
Newcomer
Richard wrote:
A couple of things to try.
1) Run the lines through the line consolidation process (Edit>Reshape>Linework Consolidation), and see if you get a significant number of cleanups.

2) Use the magic wand tool settings so you don't get so many points. Try setting the distance between points to be much larger.

Also, 3) Update to the latest version (5009). May not help, but you never know.

Thank you for your thoughtful reply Richard, here's what i've came up with so far regarding your suggestions:

-I tried point no.1, 2 before my original post, none of those make any difference (also add unnecessary steps compared to the previous method i mentioned)

-number of points and magic wand settings didn't seem to have any effect.

-I updated to 5009 earlier today, didn't fix the problem either



The trace feature is just plain broken right now for creating ridges on mesh.
Thanks anyway Richard, always nice to hear answer from other forum members
-John
ARCHICAD 22 5009 INT
Rhino 5 SR14 64-bit

ARCHICAD 16-21 INT
Windows 10 Home
i7 6700HQ 2.6~3.4GHz
NVIDIA GTX 980M 4GB
32 GB RAM

felcunha
Expert
I've seen this with very complex meshes in AC20. After having created some ridge lines, it stopped doing so.
The solution was to split the meshes into several parts.
Suggestion: try to make a polygon count in the selected meshes only in AC21 and in AC22, how many polygons do you have in your meshes ? Maybe the clue comes from it.
Felipe Ribeiro Cunha

AC 25, OS X Big Sur

Barry Kelly
Moderator
John,
Sorry no answers for you, but I can confirm that you can't magic wand the contour lines in 22 when DWG is placed in a worksheet and used as a trace reference.
It does work in previous versions.

It seems in 22 it is only recognising the space (area) between the lines and not the lines themselves.
The magic wand cursor shows it is selecting just the line, but it still 'floods' the area rather than just following the line.

The only solution I have is to place the DWG in a layer you can turn on/off as required rather than using the worksheet.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

John Stanford
Newcomer
To follow up on this topic, i received a reply with some explanation and workaround in PM from the tech support.

i haven't got the chance to try the workaround yet and may not be able to for quiet some time, so i've asked the tech support to post it here, hopefully soon, so that others with similar problem may be able to try it.

-John
ARCHICAD 22 5009 INT
Rhino 5 SR14 64-bit

ARCHICAD 16-21 INT
Windows 10 Home
i7 6700HQ 2.6~3.4GHz
NVIDIA GTX 980M 4GB
32 GB RAM

Matt Balaam
Contributor
John wrote:
To follow up on this topic, i received a reply with some explanation and workaround in PM from the tech support.

i haven't got the chance to try the workaround yet and may not be able to for quiet some time, so i've asked the tech support to post it here, hopefully soon, so that others with similar problem may be able to try it.

-John
Hi John,

If possible are you able to upload the response from tech support with the possible workaround? We are having exactly the same problem and the 6000 update hasn't fixed it.

Thanks!
AC21 (8002 AUS FULL) | AC24 (4018 AUS FULL)| Windows 10 Pro | Intel Core i7-6700 @ 3.40GHz | 16GB RAM | NVidia Quadro K620

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!