Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

AC25 Guide Lines turn invisible

roderick
Contributor

Hi all, wondering if anyone is having a similar problem.  I'm using Archicad 25 SPA, and specifically on an Apple iMac with a 5K screen if I draw any guide line in an orthogonal direction (pure horizontal or pure vertical) they appear as they normally should, in the dashed orange color.  However, if I draw any guideline in any angle they turn invisible.  In reality, they turn kind of white, so they are not visible against a white background.  The interesting part is that the guide lines are there, so If I change the background color on the screen, they appear, but in a different color, they show kind of pink or light violet.

 

What's even stranger is that this happens only specifically on the 5K iMac.  I tested the same thing on a 2020 MacBook Pro and the guide line behavior is normal, where any guideline at any angle shows in the normal orange dashed line.  I then tested again on a PC computer and also the correct behavior.  I had one of our staff architects test on her 5K iMac (slightly older model) and the behavior is also normal.

 

I then proceeded to uninstall Archicad and do a fresh install, but the behavior is still the same on my particular 5K iMac.

I've come across Archicad bugs before, but this is downright weird !

 

Example with white background:

Screen Shot 2021-09-24 at 21.44.44.png

EXAMPLE WITH DARK BACKGROUND

Screen Shot 2021-09-24 at 21.42.03.png

Roderick Anderson

SARCO Architects Costa Rica

Archicad 25 SPA

2020 iMac 5K - OSX 11.XX (latest)
1 ACCEPTED SOLUTION

Solution
Laszlo Nagy
Community Admin
Community Admin

Have you tried updating your graphics card drivers?

 

You could also go to the "Advanced Redraw Options" page of the "Work Environment" Dialog, and check  whether changing the state of the "2D Drawing Antialiasing" checkbox  or the "2D Drawing hardware Acceleration" slider change anything. These are setting that can influence Floor Plan Display.

....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

View solution in original post

5 REPLIES 5

roderick
Contributor

@Laszlo Nagy  here is a mystery for you.

Roderick Anderson

SARCO Architects Costa Rica

Archicad 25 SPA

2020 iMac 5K - OSX 11.XX (latest)

Solution
Laszlo Nagy
Community Admin
Community Admin

Have you tried updating your graphics card drivers?

 

You could also go to the "Advanced Redraw Options" page of the "Work Environment" Dialog, and check  whether changing the state of the "2D Drawing Antialiasing" checkbox  or the "2D Drawing hardware Acceleration" slider change anything. These are setting that can influence Floor Plan Display.

....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

View solution in original post

Hi Laszlo, good observation.  My results:

  1. Unchecking the "no antialiasing for horizontal and vertical lines" then makes ALL guidelines "not visible" - i.e. they turn white or very light color that is not visible.  If I then change the window background to a dark color, then ALL guidelines look pink.
  2. Unchecking the "Antialiasing for 2D drawing" entirely then corrects the problem, and then all guidelines appear in the correct orange color.
  3. Moving the hardware acceleration slider to the middle option (keeping antialising on) keeps the slanted guidelines in the light color, however for some reason they become more visible if you use a slightly colored background (like a light sand color).
  4. Moving the hardware acceleration slider to the middle option (keeping antialising on) then turns ALL guidelines to the correct, orange color.

For now, my solution will be to keep 2D antialising OFF and keep hardware acceleration ON. 

Since I'm on a Mac computer, I can't update graphics drivers, but my system is current to the latest OS update, so this should have the latest graphics drivers updates.

 

Thanks for the idea, at least this gives a solution for now... but this seems to be a bug specifically related to iMac 5K systems.

Roderick Anderson

SARCO Architects Costa Rica

Archicad 25 SPA

2020 iMac 5K - OSX 11.XX (latest)

Narska
Booster

I’m experiencing the same problem.

Tomasz Mlynarski
New York based Architect

Laszlo Nagy
Community Admin
Community Admin

I am glad that unchecking the "Antialiasing for 2D drawing" checkbox corrects the problem.

I will report this to Graphisoft.

....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Didn't find the answer? Start a new discussion

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!