Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Another Stair Rail Bug?

Brad Elliott
Contributor
After I create a stair rail there seems to be a random point where it no longer takes changes yet they are still in the object. If you look at the attached drawing the rail on the left is the original railing and I'm trying to adjust the rail width. The stair on the right is the same stair picked up with the eyedropper and drawn on that side. You can see that the rail on the right shows the modified rails.
So is there any way to get the original railing to become active or am I just stuck and have to create a new railing and work with it?
Mac OS10.13.6 AC23 USA Full

Hackintosh 4 GHz i7 32gb ram NVidia1060
2 REPLIES 2

Barry Kelly
Moderator
In the railing settings you will probably find a small yellow warning triangle.
This means you have edited one component of your railing and now each segment has its own settings.
Therefore changes you make in the rail settings will only apply to the first segment in the railing - other segments will be unaffected.

You can press the reset button at the bottom of the settings and the entire railing will take on the settings of that first segment.

Or you can continue to select individual components in 3D and edit each separately.

You can also turn on the 'Segments and Nodes' and then select the segment you want to alter.
Then go to the settings in the info box rather than the rail settings in the list box (or whatever it is called).

You can also ALT-click one segment and CTRL-click the settings into another - and also for the individual elements (inner posts, rails, balusters, rail ends, etc.).

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Brad Elliott
Contributor
Thanks Barry, The editing individual components in 3d is what I had been doing and it just flat out quit making changes even though it would accept the new numbers. IE the bar would have the 2" number in the settings but still show as 1/2".

Pressing the reset button worked and seemed to fix the bug so now I can adjust individual components again. I suspect there is some bug buried in the code that is freezing the railing that the reset button clears.

So now the work around on a complicated railing is when the railing freezes eyedropper the frozen railing and draw a new railing adjacent that will show properly. Then select the original railing and reset it which will modify the railing but release the bug. Then Alt and CTRL click from the second railing to the first to get the custom settings back. This way you don't lose the work you have put in on the original rail. If it's a simple rail then it's probably quicker to just Alt click and draw the new one.
Mac OS10.13.6 AC23 USA Full

Hackintosh 4 GHz i7 32gb ram NVidia1060

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!