Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Archicad 24 Update 3 and Archicad 23 Update 4 Released

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Dear All,

We have released the Archicad 24 Update 3 (5000) and Archicad 23 Update 4 (7000). We have created the packages for INT, AUS, NZE, UKI, USA, GER, AUT, ITA and FRA versions so far and they are passed our tests. The Check for Updates feature is enabled, it will notify you about the new updates soon. We will keep testing the rest of the language versions and release them as they pass our quality control.

Update 3 brings new exciting features to Archicad 24. This latest update makes PARAM-O available for users on macOS as well. With PARAM-O, users can quickly create custom objects and building elements — without writing a single line of GDL code or script — thanks to an easy-to-use interface developed with the architect in mind.

Learn more about PARAM-O by reading this article and watching the video below.



Here is the List of Improvements in Archicad 24 Update 3 and Archicad 23 Update 4. The Update installers are available on the Downloads section of our website.

Should you have any questions or feedback, please let us know!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

15 REPLIES 15

DGSketcher
Virtuoso
@Minh. So a month on the build number hasn't changed from the preview release [5000]. Does that mean nothing has been fixed and if we have the preview version we don't need to download again?
Apple iMac macOS Big Sur / AC24UKI (most recent builds)

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hello,

Yes, that's correct! There were no new fixes in the release packages compared to the preview packages. If you have 5000 installed (7000 in case of Archicad 23), it means your Archicad is up-to-date.

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Barry Kelly
Moderator
It seems that since I have updated to 24 build 5000, I have lost the start dialogue.

I thought it might have been something I switched of accidentally, but it has happened on both my PC and laptop.

Anyone else having this problem and how do I switch it back on?


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hi Barry,

Thank you very much for the report!

Am I correct to assume that the start dialogue you mentioned is this one?


If that's the case, we haven't received any similar report so far. When Archicad starts, after the splash screen, what shows up afterward?

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Barry Kelly
Moderator
Hi Minh,
Yep, that is the one.
Archicad starts fine, just with an empty screen - no file.
I then have to go to the file menu to open a file.

I have just updated 23 on my laptop and now it won't start at all (24 still does but without the start dialogue).
Tried to open the Task Manager to see if there was anything there.
Eventually a message popped up to say a program could not start.
Now I just have a black screen!


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

vistasp
Expert
My startup dialog didn't go AWOL but, after loading a recently used file, I got a "Some Add-Ons could not be loaded" error message.

I checked the add-on manager and found an exclamation mark against ParamO (as opposed to Param-O). Made no changes as it could not be removed.

Closed AC and reopened the file. This time around, there was no error message. So all good, but just reporting.
= v i s t a s p =
bT Square Peg
https://archicadstuff.blogspot.com
https://www.btsquarepeg.com
| AC 9-25 INT | Win10 | Ryzen 2600 | 16 GB | GTX 1150Ti |

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hi Barry,

Thanks for the explanation! This is very strange to hear, I asked my colleague and we have never seen a case where the Startup dialog does not appear, but the Archicad interface can still open. May I ask how did you start Archicad: by double-clicking the ARCHICAD Starter/ARCHICAD.exe or by clicking the icon on Start Menu/Desktop?

I will send you a tool called "Sleepy tool" to collect the log at Archicad startup.

The case about AC23 is even stranger. Do you see the AC23's splash screen loading? Does it appear in Task Manager and then disappear? What do you mean by having a black screen in the end?

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
vistasp wrote:
My startup dialog didn't go AWOL but, after loading a recently used file, I got a "Some Add-Ons could not be loaded" error message.

I checked the add-on manager and found nothing untoward. Made no changes. Closed AC and reopened the file. This time around, there was no error message. So all good, but just reporting.


Clipboarder.2021.03.30-002.png
Hello,

Thank you for the question!

This is a known issue with Archicad 24 Update 3 if you have PARAM-O installed before. Please have a look at this article for more information: https://helpcenter.graphisoft.com/knowledgebase/134068/

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

vistasp
Expert
Thanks Minh.
= v i s t a s p =
bT Square Peg
https://archicadstuff.blogspot.com
https://www.btsquarepeg.com
| AC 9-25 INT | Win10 | Ryzen 2600 | 16 GB | GTX 1150Ti |

Barry Kelly
Moderator
mnguyen wrote:
May I ask how did you start Archicad: by double-clicking the ARCHICAD Starter/ARCHICAD.exe or by clicking the icon on Start Menu/Desktop?

I have tried all these methods to start and I just get the blank Archicad with no file or start menu.
If I double click a file it opens fine (of course no start dialogue then).


mnguyen wrote:
The case about AC23 is even stranger. Do you see the AC23's splash screen loading? Does it appear in Task Manager and then disappear? What do you mean by having a black screen in the end?
No there was no splash screen and nothing in Task manager.
Just re-installed 23 and it starts OK now - but still with no start dialogue though.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Barry Kelly
Moderator
Barry wrote:
I have just updated 23 on my laptop and now it won't start at all (24 still does but without the start dialogue).
Tried to open the Task Manager to see if there was anything there.
Eventually a message popped up to say a program could not start.
Now I just have a black screen!

This could have just been a perfect storm - laptop running low on hard disc space, IT playing around with antivirus security settings, and on top of that the update not installing successfully because of these problems.

I have freed up some space and re-installed 23 and all seems good now.
Except there is no start dialogue, straight into the 23 splash screen and opens with no file open.
When I reinstalled I updated to 23 build 6001 and kept a copy of that - it starts with the start dialogue.


So has anyone else on a Windows system updated Archicad 23/24 AUS version to the latest build?
Do you still have the startup dialogue?


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Lingwisyer
Virtuoso
So has anyone else on a Windows system updated Archicad 23/24 AUS version to the latest build?
Do you still have the startup dialogue?

My 23 AUS 7000 works fine so far, no issues. Still have the dialogue.



Ling.
AC18-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200

Win10 | R5 2600 | 16GB | GTX1660

Anonymous
Not applicable
Is there a projected date that Param-0 will be available to SOLO users? Thanks!

Barry Kelly
Moderator
Lingwisyer wrote:
My 23 AUS 7000 works fine so far, no issues. Still have the dialogue.

It seems to be just an issue with my 2 working machines.
At exactly the same time as the updates, we got a new network anti-virus system.
It could be that or just something I have done.
Still investigating.
I am going to try a complete uninstall and re-install and if that doesn't work I will just wait and see what happens with the next update.

I did get my hands on a brand new laptop and that worked fine with the same network ant-virus.
So I am assuming it is something I have done.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Brett Brown
Contributor
Solo has Param-o on a Mac AC 24 Version 5002
Imac, Mojave, AC 20, AC 25 Solo UKI, Vectorworks Architect 2021, Revit LT 2021

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!