cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Design forum

Auto-update slowness

Mjules
Advisor
ArchiCAD is too slow when working on complex architectural projects. The software updates anytime, and I have to wait up to 3 minutes for each update. Each change I make in the drawings corresponds to an update. Solving this issue may help Graphisoft find new clients in very competitive markets like Canada and USA for example.

Other important things are to make old tools like Morph, Curtain Wall, Column, Roof, etc. complete. There are too many incomplete tools in ArchiCAD, and this doesn't help during the architectural and urban design process.
Martin Luther Jules
AC 10-26 (Full)
Asus | 64 GB RAM | Windows 11
17 REPLIES 17

jl_lt
Advisor
Hi Mr Mjules, you can deactivate that annoying automatic updating and it definetely and significantly speeds things up.

Mjules
Advisor
Jl_lt,

Surely? I would appreciate if you could tell me how to proceed to deactivate it. Is it through the work environment?
jl_lt wrote:
Hi Mr Mjules, you can deactivate that annoying automatic updating and it definetely and significantly speeds things up.
Martin Luther Jules
AC 10-26 (Full)
Asus | 64 GB RAM | Windows 11

Laszlo Nagy
Community Admin
Community Admin
Check out the "Update Auto-rebuild Model viewpoints continuously" checkbox in the "Model Rebuild Options" page of the "Work Environment" Dialog.
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

Mjules
Advisor
I just see the features that might help me deactivate it from the work environment. I will try it. I never paid attention to that.
jl_lt wrote:
Hi Mr Mjules, you can deactivate that annoying automatic updating and it definetely and significantly speeds things up.
Martin Luther Jules
AC 10-26 (Full)
Asus | 64 GB RAM | Windows 11

Mjules
Advisor
Many thanks, Laszlo. I appreciate the information!
LaszloNagy wrote:
Check out the "Update Auto-rebuild Model viewpoints continuously" checkbox in the "Model Rebuild Options" page of the "Work Environment" Dialog.
Martin Luther Jules
AC 10-26 (Full)
Asus | 64 GB RAM | Windows 11

bouhmidage
Advisor
8 GB of RAM and without SSD, for AC 24, that's not sufficient,
i'm running AC 24 on a NVME 2.0 , 32 GB of RAM and 6 GB graphics, without any problems,
heavy projects with structural elements imported from tekla ( heavy file )
AMD Ryzen 9 3900X, 32 GB RAM, RTX 3080 10 GB
Archicad 25
Windows 10 professional
https://www.behance.net/Nuance-Architects

Nader Belal
Mentor
@Mjules

Just as @bouhmidage have said your PC specs are just too low, and for Windows reasons you need 32 GB, and preferabiliy 64.
A good friend of mine have once told me that I´m so brute that I´m capable of creating a GDL script capable of creating GDLs.

Mjules
Advisor
Thanks you all for your posts!

I'm going to change my computers and look forward to seeing change in ArchiCAD performance.
Martin Luther Jules
AC 10-26 (Full)
Asus | 64 GB RAM | Windows 11

rob2218
Booster
the "hangup" by deactivating the "auto update" is that heaven forbid you are in a crunch and just go to publish the PDF set....and notice your views are NOT updated.....yer screwed.

Also...auto-update keeps everything current.

I don't know why there's even the ability to NOT auto-update.
silly in my opinion. you ALWAYS want your views...ALL your views...updated at all times.
...Bobby Hollywood live from...
i>u
Edgewater, FL!
SOFTWARE VERSION:
Archicad 22, Archicad 23
Windows7 -OS, MAC Maverick OS

Laszlo Nagy
Community Admin
Community Admin
Rob,

We are actually talking about the Auto-Rebuild of Tabs.
We are not talking about Auto-Update of Views placed on Layouts as Drawings.
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

PVBergkrantz
Advocate
rob2218 wrote:
the "hangup" by deactivating the "auto update" is that heaven forbid you are in a crunch and just go to publish the PDF set....and notice your views are NOT updated.....yer screwed.

Also...auto-update keeps everything current.

I don't know why there's even the ability to NOT auto-update.
silly in my opinion. you ALWAYS want your views...ALL your views...updated at all times.
If you are working with layouting stuff on multiple pages with a couple of facades on each, jumping between pages, moving text, etc its a big pain to have auto update on. But there should be a third option, "auto update on publish".
| AC 25 Int | Win10 | i7-7800X | 32 GB | GeForce RTX 2060 6GB |

Laszlo Nagy
Community Admin
Community Admin
My "Best Practice" is to use the Drawing Manager to check the status of all Drawings and update them as necessary before publishing. That way it can be guaranteed that they will all display the latest state of the project, even if they are set to "Manual Update".
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

rob2218
Booster
LaszloNagy wrote:
Rob,

We are actually talking about the Auto-Rebuild of Tabs.
We are not talking about Auto-Update of Views placed on Layouts as Drawings.
Ok, I see...I get it. the "tabs" that you have open at the time of your work session. I get it. Still......don't have so many tabs "open"....just keep the floor plan tab, or ONE elevation tab or ONE 3d tab and that's it....why have 12 to 16 tabs open for "when" you need to jump into them.....dunno but I've always found that those 'tabs' that are at the top are a bit distracting. Sure..you may say they are convenient but they take up a lot of resource power from your machine.
...Bobby Hollywood live from...
i>u
Edgewater, FL!
SOFTWARE VERSION:
Archicad 22, Archicad 23
Windows7 -OS, MAC Maverick OS

slavapolic
Participant

Hi All,

 

I am having an issue as well, with the "drawing update" when on sheets of layout book. The views update as they always did, I do NOT want to ever have to use the manual update, for many of my own reasons.
However this feels like either an Archicad 25 problem or my new PC problem, as I havent had this issue on my old inferior pc, while using Archicad 24.

The current/new PC is a Dell Precision 7920 Tower XCTO Base with

Intel(R) Xeon(R) Silver 4210R CPU @ 2.40GHz 2.39 GHz
 64GB 4x16GB DDR4 2933MHz RDIMM ECC Memory
NVIDIA Quadro RTX4000, 8GB, 3DP, VirtualLink (XX20T)
and  M.2 1TB PCIe NVMe Class 40 Solid State Drive 

Please help, this is extremely irritating, every new layout i open, i need to first stand by for a couple of minutes.

Laszlo Nagy
Community Admin
Community Admin

You activate a Layout and you have to wait for a couple of minutes for placed Drawings to update? That sound extremely long. Those placed Drawings should update within seconds, not minutes.

Can you show one such Layout and show how a Drawing that needs so much time to update looks like placed on that Layout?

....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

slavapolic
Participant

Hi Laszlo,

not a couple of minutes (I exaggerated, apologies), however, more than 10 seconds. I dont want to be a primadonna but even 15-20 seconds is too long if you need to be shifting through a set of layouts, am i wrong? I dont have this issue on other pc's so Im hoping its just a matter of a hidden setting as this pc is superior on paper.

slavapolic_0-1655739966507.png

 

Laszlo Nagy
Community Admin
Community Admin

What are those colorful things on the right side of the Layout? Are the schedules placed as Drawings on the Layout? If they are, I wonder if that is the cause of the slowness. Archicad probably has to regenerate the Schedules every time and then update.

 

If you want to investigate a little bit you can try things like:

1. Delete all Drawings that come from Schedules, and see how fast the update is.

2. Delete the Drawings that come from Floor Plans, and see how fast the update is.

That way you may find that one or the other causes most of the update time.

 

Also, you said that you don't have this issue on other computers. Are you saying that if you work on this exact same file on another computer with the same Archicad version, your Update times are much faster? If so, there is probably something specific to this computer that causes the slowness.

....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!