Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Custom Door Panel

TracyGA
Participant
Has anyone had issues creating a custom door leaf in ArchiCAD 19? My coworkers and I have been trying to create one, but the door tool will not recognize the library part and gives us no options for a custom door.
21 REPLIES 21

Karl Ottenstein
Moderator
Works fine for me. Either usage error ... or some issue with the particular door that you're using.

Create your door leaf flat on the ground and then save as a door leaf object via the menu in the screenshot here...
Screen Shot 2015-08-08 at 1.06.49 PM.png
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.1, iMac Pro

Karl Ottenstein
Moderator
Then, select custom as your door leaf type in the door object and your available leaf objects should be visible as seen here.

I saved this test leaf to the embedded library...
Screen Shot 2015-08-08 at 1.06.19 PM.png
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.1, iMac Pro

Matthew Johnson
Booster
TracyGA, We are having similar issues with custom door panels. Panels that worked in 18 have worked in 19 for a few weeks and are no disappearing from projects and no longer available in the library part drop menu.

It might be an incompatible library part but I haven't added any new leafs to cause a new conflict and am yet to find the part causing the issue.
Matthew Johnson - P O W E . Architects
AC25, Windows 10 64bit
Dell Precision 5520 i7 w/ Nvidia Quadro M1200 4K dual
I'd rather be sailing.

Anonymous
Not applicable
I am having similar issue. The custom door list doesn't show up in AC18. I tried to reload library, re-create door, opening in AC19 but nothing is working. But it is working perfectly if I create a new PLN file in either AC18 or AC19.

The PLN that having issue with custom door list is actually migrated from AC16. I guess that could be issue.

Matthew Johnson
Booster
We have been working with tech support on this over the past week and may have uncovered an answer.

When you create a custom door leaf library part and select the subtype of "Custom Door Leaf" it automatically creates some default variables two of which are "coll_guid" and "coll_name". I believe that these are to identify a door panel collection. By default they are given values that up till V18 didn't seem to matter. (In the screen shot below are the default values on a freshly created door leaf object that I have done no editing to.)

In 19 they appear to cause an error and will not let the leaf show in the door library part drop down menu. If we set the values of these variables to "0" the leafs become available.

I'm still working with GS HQ on why this happens and will try and post again here once we know the deeper meaning to it all.
Matthew Johnson - P O W E . Architects
AC25, Windows 10 64bit
Dell Precision 5520 i7 w/ Nvidia Quadro M1200 4K dual
I'd rather be sailing.

Katalin Borszeki
Graphisoft
Graphisoft
Hi All,

This problem (as Matthew Johnson pointed out) is usually caused by the „coll_guid” and „coll_name” parameters. These parameters are present in Custom door panels by default, but the value of the parameters should be empty. If the values are not empty, it will be considered to be a door leaf collection, and ARCHICAD will try to load all the door leaves from that single object (and as a result, no leaves will be available).

By default, if you create a custom door leaf from scratch (either using GDL, or Save As...>Door leaf), these fields should be empty, so If you encounter such an error, please let us know how you achieved such a faulty state, so we can see if there’s an error here:
- What method did you use to save it? (GDL, or Save As, etc)
- Have you created them with the current version of ArchiCAD, or did you migrate the project/library from an earlier version?
- Are there particular steps you did before the door leaves went missing?
- Have the leaves gone missing in a Teamwork project, or in Solo?
- Do you have a before and after state file?

Thank you,
Katalin Borszeki
Implementation Specialist
GRAPHISOFT

http://helpcenter.graphisoft.com - the ArchiCAD knowledge base

Anonymous
Not applicable
This is an ongoing problem with MAC users to which no one seems willing or able to fix a problem with what they are calling "not their issue" because they are "custom objects" and they "don't support custom objects"!!! Our firm only uses custom door panels because the stock are so... not in style anymore.

Here is how I see the problem. It started with 19, but if you loaded the 18 library the door panels worked. Then 4011 happened and that didn't work anymore. I had hoped they would have fixed this by now.

As a firm we are contemplating requesting a refund an going back to 18.

Katalin Borszeki
Graphisoft
Graphisoft
Hi Utahben76,
As Matthew Johnson mentioned, there are two parameters in the GSM of the object that should only be filled in case it's a door leaf collection. For some reason, these parameters get filled out in certain cases in the custom door leaves as well. (this might be caused by an Add-on you use to create these door leaves). You can fix the issue by opening the GSM in GDL editor, and setting the parameter values to 0. See picture attached for details. Are you by any chance using a CADimage Add-on to create these door leaves? If the problem persists please answer our questions in the previous post so that we can investigate the matter further!! Thanks, k
Door Collection.png
Katalin Borszeki
Implementation Specialist
GRAPHISOFT

http://helpcenter.graphisoft.com - the ArchiCAD knowledge base

Anonymous
Not applicable
Katalin,

I tried to open the gdl scripting and set it to 0 bit it was already set to 0.

- What method did you use to save it? file/libraries and objects/save selection as/door leaf
- Have you created them with the current version of ArchiCAD, or did you migrate the project/library from an earlier version? current
- Are there particular steps you did before the door leaves went missing? upgraded to 19, but if you loaded 18 library they worked. But not after 4011 or 4013 hotfixes
- Have the leaves gone missing in a Teamwork project, or in Solo? both
- Do you have a before and after state file? no

vfrontiers
Contributor
Yes... I've had this problem since 19 (perhaps even before)... but in my case, not only a newly created leaf does not appear, but NONE of the previously selectable leafs appear either... the menu is blank...

Originally talking with tech support suggested that if I had TWO leafs named the same it would cause the BLANK MENU issue. So I have been trying to delete duplicate names (and you have to go find these... they don't show up in the object duplicate lists)...

That work for a while (maybe until next time I opened the file) then came back... it will be in ONE FILE then not (available) in another...

This all happens AFTER a successful session... in other words, I create the leaf (in one example a custom garage door).. I produced elevations and 3d views... next time I open the file, the door leafs disappear and the menu is blank.
Duane
Visual Frontiers
AC22 6021:|: AC24 4007:|: Enscape3:|:TwinMotion
DellXPS 4.7ghz i7:|: 8gb GPU 1070ti

vfrontiers
Contributor
BTW.. all of my custom door leafs are SLABBIES saved as DOOR LEAF..

Sometimes to EMBEDDED, mostly to OFFICE or PROJECT LIBRARY...

Oh yeah, and they are usually TEAMWORK files... so I have to do the whole REFRESH business..
Duane
Visual Frontiers
AC22 6021:|: AC24 4007:|: Enscape3:|:TwinMotion
DellXPS 4.7ghz i7:|: 8gb GPU 1070ti

Anonymous
Not applicable
Jeff at tech support finally figured the door leaf issue out! For us at least. In our office library we had some door objects that had macro issues that were interfering with all the other door leafs. I found them by unloading the library and reloading it folder by folder then, object by object, all the while checking a door with a custom panel to see what objects made the panel disappear. Good luck to the rest of you! Hope this works.

vfrontiers
Contributor
Wait, there has to be more than that! Was there anything OBVIOUS about these objects that had to be removed? We're they YOUR objects? Third Party or GS? Why do they work sometimes but not all the time? ( I suppose it could be based on what libraries I have affiliated to which project, but for the most part, all my projects work off the same library set?

Don't mind looking for NEEDLES as long as I know which HAYSTACK to look in.
Duane
Visual Frontiers
AC22 6021:|: AC24 4007:|: Enscape3:|:TwinMotion
DellXPS 4.7ghz i7:|: 8gb GPU 1070ti

Anonymous
Not applicable
We're having the same or a similar issue... For some reason all of our custom door leaf doors a defaulting to a custom door but not the right custom door and when we try to load the correct custom leaf the tool goes blank and nothing can be changed...

There has to be a fix from GS on this...

Katalin Borszeki
Graphisoft
Graphisoft
Hi All,
Unfortunately we didn’t get an answer from Steve when we contacted him to investigate his issue and could not confirm if the same works for him as for utahben76. best, k
Katalin Borszeki
Implementation Specialist
GRAPHISOFT

http://helpcenter.graphisoft.com - the ArchiCAD knowledge base

Anonymous
Not applicable
Sorry.. I lost track of that private message... Been Busy... In the end I'm not certain sending you the file will help... We found a way around it... We happened to have that door in another project as well that worked so I copied a door with the correct attributes from the project that it worked in to the project it didn't work in and that fixed it...

sorry for the delay.

Katalin Borszeki
Graphisoft
Graphisoft
Thanks for letting us know!
Katalin Borszeki
Implementation Specialist
GRAPHISOFT

http://helpcenter.graphisoft.com - the ArchiCAD knowledge base

Anonymous
Not applicable
We are experiencing similar problems in one project file:
Custom door panels that have been both drawn and saved within the project file worked at first. When reopening the project all custom door panels are missing. The drop-down menu in the object editor window is empty and not even new saved panels are shown. Custom panels are listed in the library editor but with 0 placed objects.

Checked that both "coll_guid" and "coll_name" values in all door panel objects are set to 0.

Running MAC, ArchiCAD 19 7014.
Original project file migrated from 18 9019, but custom panels made in 19.

Anonymous
Not applicable
Any update on this issue?
Something similar is happening with me in 22, but not only with custom door leaves, but also with custom cw panels

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!