Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Downloaded Objects have large dimensions, how do i fix that?

I have been trying to build an object library using items downloaded from the website Formfonts.com. I'll relay my entire process, even if some steps are not relevant to my exact problem.

Ok, here it goes. I'll download the object from Formfonts as a DWG. I then go into archicad, open the object and save it to the embedded library. After that, I go back into the object to place a thumbnail, and clean up the 2d object. I do this because we are placing the object into floor plans, and most of the time the 2d image is way too complicated. All of this goes off without a hitch. I am running into problems with the size of the object. For example, I have downloaded a coffee table, and when I open the object in archicad, the dimensions are something like 77' x 73'. Yes, that says feet and not inches. Simply altering the dimension does nothing. I'll save it, re-open the object, and the dimensions will be back to the 77x73. I have gone into details and made sure the box which says "fit size to 2d symbol" is checked. I have also made sure the 2d symbol is the proper size. This works to an extent, but then the 3d object remains enormous. I can manipulate the object after it has been placed into a drawing, however we want to be able to place this object without having to manipulate it. This will save us time and create a graphic standard. How can I fix this problem?
11 REPLIES 11

Erika Epstein
Contributor
Hard to tell from your screenshot where the problem is. Usually the first thing I'll try is dividing the dimensions by 12 to see if the dwg unit translator is off; using a foot instead of an inch or vice versa. I get 6.4' x 6'; I don't know the dimensions of the table, but does that sound right?

Google-ing the title of your object, I see the design is all rectilinear, see attached image. This would be very easy to model with slabs and then save as an object. Drag a fill the size of the top into the 2D window and then you can set a masking pen so you don't see the floor below. Take a look at the GDL beginner guides, specifically David Nicholson Coles Cookbook, and version will suffice for what you are doing. A search here will provide some links to the online version.

HTH
days-forum-square-low-table-habitat-designed-robin_forum_table.jpg
Erika
Architect, Consultant
MacBook Pro Retina, 15-inch Yosemite 2.8 GHz Intel Core i7 16 GB 1600 MHz DDR3
Mac OSX 10.11.1
AC5-18
Onuma System

"Implementing Successful Building Information Modeling"

Thanks Erika for the reply.

If I had more time I would model the object, but unfortunately that is not the case. I'm downloading the models so I don't have to model them myself.

Anyway, I liked your suggestion by dividing by twelve to get a different dimension, but if I were to change the dimensions from the screen shot (~77x73) to 6.4'x6' they will just change back after saving them. I wish I could just change the dimensions, it seems the most logical solution, but in the end it ends up doing nothing.

Is there another screenshot that I could send that may show my problem more effectively?

Thanks again for replying.

Erika Epstein
Contributor
You misunderstood. Which ever translator you used, set the unit to inches rather than feet or vice versal
Erika
Architect, Consultant
MacBook Pro Retina, 15-inch Yosemite 2.8 GHz Intel Core i7 16 GB 1600 MHz DDR3
Mac OSX 10.11.1
AC5-18
Onuma System

"Implementing Successful Building Information Modeling"

Laszlo Nagy
Community Admin
Community Admin
The other possible thing to try is to divide by 25.4, since 1 inch = 25.4 millimeters.
Then you would have a coffee table with dimensions of about 3 feet by 3 feet which also sounds about right.

So maybe in your DWG Translator, the conversion unit should be set to 1 millimeter instead of 1 inch.
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Thank you both for your replies. I have spent time in the translator options and have yet to figure it out. Can either of you present specific steps that will help me?

Also, if/when I fix these objects through the translator, will the size permanently be saved. For example, now I can go in and easily change the size of that table to 3' x 3', but if I place that object again, it will be 76'x77'. Once the proper size is obtained, will it be permanent?

Thanks again for the help.

Erika Epstein
Contributor
When you import them, if you are using the 3ds translator

File>File Special> Import 3Dstudio file

set the SCALE from mm to meters
Erika
Architect, Consultant
MacBook Pro Retina, 15-inch Yosemite 2.8 GHz Intel Core i7 16 GB 1600 MHz DDR3
Mac OSX 10.11.1
AC5-18
Onuma System

"Implementing Successful Building Information Modeling"

Laszlo Nagy
Community Admin
Community Admin
The opening post says it is a DWG file.
In that case activate File\File Special\DXF-DWG Translation Setup menu command and in the Dialog, select the Translator set as default for import in the Available Translators panel at the top. It is usually the 02 For editable import Translator. The icon next to its name shows. Then go to the Settings in Selected Translator panel and select 1 millimeter as value in the Value of 1 DXF/DWG Drawing Unit in ArchiCAD field.
Save Settings and Close, then import the DWG.
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Laszlo,

I tried the suggestion you made on March 19th and it does not seem to be working. There were some issues though...

First, none of the Available translators were available for editing. They were all locked (including the one you mentioned; 02 for editable imports). Therefore I could not access the options below. The only translator I could access was the "special built in translator" but all of the options are also locked, but i can at least look through the options. I tried duplicating that translator, and then went into the setting and changed the value of 1 to 1 millimeter, but that didn't seem to work when I opened the object. I still got a 70' coffee table.

Is there a way to unlock the other translators? I am using Archicad 14. Also, if I duplicate the special built-in translator, can I edit the options to mimic those of the 02 for editable imports translator?

Thanks for trying to help me out.

Barry Kelly
Moderator
You should be able to duplicate the "02 for editable imports" translator as well.
Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Laszlo Nagy
Community Admin
Community Admin
Besides duplicating, you can see in the Location field the exact path to the XML files containing the given Translator.
It is possible that the XML file got set to read-only and this is why it appears locked in the Dialog. At least this is how it works on my computer.
You can uncheck the read-only checkbox in the Properties Dialog of the XML file in Windows Explorer. Then, if you leave the DXF-DWG Translator Dialog, then come back, the given Translator should not be locked.

Why it got set to read only? That is a good question.
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Awesome! Thank you guys! I finally got it to work. Here was the issue. When I tried to alter the DWG translator settings, I was not allowed to click or even duplicate the "02 for editable imports". Upon clicking the only item I could, I discovered that the location of the file was for a different computer user. I have my own login and password for this computer. There is an administrative login as well. Archicad is loaded on the administrative side. Therefore, I could not go in to change the settings for the DWG Translator. I simply logged into the administrative side and everything works great. Thank you so much for helping me!

Best,

Will

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!