cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Design forum

Grasshopper – Archicad Live Connection not working on M1 iMac

zeyi
Participant

I am using Rhino7 and Archicad25 on M1 iMac. After Start Connection, the connection status is green and there is no error information shown in Grasshopper, but no models are generated in Rhino or Archicad, and the material or favorites pop-up window could be not loaded.

 

However, everything is fine on my older 2015 Macbook. Is there a compatibility problem for Live Connection with M1 Mac?

15 REPLIES 15

I am experiencing the same problem. Any update from Graphisoft? It seems that they have absolutely not interested in making the Archicad Grasshopper Connections stable and an usable product. Seems to be always in a Beta State.

Archicad 26 ARM, MacBook Pro M1 Max 64Gb, macOS Monterrey.

Gastmanator
Participant

I have the same problem. Archicad 24, Rhino 7, macOS Monterey. The connection is established, status is green but no data is exchanged. Even between Rhino and Grasshopper - elements from Archicad tab in Grasshopper are not visualized in Rhino.

Do anybody have idea where the problem is? 

Mario Sacco
Enthusiast

Same problem on M1 Max Powerbook

MacBook M1 Max 64GB- OS X 12.2.1 - Archicad 25
https://www.archiradar.it/en/

Mario Sacco
Enthusiast

here the solution suggested by George from Enzyme, tested with few components

It works with AC24 and AC25 on M1 MAX Powerbook

 

If you have a brand new mac, and install Rhino 7 only, there was a bug in the GHAC that refers to the wrong Plist file.
To solve the issue, we need to navigate to
/Users/<username>/Library/Preferences/
then rename the PLIST: "com.mcneel.rhinoceros.7.plist"
to: "com.mcneel.rhinoceros.plist"
Please note that the Library folder inside userhome is a hidden folder. You can follow this guide to access it:
https://www.lifewire.com/os-x-is-hiding-your-library-folder-2260833

 

https://community.Graphisoft.com/t5/Design-forum/Grasshopper-Archicad-connection-not-connecting/m-p/...

MacBook M1 Max 64GB- OS X 12.2.1 - Archicad 25
https://www.archiradar.it/en/

bauart
Participant

Amazing! Thanks @Mario Sacco for your answer! I tested it and seems to work for me! Great! I was quite disappointed with Archicad support/ Graphisoft, which was saying to wait for an eventual update with AC26... Quite nice that it can be solved very easily! 😄

The work around renaming the plist file seems to solve the connection issue, but my Archicad crashes just by linking a morph into the grasshopper connection. I am using macOS 12.3.1 on an MacBook Pro M1 Max 32gb. I have tried reinstalling everything from scratch, but still get a very unstable connection and an unsuable workflow. Please resolve this.

Archicad 26 ARM, MacBook Pro M1 Max 64Gb, macOS Monterrey.

Hello,

 

Thank you very much for the report and I am very sorry to hear about the issue!

I started with a new file but couldn't reproduce the issue. I'm wondering if this happens with any file, and if yes, could you please let me know the bugID number when Archicad crashes?

 

Looking forward to hearing from you!
Best regards,

Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Alois Rosenfeld
Contributor

Hello,
I can relate to the problem of @Jaime-airc_digital . After reinstalling everything, and also renaming the .PLIST as mentioned above, my Archicad Crash, even for a new file containing only a hatch. Here is the Bug report that I submitted to Graphisoft: AC25-2022-08-09-13-33-31-6860
I was in contact with local Reseller Abvent and IDC, they said they could do nothing for me and I should get in touch with you (Graphisoft) directly.
Please note that I works well with Archicad 24. Could you give me assistance please?

macOS Monterey 12.5 | Archicad 25 Build 5010 | Rhino 7 | Live Connection 25 | MacBook Pro M1 Max 64GB

Hello Minh,

 

Thanks for your reply, here is the Bug ID I just generated replicating the crash:

AC25-2022-08-10-08-41-53-8301

MacOs, Archicad and Rhino 7 are all updated to their latest versions and Archicad crashes just when trying to select in Archicad a morph to deconstruct from Rhino.

Archicad 26 ARM, MacBook Pro M1 Max 64Gb, macOS Monterrey.

Hi @Jaime-airc_digital and @Alois Rosenfeld 

 

Thank you very much for sharing the report! I checked both crashes and they are identical. Thanks to Jaime's comment (deconstruct a morph), I was able to reproduce the crash, but the strange part is the crash modules in my case are totally different from yours. I have entered defect DEF-10281, however I strongly suggest reaching out to your local support for further investigation, as they will be able to contact our developers for confirmation of the problems.

 

Thank you once again for your finding, and I am very sorry for the issue!
Best regards,

Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

HI @Minh Nguyen ,


Thank you very much for your answer. 
As mentioned above, I already made everything I could do to communicate this issue to local support. But they are categoric: They can't do nothing on their side, and I should directly ask Graphisoft to investigate further.
Please, I already mentioned this issue to local resellers (IDC & Abvent) 7 months ago, and nothing improved. They only told me that I should hope that with Archicad 26, it should be fixed again, which is not satisfactory as an answer.
I am available if you want to have a direct chat about it. 
I really hope that the defect DEF-10281 will be investigated by the Graphisoft team directly.

Best regards,

Alois

ESQ-AR
Participant

Does anyone know why this error happens on Mac?
What happens is that I need to use rhino-grasshopper and make the live connection with Archicad 25-26, I download and install the live connection plug-in and when doing something in grasshopper it is not reflected in Archicad, however, Archicad does recognize that there is a connection. I have already tried to test different versions and I have also installed the live connection plug in for each version they all have the same error.

In a post on this forum, I found that a possible solution was to modify the name of the file found inside the path /Users//Library/Preferences/) and rename it from:

com.mcneel.rhinoceros.7.plist to com.mcneel.rhinoceros.plist

But this didn’t work. Below are some images of what happens. I thank you in advance for your help.

 

Captura de Pantalla 2022-10-20 a la(s) 4.54.30 p. m..pngCaptura de Pantalla 2022-10-20 a la(s) 4.51.10 p. m..pngCaptura de Pantalla 2022-10-20 a la(s) 4.52.39 p. m..pngCaptura de Pantalla 2022-10-20 a la(s) 4.52.26 p. m..png

I used to experience this problem, but it got sorted with the latest update of the connection. Have you tried that? I am in MacOS Monterrey and using AC 26, not sure if being in Big Sur may be a factor on your issue.

Archicad 26 ARM, MacBook Pro M1 Max 64Gb, macOS Monterrey.

Yeah. I tried to install and uninstall different versions of Archicad (24,25,26), also I install and unstall the connection with rhino-grasshopper for rhino (7,6) depending on the connection that exists for each version as stipulated in Graphisoft but the error continues as seen in the images.

ESQ-AR
Participant

This some videos with the problem:

 

https://we.tl/t-G4m42NUs0H

Didn't find the answer? Start a new discussion

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!