Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

How can I change the default fill for object library?

Anonymous
Not applicable
Hello everyone! I'm sorry if I am asking a question that has already been answered, I just couldn't find a solution to my problem.

At the office, I work in Archicad 20, win 10, i7 4700HQ CPU.

Whenever I place an object from the library, I have to go through it's settings and change the fill from a grid to an empty fill and the pen colours. It is not hard to do, is just when you have to do it for multiple object it is a bit time consuming. Also, when I place them on screen, they appear to be grey instead of white, with a brown pen. I tried changing the fills and the pens in the attributes, but that didn't work out great. Is there any way to do it for the whole library?

01.jpg
8 REPLIES 8

Laszlo Nagy
Community Admin
Community Admin
You probably started a new project file based on the project settings of an already existing file, which may have fills defined differently for the default values.
Try this:
1. File>New>New...
2. Use a Template - select "ARCHICAD 20 Templaate.tpl", then click OK.

This way the file should contain fills in a way so that your GDL Objects are displayed with correct Fill types.
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Barry Kelly
Moderator
The Graphisoft objects are all set to use the attributes set in the default Archicad template.
Your job has different attributes, so every object may appear to be using the wrong pens, fill and materials if the attributes in your file do not match those in the default template.

You either need to adjust the element settings as you go or save favourites for the ones you use often (once you have set them up correctly), or alter your template (job) so it uses the same attributes as the default template (this can be a little messy to try and change in the middle of a job).

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
laszlonagy wrote:
You probably started a new project file based on the project settings of an already existing file, which may have fills defined differently for the default values.
Try this:
1. File>New>New...
2. Use a Template - select "ARCHICAD 20 Templaate.tpl", then click OK.

This way the file should contain fills in a way so that your GDL Objects are displayed with correct Fill types.


We have a template set for everyone in the office to use, as we are transitioning from AutoCAD to ArchiCAD... This seems to happen with the Zone Tool as well, even though the fill is set up to be white, it appears grey on the screen, even if I saved it as white and all pens are white.

Is there any way I could do to modify these settings within the template that I am working in atm? I tried looking for some guidence within the ArchiCAD help section, but couldn't actually find much...

Also, thank you for the quick reply!

Anonymous
Not applicable
Barry wrote:
The Graphisoft objects are all set to use the attributes set in the default Archicad template.
Your job has different attributes, so every object may appear to be using the wrong pens, fill and materials if the attributes in your file do not match those in the default template.

You either need to adjust the element settings as you go or save favourites for the ones you use often (once you have set them up correctly), or alter your template (job) so it uses the same attributes as the default template (this can be a little messy to try and change in the middle of a job).

Barry.
Is there any guidance on doing this? I was trying to find it on the web but couldn't find much about changing a template's settings.

Also, thank you for the quick reply!

runxel
Ace
Simona wrote:
This seems to happen with the Zone Tool as well, even though the fill is set up to be white, it appears grey on the screen, even if I saved it as white and all pens are white.
Can you please also check the automatic pen visibility?
AC 24 [ger] | Win 10 | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

Anonymous
Not applicable
runxel wrote:
Simona wrote:
This seems to happen with the Zone Tool as well, even though the fill is set up to be white, it appears grey on the screen, even if I saved it as white and all pens are white.
Can you please also check the automatic pen visibility?
I have, from what I knew, I didn't have any of the options checked.
Would it work if I readjusted the fills and pens in the attributes manager again? Maybe I've done something wrong? Or is there a way to assign a certain fill to the object library?

Thank you!
work environment.JPG

Karl Ottenstein
Moderator
Simona,

Yes, you can 'fix' things in your current project/pln and or company template... using Attribute Manager to restore all of the attributes to their expected settings.

https://helpcenter.graphisoft.com/guides/archicad-21/archicad-21-reference-guide/configuration/attri...

It sounds like someone in your office created an office template for everyone to use, but did not understand that certain pens (colors and weights), fills, line types, etc are expected to be in certain positions and if they are changed, then you will get peculiar library default results as you are seeing.

Attributes (pens, fills, etc) are NOT matched by name ... but by an index number. You will want to create a new file from the Graphisoft template, as others suggested below. Then, open the file you're working on and go to Attribute Manager. There, you'll open the empty pln that you had just created with the Graphisoft attributes in the right panel ... and your current project/template will be in the left panel. You'll select attributes on the right and OVERWRITE to the left - to get them pack to their proper index numbers (or at least the index numbers that all the library parts expect).

There is a lot of discussion on using Attribute Manager in these forums - search for that term. It is a relatively quick process once you've mastered it, but will take some time to sort it out the first time. There is a post (can't find it quickly) that notes the pens that library parts use by default - typically pens 1-10, and white (19/91) and a few others... I think by Link... and some of the standard fills that must be at certain index numbers etc. Without things at the factory defaults, the factory default library will not have meaningful default appearance as you've seen.
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.6, iMac Pro

Anonymous
Not applicable
Karl wrote:
Simona,

Yes, you can 'fix' things in your current project/pln and or company template... using Attribute Manager to restore all of the attributes to their expected settings.

https://helpcenter.graphisoft.com/guides/archicad-21/archicad-21-reference-guide/configuration/attri...

It sounds like someone in your office created an office template for everyone to use, but did not understand that certain pens (colors and weights), fills, line types, etc are expected to be in certain positions and if they are changed, then you will get peculiar library default results as you are seeing.

Attributes (pens, fills, etc) are NOT matched by name ... but by an index number. You will want to create a new file from the Graphisoft template, as others suggested below. Then, open the file you're working on and go to Attribute Manager. There, you'll open the empty pln that you had just created with the Graphisoft attributes in the right panel ... and your current project/template will be in the left panel. You'll select attributes on the right and OVERWRITE to the left - to get them pack to their proper index numbers (or at least the index numbers that all the library parts expect).

There is a lot of discussion on using Attribute Manager in these forums - search for that term. It is a relatively quick process once you've mastered it, but will take some time to sort it out the first time. There is a post (can't find it quickly) that notes the pens that library parts use by default - typically pens 1-10, and white (19/91) and a few others... I think by Link... and some of the standard fills that must be at certain index numbers etc. Without things at the factory defaults, the factory default library will not have meaningful default appearance as you've seen.
Thank you so much! That seemed to be the problem, as there were some pen colours changed! I've also searched on the forum for the attributes manager and found so many helpful discussions!
Thank you!

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!