Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Not Able to Change Units

Anonymous
Not applicable
I have a metric project. I created a unit profile in centimetre in Dimensions in Project Preferences and changed to it. However, after I switched between different views for two to three times, the units changed back to the decimal feet. No matter how many times did I changed the unit to the centimetre, it would automatically switch back. Is it a bug?
6 REPLIES 6

Barry Kelly
Moderator
Shenghao wrote:
Is it a bug?
No.
Each view has its own settings and in those settings you can assign a a dimension style.
So you can have multiple views of the same view point - but all with different settings if you want.

So in the Navigator there are four buttons - one for Project Map, one for View Map, one for Layouts and one for Publisher Sets.

The Project Map contains your View Points.
You control all of the settings here manually.
i.e. you can set the dimension style, layer combination, scale graphic overrides etc., to what ever you want - and that is what you will see on screen.

Then what you should be doing is saving a View of each View Point - these will be saved in the View Map.
Each one of these views 'saves' the settings for things like dimension style, layer combination, etc.
So when you choose one of these views, all of the settings will change automatically to suit what you want it to be.

It is these Views that you then place onto the layouts - that way they remember what settings they are supposed to have.

You then Publish these layouts.

So once you have it all set up, with all the views you want and have them placed on your layouts, you simply make changes in Archicad.
You can use the Project Map View Points to navigate around your project - but remember you have to control the settings your self so what you see on screen is correct.
Or you can use the View Points in the View Map and the settings will adjust automatically for you as they were set in that view (and yes you can change the settings if you need to).


So if you are using the Views in your View Map, make sure that in the settings, they are set to use the decimal (centimeter) style.

Also when you change the dimension style, be sure to "Store As' one of the styles to make it a permanent change to that style.
That style is what you apply to the view settings.
You don't want it to ever say 'Custom'.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
Thank you for your reply. I understand each view has its own settings. However, let's say, I'm in Elevation 1, I changed the units, and I switched to Generic Perspective. When I come back to Elevation 1, it's back to imperial units. And since I changed the settings in the Project Preferences windows, literally it should be a global setting.

I just found that only when I switch the units in Generic Perspective won't them turn back to imperial. Otherwise, if I switch the units in plans, or elevations, or any viewpoint other than Generic Perspective, the units will turn back to default when I come back from Generic Perspective.

Lingwisyer
Virtuoso
That might be due to you opening the perspective view "as is" rather than "with current settings"
AC18-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200

Win10 | R5 2600 | 16GB | GTX1660

Anonymous
Not applicable
It could be. Where can I change "As is" to "With current settings"?

Barry Kelly
Moderator
It is a bit strange because technically the 3D views do not have dimensions and therefore can't have a dimension style.
For me the 3D is staying to whatever dimension style I set and it does not affect my plan.
Likewise changing the plan dim style does not affect the 3D.

If you are just switching views using the TAB bar, look closely at the icons.
Black means they are from the Project Map and therefore have no settings of their own.
Blue icons are from the View Map and should have their own settings which should become active when you open them.

It is possible to copy the settings (ALT click) from one TAB and inject them (CTRL+ALT click) into another TAB.

I am using version 24.
What version are you using?


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
That's exactly what I was thinking -- 3D view doesn't have dimensions. I switch the units via Options - Project Preferences - Dimensions, which should be global. I'm using 24 as well. So all the "views" I mentioned refer to Project Map.

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!