Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 
Design forum

Original still selected after copying

Not applicable
Is this driving anyone else crazy? I select something and copy it. End the command and both the copy and the original are both still selected. Many times I want to make changes to the copy but If I don't deselect the original then the changes are made to both.

In my experience so far the only time that this "improvement" is beneficial is if I want to group the copies and the original. It saves a step.

Is there any way to turn of this behavior and release the original after the copy command?

Thanks. Doug

AC 19

Hi Doug,

Thank you for the feedback. For clarification to users not familiar with this topic, I just want to make clear the commands:

- If you Copy and Paste, neither the original nor the copy remain selected after the operation. (same in previous versions as in 19)
- If you Drag a Copy, Mirror a Copy or Rotate a Copy the original does not remain selected but the copy does. (same in previous versions as in 19)
- If you use the Multiply command, the original does not remain selected but the copies do.
- If you Drag Multiple Copies or Rotate Multiple Copies, then the original and the copies all remain selected. (new in version 19; previously the original did not remain selected) And I think this is the one you are referring to.

It seems there is a split amongst users on this topic. The Drag Multiple Copies and Rotate Multiple Copies was purposefully changed in ARCHICAD 19 because many users were doing the extra step of Undo, then Redo to select all. It was a big wish amongst users. There is not an option to toggle between the 2 methods, but hopefully my breakdown above helps to illuminate the differences between commands. However, there is a wish already posted internally to add a toggle control and I have commented and put a link to your post in the comments of that wish.

Help Center > Guides > ArchiCAD 19 INT Reference Guide > Interaction > Editing Elements > Create Element Duplicates

Best regards,
Nicholas Cornia
Technical Support Team - GRAPHISOFT North America
ARCHICAD on Twitter

Not applicable
Thanks for the info Nicholas. I'm a little embarrassed to say that part of the problem is my own doing. I've had a shortcut key for Drag Multiple Copies for so many years that I had forgotten the Drag A Copy even existed. A lot of the copying that I was doing the night I posted were one off copies. Guess I'm going to change my "C" key to Drag A Copy and pay attention when dragging multiple copies.

I think a toggle is a good idea and I appreciate you making note of this wish.

Thanks again,


Didn't find the answer? Start a new discussion

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!