Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem: Unwanted cutting plane appears 2m in front of camera in 3D window

peter_h
Newcomer
In AC23, seemingly at random, and occasionally, the 3D window view changes to have a cutting plane, approx 2m in front of the camera lens. It follows the camera wherever the camera goes, and is really annoying and unhelpful. I can't continue to do any useful editing in the 3D window after it happens, because I can't get closer than 2m to an object before it starts to disappear! I can't find anywhere to turn this "cutting plane" off, and I don't even know what it is -- and if it's a bug or a "feature" that has somehow been turned on. All the cutting plane features I've found seem to assume a static cut, not one that continuously follows the camera around.

Any ideas what it is, and how I can get rid of it... and how to stop it happening in the future.

My only current recourse is to abandon the current file and load a previously saved version.

I've attached a few screenshots of a fly-in to the building, to illustrate the "effect".
Pete,
Wellington, New Zealand.
Win10pro x64, AC 23 Student.
Intel Xenon E31235 Quad 3.2GHz, 16GB, Nvidia GFX670, 4 x multi-monitor setup, 3dconnexion SpaceExplorer.
11 REPLIES 11

Barry Kelly
Moderator
I had this the other day while trying to edit a GDL object.
I can't recall exactly what I did to fix it - like you I was checking everything.

But try switching the 3D window to the vectorial engine.
Then switch back to OpenGL.
I am pretty sure that is what fixed it for me.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

mikas
Advocate
Are you modelling far away from the project origin?
It might help if you moved your model closer to it.
https://helpcenter.graphisoft.com/user-guide/76330/
AC25, Rhino6/7+Grasshopper, TwinMotionMac Pro 6,1 E5-1650v2-3,5GHz/128GB/eGPU:6800XT/11.5.1 • HP Z440 E5-1650v3/256GB/RVII/W10Pro

peter_h
Newcomer
OK... some more info:

The problem persists with a close of AC completely...restart...load up the same saved file again. So it's some setting/bug that gets saved with the file.

WORKAROUND FOUND:

I switched to VIEW>3D VIEW OPTIONS>AXONOMETRY, and then back to VIEW>3D VIEW OPTIONS>PERPECTIVE (because a switch to Vectorial view took waayyyy too long to never appear), and VIOLA!!! -- back to normal and useable again.

This doesn't solve the mystery behaviour though. So let the solving continue.... 😕
Pete,
Wellington, New Zealand.
Win10pro x64, AC 23 Student.
Intel Xenon E31235 Quad 3.2GHz, 16GB, Nvidia GFX670, 4 x multi-monitor setup, 3dconnexion SpaceExplorer.

peter_h
Newcomer
mikas wrote:
Are you modelling far away from the project origin?
It might help if you moved your model closer to it.
https://helpcenter.graphisoft.com/user-guide/76330/
Nope. Project origin is within the building.
Pete,
Wellington, New Zealand.
Win10pro x64, AC 23 Student.
Intel Xenon E31235 Quad 3.2GHz, 16GB, Nvidia GFX670, 4 x multi-monitor setup, 3dconnexion SpaceExplorer.

Barry Kelly
Moderator
peter_h wrote:

WORKAROUND FOUND:

I switched to VIEW>3D VIEW OPTIONS>AXONOMETRY, and then back to VIEW>3D VIEW OPTIONS>PERPECTIVE (because a switch to Vectorial view took waayyyy too long to never appear), and VIOLA!!! -- back to normal and useable again.

Maybe that is actually what I did as well - I really can't remember.
For me it is not something that happens very often (in fact only this once so far).
And once fixed does not seem to re-occur - fingers crossed.

At least we now have a solution to get out of the problem.
Thanks for clarifying.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Lingwisyer
Virtuoso
I think that cycling your 3D view type resets your CAMERA origin, of which I believe is that cause of this issue.
AC18-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200

Nguyen Minh
Graphisoft Moderator
Graphisoft Moderator
peter_h wrote:
In AC23, seemingly at random, and occasionally, the 3D window view changes to have a cutting plane, approx 2m in front of the camera lens. It follows the camera wherever the camera goes, and is really annoying and unhelpful. I can't continue to do any useful editing in the 3D window after it happens, because I can't get closer than 2m to an object before it starts to disappear! I can't find anywhere to turn this "cutting plane" off, and I don't even know what it is -- and if it's a bug or a "feature" that has somehow been turned on. All the cutting plane features I've found seem to assume a static cut, not one that continuously follows the camera around.

Any ideas what it is, and how I can get rid of it... and how to stop it happening in the future.

My only current recourse is to abandon the current file and load a previously saved version.

I've attached a few screenshots of a fly-in to the building, to illustrate the "effect".
Hi Peter,

Thank you for sharing the issue and I am very sorry about the experience!

As other has suggested, I believe that there must be something off with the camera settings. Is there a chance that you still have the old file? Or is there a way to replicate the issue?

Looking forward to hearing from you!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

peter_h
Newcomer
Hi Minh ,
Yes, I'm still getting this problem, with my current file. And switching to different 3d view modes doesn't help now.
However, making my terrain mesh invisible does stop the problem (so there is zero objects of type MESH in the view). Turning the layer with my mesh on it reinstates the problem.
Pete,
Wellington, New Zealand.
Win10pro x64, AC 23 Student.
Intel Xenon E31235 Quad 3.2GHz, 16GB, Nvidia GFX670, 4 x multi-monitor setup, 3dconnexion SpaceExplorer.

Nguyen Minh
Graphisoft Moderator
Graphisoft Moderator
Hi Peter,

Thank you for the information! I am wondering if you can share the file with us for a closer look? Please let me know if you need a secure place to upload the file.

Looking forward to hearing from you!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

peter_h
Newcomer
So trying to narrow this down.... by turning off layers to simplify....

I'm left with 3 layers turned on in the plan view window...
Terrain: only has one big mesh object.
Exterior Walls: has 4 wall objects.
Archicad Layer: has nothing (but I can't turn it off)

I have the 3D view set to OpenGL. I navigate using SpaceExplorer 3D mouse.

With nothing selected, I hit F5 (I'm on Windows, so f5 to display everything in 3D window)
Result: The mystery cutting plane cuts through objects in front of moving camera.

In plan view, I press ctrl-A (select all), and hit f5 again.
Result: No annoying cutting plane!

So the problem only happens when I don't specifically select the objects I want to shown in the 3D window, and instead rely on AC to automatically draw all the visible objects, that I have showing in plan, in my 3D window (which is the default way of working).

BTW, my AC23 version is 4006 NZE

Minh: do you still want me to send you my minimum file to try recreate this situation here?
Pete,
Wellington, New Zealand.
Win10pro x64, AC 23 Student.
Intel Xenon E31235 Quad 3.2GHz, 16GB, Nvidia GFX670, 4 x multi-monitor setup, 3dconnexion SpaceExplorer.

Nguyen Minh
Graphisoft Moderator
Graphisoft Moderator
Hi Peter,

Thank you for the detailed explanation! Yes, I would definitely be interested in taking a look at the file. I sent you a link via Private Message, with which you can upload the file directly to us.

Please let me know once the process is finished. Thank you once again!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!