Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

RHINO 7

Frank Gergaud
Newcomer
Hi,

I can see that Rhino 7 doesn't recognise ArchiCAD live connection. Is there a way to make it work or how shall I do it?

Frank
1 ACCEPTED SOLUTION

Solution
Laszlo Nagy
Community Admin
Community Admin
The Grasshopper-Archicad 24 Live Connection now supports Rhino 7:

https://graphisoft.com/downloads/addons/interoperability/rhino

The Grasshopper-Archicad 25 Live Connection is also coming soon, according to the web page.
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

View solution in original post

28 REPLIES 28

Eduardo Rolon
Moderator
Isn't Rhino 7 in Beta? I think the connection might require Rhino 6.
eduardo rolón AIA NCARB
Another of the forum moderators.
Macbook Pro 2.4 i9 32GB ram
OS X 10.XX latest
AC25 US/INT -> AC08

Frank Gergaud
Newcomer
It seems that they now release the Rhino 7 and it's not a BETA anymore.

Yes the connection requires Rhino 6. But I need to have in Rhino 7 so I just wonder if ArchiCAD was thinking of developping this for Rhino 7.

Eduardo Rolon
Moderator
I don't see why not but they might take a little while in releasing the update.
eduardo rolón AIA NCARB
Another of the forum moderators.
Macbook Pro 2.4 i9 32GB ram
OS X 10.XX latest
AC25 US/INT -> AC08

daviddelven
Newcomer
Hello,

Before that, we should have already the update of the R6 compatible with the last AC built. Many of us apply the built due to necessary bug fixes, and we cannot use the R6 Grasshopper Live Connection.
ejrolon wrote:
I don't see why not but they might take a little while in releasing the update.
David Delgado Vendrell
http://www.daviddelgado.cat
i7-7820HK CPU 2,90GHz 32GB RAM
Triple Monitor 17"+25"+32" Nvidia Geforce GTX 1080
SSD+HDD, Win10 Home - 64 ENG
AC18-AC24 INT (64-bit, latest build)
Surfing with ARCHICAD since 2013

leceta
Booster
Second AC24 update and gh connection is still only compatible with 3008.

Am I the unique one who thinks that GH connection doesn't deserve the consideration of a "professional tool"?
its buggy, it's not up to date with Archicad... this is so sad.

archimax
Newcomer
Urgently need Rhino 7 support!
-------------
AC21-INT

archimax
Newcomer
Found that GH assembly lives in C:\Program Files\Rhino 6\Plug-ins\Grasshopper\ArchiCADConnection.gha

Copied it to C:\Program Files\Rhino 7\Plug-ins\Grasshopper and now it seems to work with Rhino 7
-------------
AC21-INT

hi

do you see any chance that the Archicad - Grasshopper connection gets similar development and marketing focus like the one you find here listed as the second topic:
https://www.rhino3d.com/en/7/new/

I see the potentials by integrating the Rhino/GH environment with a BIM application crucial.

BR, Florian
AC24 4018 INT, Win10, Quadro P2000, Xeon, BIMCloud

furtonb
Enthusiast
Based on the available information (right now), don't hold your breath...

https://archicad-talk.graphisoft.com/viewtopic.php?f=43&t=68012&start=10
https://discourse.mcneel.com/t/rhino-inside-archicad/93421
actively using: AC22-25 INT | Rhino6-7 | macOS / win10

Bricklyne Clarence
Participant
Florian wrote:
hi

do you see any chance that the Archicad - Grasshopper connection gets similar development and marketing focus like the one you find here listed as the second topic:
https://www.rhino3d.com/en/7/new/

I see the potentials by integrating the Rhino/GH environment with a BIM application crucial.

BR, Florian

Sorry, a bit off-topic, but...
God, just look at all the new features in that new features page.

I just kept going through the list of all the new things in the new version, and I just couldn't help feeling jealous of Rhino users. Some of them are even features that I want in ARCHICAD, for crying out loud (the Ambient Occlusion with edges display mode that is used a lot in architecture but which for some strange reason no one has ever though to integrate into their software for -straight-out-of-the-box use (I think Revit has it now), for example, or the improved gradients and transparent hatches).

Remember what it was like to get the new version of your favourite software and find it was just chock full of so many new features (that were useful to YOU), that you didn't even know if you'd be using all of them, much less even know about them all?

Some of their new features are so extensive, that they have sub-categories within the new features of the new sub-features that each feature has.
It's insane!

But then again, the Rhino developers do take their time releasing new versions, which makes it that you're assured of getting good value for money when the new version is released.


Sorry, but I just had to remark on that.
It just blew my mind.

Szamimate
Newcomer
I had the same problem. Here is my solution from the rhino forum:
The connection seams to be working between ArchiCAD 24 and Rhino 7.0 - but the install process is far from smooth. Here is what I did, if anyone has the same problem:
[list=2]
  • download, and install Rhino 6. It only asks for licence for starting the software - which you don’t need
  • [list=2]
  • install the ArchiCAD connection. It will work this time.
  • [list=3]
  • the installer puts a ArchiCADConnection.gha file to rhino6/plug-ins/grashopper. Copy it to rhino 7.
  • [list=4]
  • the .gha will not load at this point, as it needs Newtonsoft.Json.dll to run. It is renamed as Newtonsoft.Json.Rhino.dll in rhino 7. I copied the one from the rhino 6/system to Rhino 7/system. Seams to be working
  • [list=5]
  • at this point ArchiCAD stopped working. I needed to reinstall it
  • [list=6]
  • after the reinstall, is seams to be working fine (well at least on the surface)
  • Szamosi Máté

    alexsks
    Newcomer
    For me it worked without problems (AC 23, AC/GH Connection 3007) by just copying these files (to Rhino folder "Plug-ins/Grasshopper").

    ArchiCADConnection.gha
    Newtonsoft.JSON.dll
    ProductVersion.xml

    I was under the impression that Newtonsoft.JSON.dll is created by the Archicad plug-in, I didn't see it in Rhino 7/6 (renamed or not). Anyway, I didn't rename it.

    To write some details... Since I was installing on a new computer and anticipated problems after reading this thread, I did the following tests:

    1) I installed Rhino 7 using installation folder "Rhino 6" - plug-in couldn't install as it didn't detect Rhino (yes, stupid idea).
    2) I installed Rhino 6 using installaton folder "Rhino 5" - plug-in was installed for the old version.
    3) I copied the three files from old to new and it worked.

    Final test, on a virtual machine, I installed normally Archicad 23 and Rhino 7. I copied the three files as above and I copied the folder "Grasshopper-ARCHICAD Live Connection" from Archicad's Add-Ons on the main PC to the virtual PC. It works. That's on different hardware and pc names. I assume the installation of the plug-in just copies the needed files, so, with the above files, there's no need to install Rhino 6 and the plug-in.

    Emil Meijer
    Graphisoft
    Graphisoft
    alexsks wrote:
    For me it worked without problems (AC 23, AC/GH Connection 3007) by just copying these files (to Rhino folder "Plug-ins/Grasshopper").

    ArchiCADConnection.gha
    Newtonsoft.JSON.dll
    ProductVersion.xml
    Can confirm that this is working on my end too. Used the files from Rhino 6 installation folder and just copied them into the Rhino 7 folder. It hasn't given me any errors so far.

    Aaron Bourgoin
    Booster
    worked for me as well.
    Think Like a Spec Writer
    AC23-3003 USA / AC24-4018 USA
    Rhino 7 Mac
    OSX 10.14.6 & 11.3.1

    Jose Gemez
    Newcomer
    Hi! one cuestion. Someone is using Rhino 7 and Arhicad 24 4018 in "production"? Thanks in advance. We have update Archicad and Rhino...

    furtonb
    Enthusiast
    I use the connection plugin rarely, but it works as explained above. I'm mostly merging or hotlinking models - export to Rhino 5 and you can work with it, still no native hotlink/merge support for Rhino 6 or 7, AFAIK.
    actively using: AC22-25 INT | Rhino6-7 | macOS / win10

    Jose Gemez
    Newcomer
    I'm working with some pointclouds! its very stable for my workflow

    Durval
    Newcomer
    Emil wrote:
    Can confirm that this is working on my end too. Used the files from Rhino 6 installation folder and just copied them into the Rhino 7 folder. It hasn't given me any errors so far.
    Did someone try a similar solution for MacOS?
    --- www.dtabach.com.br ---
    AC 24 BR – MacBook Pro 2,9 GHz Intel Core i7 16GB RAM Mac OS 10.14

    Aaron Bourgoin
    Booster
    I managed to do this on MacOS.
    Think Like a Spec Writer
    AC23-3003 USA / AC24-4018 USA
    Rhino 7 Mac
    OSX 10.14.6 & 11.3.1

    Still looking?

    Browse more topics

    Back to forum

    See latest solutions

    Accepted solutions

    Start a new discussion!