Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Stopping AC mid calculation?

TDabney
Participant
Hello -

This is probably an easy one. How do you stop AC from calculating in the 3D window, section/elevation tool and photorendering window? For example: you start a photorendering and then realize you forgot to adjust the sun angle so you want to stop it mid-way thru and restart after making some adjustments. I used to be able to type "command . (period)" to get it to stop. For some reason it hasn't worked for me for a while. I'm using Mac 10.3.1, AC 8.0v3.

Thanks,

Tom
TND Architects P.L.L.C.

macOS 12.3

2021 16" MacBook Pro

Apple M1 Max

ArchiCAD 25
19 REPLIES 19

David Larrew
Booster
As you said, in AC7.0 the hot-key was "Ctrl"+".".
Since upgrading to AC8.* I haven't needed that command (yet) - AC8.1 is much faster in most areas where I would usually have to cancel out.
David Larrew, AIA, GDLA, GSRC

Architectural Technology Specialist

a r c h i S O L U T I O N S



WIN7-10/ OSX 10.15.7

AC 5.1-25 USA

TDabney
Participant
David wrote:
In AC7.0 the hot-key was "Ctrl"+".".
I haven't tested it in AC8.* yet.
Yes - It still works for me in AC7.0, but not AC 8.0 - and I haven't been able to find a key combo that does work in 8.0 - has anyone else?
TND Architects P.L.L.C.

macOS 12.3

2021 16" MacBook Pro

Apple M1 Max

ArchiCAD 25

David Larrew
Booster
This may be obvious, but... Have you tried the "Esc" key?

I think that GS re-assigned the "Esc" key function from the Snap toggle to an actual escape command.
David Larrew, AIA, GDLA, GSRC

Architectural Technology Specialist

a r c h i S O L U T I O N S



WIN7-10/ OSX 10.15.7

AC 5.1-25 USA

TDabney
Participant
David wrote:
This may be obvious, but... Have you tried the "Esc" key?

I think that GS re-assigned the "Esc" key function from the Snap toggle to an actual escape command.
Yup - and about every other combo my fingers could come up with!
TND Architects P.L.L.C.

macOS 12.3

2021 16" MacBook Pro

Apple M1 Max

ArchiCAD 25

David Larrew
Booster
TDabney wrote:
Yup - and about every other combo my fingers could come up with!
Now you've peaked my curiosity.

As I said earlier, due to the increased speeds in AC8.1, I haven't had to find or use the old "Stop Process" command. But now I want to know where it went.
David Larrew, AIA, GDLA, GSRC

Architectural Technology Specialist

a r c h i S O L U T I O N S



WIN7-10/ OSX 10.15.7

AC 5.1-25 USA

TDabney wrote:
For example: you start a photorendering and then realize you forgot to adjust the sun angle so you want to stop it mid-way thru and restart after making some adjustments.
Tom
Once you start a rendering, the progress bar should have a "Stop" button next to it in the photorendering window. Doesn't that work for you?
Richard
--------------------------
Richard Morrison, Architect-Interior Designer
AC25 (since AC6.0), Win10

__archiben
Newcomer
guys

'Cmd' + period ('.') works for me, just like it used to . . .

i can't remember having done it with 8.0.x, but it works for 8.1.

[update - that's 8.1 with panther (OSX 10.3.1)]

~/archiben
b e n f r o s t
b f [a t ] p l a n b a r c h i t e c t u r e [d o t] n z
archicad | sketchup! | coffeecup

Anonymous
Not applicable
It could be an issue specific to 8.0 and Panther

Karl Ottenstein
Moderator
Unless you guys have a trick...under Windows, the ctrl-. shortcut doesn't work for me anymore - I have to actually click on the stop button during a render. And sometimes (not always), the progress bar and stop button don't appear, so there's no way to stop the process.

If I go under keyboard shortcuts, it reports that ctrl-. is assigned to the system, so it isn't as if I accidentally reassigned it to something else.

So, hey, maybe something is working better on the Mac side these days!

Karl
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.6, iMac Pro

Anonymous
Not applicable
Hit ctrl+alt+delete to open task manager.

Click "end task now"

When asked to confirm, hit cancel.

When asked to"don't save, cancel or save" hit cancel and you will return to exactly where you were before you started the 3D or section window.

Djordje
Advisor
Karl wrote:
Unless you guys have a trick...under Windows, the ctrl-. shortcut doesn't work for me anymore - I have to actually click on the stop button during a render. And sometimes (not always), the progress bar and stop button don't appear, so there's no way to stop the process.

If I go under keyboard shortcuts, it reports that ctrl-. is assigned to the system, so it isn't as if I accidentally reassigned it to something else.

So, hey, maybe something is working better on the Mac side these days!

Karl
Anybody tried Backspace?
Djordje



ArchiCAD since 4.55 ... 1995
HP Omen

Karl Ottenstein
Moderator
Djordje wrote:
Anybody tried Backspace?
Yup. Nothing stops it for me except clicking the 'stop' button - which doesn't always appear soon enough (for example, with the Sketch engine).

Karl
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.6, iMac Pro

Ben Odonnell
Newcomer
Karl wrote:
Unless you guys have a trick...under Windows, the ctrl-. shortcut doesn't work for me anymore - I have to actually click on the stop button during a render. And sometimes (not always), the progress bar and stop button don't appear, so there's no way to stop the process.

If I go under keyboard shortcuts, it reports that ctrl-. is assigned to the system, so it isn't as if I accidentally reassigned it to something else.

So, hey, maybe something is working better on the Mac side these days!

Karl
By default, since ArchiCAD 8, the progress dialog is turned off
Strange really. But to activate it you can find it under your preferences, see image. But CTRL+. hasn't worked for me since ArchiCAD 8.
Prefs.jpg
Ben O'Donnell
Architect and CTO at BIMobject®
Get your BIM objects from bimobject.com

TDabney
Participant
Ben wrote:

By default, since ArchiCAD 8, the progress dialog is turned off
Strange really. But to activate it you can find it under your preferences, see image. But CTRL+. hasn't worked for me since ArchiCAD 8.
Ahhh - I think this is what I was looking for. Upon further investigation, I'm finding that command + (.) does seem to work for me in the section/elevation window as well as the 3D window. It results in an "Errors occured during the last opperation" message. Where I was having issues was the rendering window (while using the sketch engine). W/out the progress dialog box there is no way to stop it - at least as far as I can tell - and while it doesn't appear instantly, it does show up eventually and is better than force quitting or waiting 20 min. for the rendering (which you're just going to trash anyway) to finish.

Thanks Ben!

Tom
TND Architects P.L.L.C.

macOS 12.3

2021 16" MacBook Pro

Apple M1 Max

ArchiCAD 25

Ben Odonnell
Newcomer
Pleasure Tom..

Ben
Ben O'Donnell
Architect and CTO at BIMobject®
Get your BIM objects from bimobject.com

__archiben
Newcomer
Karl wrote:
Unless you guys have a trick...under Windows, the ctrl-. shortcut doesn't work for me anymore - I have to actually click on the stop button during a render. And sometimes (not always), the progress bar and stop button don't appear, so there's no way to stop the process.

If I go under keyboard shortcuts, it reports that ctrl-. is assigned to the system, so it isn't as if I accidentally reassigned it to something else.

So, hey, maybe something is working better on the Mac side these days!

Karl
well you all had me going there. i went back and tried it again - 'Cmd' + '.' does still work for me. i have to double-press the '.' - but then i've always done that anyway.

and the progress report window came up by default for me on each ocassion. but that may be because the projects were started in earlier versions and the preference was saved with the file.

karl - try double-tapping the '.' key whilst you're holding 'Ctrl'. if that works for you i guess the macs are still hanging out the back . . .

~/archiben
b e n f r o s t
b f [a t ] p l a n b a r c h i t e c t u r e [d o t] n z
archicad | sketchup! | coffeecup

Karl Ottenstein
Moderator
~/archiben wrote:
karl - try double-tapping the '.' key whilst you're holding 'Ctrl'. if that works for you i guess the macs are still hanging out the back . . .
Well, the progress dialog has always been enabled for me - just choose not to appear until far into a rendering sometimes.

Double tapping the ".", trying the left and right side Ctrl key, backspace, no combination stops things still. I have to actually click the 'stop' button in progress window (when it finally shows itself)!

So, looks like the Mac is ahead of Windows on this one - or else something is hosed in my installation!

Karl
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.6, iMac Pro

Anonymous
Not applicable
I don't think my progress dialog has ever been turned off
IMHE pressing the key combination is not always very consistent. On something simple like a 3D or a section it usually works. But the more complicated the operation (photorendering), the less reliable it becomes. I often resort to hitting the key combination a couple of times, and if it doesn't want to stop, I'll then hit the stop button on the progress dialog which is pretty reliable.

Anonymous
Not applicable
Just to add to my previous post, I was trying to stop a couple of sketch renderings and the progress dialog was taking forever to appear and CMD+. wasn't doing anything, so I simply went up to File menu with my mouse and selected Close mid render. About 1.5 s later the window closed, go figure.

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!