Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Texture problem on steep sloped mesh

christr
Newcomer
Hi.

I hope some of you out there can help me. I'm trying to project a texture onto a terrain in AC12, but somehow the texture shows up wrong on the steepest parts of the mesh. Is there a way to correct this? Is seems like the texture on these steep parts are projected vertically onto the terrain instead of planar like I want it to.

Thanks for any help
13 REPLIES 13

TurboGlider
Newcomer
That is a normal behavior from a 3d software where you have a planar map on a mesh that slope much. One way to go is to place roofs on the most bad places and apply a terraintexture on that roof. But it can be hard to get a smooth edge between the mesh and roof.

christr wrote:
Hi.

I hope some of you out there can help me. I'm trying to project a texture onto a terrain in AC12, but somehow the texture shows up wrong on the steepest parts of the mesh. Is there a way to correct this? Is seems like the texture on these steep parts are projected vertically onto the terrain instead of planar like I want it to.

Thanks for any help
Tobias Gustafsson, Sweden
Windows 10 Pro 64-bit [SWE] - AC 16-19 [SWE] 20 [INT] (since 6.5) - Cinema 4d Visualize R17 - Maxwell Render 3.2

christr
Newcomer
I could probably do that, but since the problem is pretty much all over, this would take days, and would still not look 100%. There must be a way to control this?

TurboGlider
Newcomer
Do you have a free form 3d software like 3d studio or Cinema4d? You could control it there. But not here in ArchiCad.
Tobias Gustafsson, Sweden
Windows 10 Pro 64-bit [SWE] - AC 16-19 [SWE] 20 [INT] (since 6.5) - Cinema 4d Visualize R17 - Maxwell Render 3.2

Braza
Newcomer
Hi christr,

Maybe it can be fixed by GDL...

You would need to save the mesh as an object and edit the 3d script...

Long shot... but it worth try...

If you post a pla file of your mesh here I'll take a look.

Ah! And don't forget to create a signature in your profile with your AC version and OS and HW specs here on the forum... It will help us help you.
Paulo Henrique Santos, Architect
AC24_INT#3008 / I7 / 16Gb / 512Mb SSD / Windows 10

christr
Newcomer
Hi.

I'm onto thin ice here with gdl objects, but you may very well take a look. Would be fantastic if it works!

I could of course take the model into 3DS Max or similar, but the project is just starting, so it would be amazing if I could work on the entire project in AC.

How do I upload a large file?

Braza
Newcomer
christr wrote:
How do I upload a large file?
No need to upload the whole project...

1. Backup your work...

2. Save your project with the "pla" extension (drop down in the save options) and delete everything except the mesh... (The pla file will put all the textures in a single package)

3. Zip it and upload the zip file here in the "Add an Attachment" Section of your post.
Paulo Henrique Santos, Architect
AC24_INT#3008 / I7 / 16Gb / 512Mb SSD / Windows 10

Karl Ottenstein
Moderator
I have always had this problem with steep terrain meshes in ArchiCAD and have reported it as a bug.

I disagree that this is 'normal' in 3D software. The ArchiCAD texture mapping defects are worse than those illustrated, sometimes giving bizarre spirals of distortion. See this discussion:
http://archicad-talk.graphisoft.com/viewtopic.php?p=144913

For the same mesh that gives me problems in ArchiCAD, when I apply the same texture in Artlantis, everything is fine.

Cheers,
Karl
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6, iMac Pro

David Collins
Booster
Texture mapping in ArchiCAD has always had these issues, particularly for meshes (MASS) and TUBES.
Not much hope for a solution in GDL: to achieve full control you'd have to recreate the terrain using single primitive planes and then map each one using TEVE commands. Ouch!

See:

http://archicad-talk.graphisoft.com/viewtopic.php?p=127264&highlight=#127264

for problems getting a flag image to map properly on an animated flag object.

As Karl says, Artlantis can often do a better job of this than ArchCAD, but not always.
Another thing to try, at least in OpenGL: turn off smoothing.
David Collins
Win10 64bit Intel i7 6700 3.40 Ghz 32 Gb RAM
AC 24.0 (3022 INT FULL)

christr
Newcomer
Thanks for the replies.

I understand that this is a known problem, so I won't try too hard in AC. I will however try it in either Artlantis or 3DS Max. At least I know how to get it to work in 3DS Max.

Braza: Thanks for the help. I will see how it turns out in the other programs, and I will get back to you if I'm in need of your help.

46cruisair
Newcomer
just my two cents worth here >

if the jpg offered is the image that has problems > my opinion is that it looks very realistic vs. having the steep slopes with a green texture on them. a very steep slope in the natural environment would not have much if any vegetation on it.

to me it looks very good - realistic.
Jeff Warren, Architect
Simpsonville, SC

AC23/3003 USA FULL
OS-X 10.15.4
iMac i7 Quad 4GB, 3.8 GHz Quad-Core Intel Core i5

Brewer Davidson
Newcomer
I've also had this mesh problem for sometime now. In my experience it only occurs on sections of mesh where the faces are steeper than 45 degrees. When modelling building sites this rarely poses a problem since they tend to be semi-flat. Make sure that if the contours are at 1m intervals that they are spaced a minimum of 1m apart in plan. Obviously where you have steep cliffs like in your example this may not be possible.

If you want to keep the contours accurate then there is no way around it I'm afraid but if you are willing to sacrifice accuracy for correct texture mapping I'd go around and spread out the contours where the texture ripping is occuring to make the terrain flatter.
| Intel P4 3.4GHz | 2GB RAM | ATI X600 256MB |
| WinXP Pro | ArchiCAD 13 NZE |

Just wanted to voice that this is still an issue in AC25!

 

If any solution has been found, please let me know!

VF_LandMASS.JPG

Duane
Visual Frontiers
AC22 6021:|: AC24 4007:|: Enscape3:|:TwinMotion
DellXPS 4.7ghz i7:|: 8gb GPU 1070ti

Nguyen Minh
Graphisoft Moderator
Graphisoft Moderator

Hi Duane,

 

Thank you very much for the report and I am very sorry about the experience!

 

After some reseach, I found that the Mesh, as most 3D things in AC, has box-type Texture projection. This means there is an imaginary box around the mesh, the texture painted on its six sides, and texture on each mesh-triangle is projected from one of the six sides. The chosen side is the one with the closest direction to the plane of the triangle. So the steep triangles receive their Texture from the vertical sides, and probably from a completely different section of the Texture image than the neighboring non-steep triangles, which cause discontinuity.

 

What we would need is a Planar projection on the Mesh - all Mesh faces receive texture from one (horizontal) plane. Unfortunately, this cannot be set on Meshes. But, if you convert the Mesh to Morph and Select only the upper surface (Ctrl-Shift subelement selection) Planar texture projection may be set in the settings dialog.

 

ARCHICAD_B8dHqD0B8k.png

 

This way the Texture fits the Morph, but the projection origin and direction will be modified. We can create a new Surface for the Morph and rotating the Surface Image with the desired angle. Then select the upper Surface and Align the 3D Texture with Set Origin.

 

I hope it gives a proper workaround in this case. Please let me know if you have any further questions!

Best regards,

Minh

 

 

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Didn't find the answer? Start a new discussion

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!