cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Design forum

The libraries ...AGAIN

cocoloco
Booster

Hi

Working in archicad with our team and it's a nightmare...We all work in archicad 26 (same freaking version and one would think it will be the same library as well as we don't download anything extra)

 

One person is creating floor plan, the second renderings, and the third design concept... When the first finish the floor plan, the other two opens it and guess what, so many pieces are missing even though the person saved the file as pln, pla, dwg and we as well have there folder with that library (just in case). And yet, there is still something missing. 

This happens every-single-time. 

 

I don't know what to do. It says which library is "missing" but it also says we miss library archi26 which we do have for sure but also others, which should be extracted through the files and folders the person saved it in anyway! 

 

 

 

13 REPLIES 13

Lee Hankins
Mentor

it looks like you are using Libraries from both the full Archicad 26 and also Archicad 26 Solo. The missing library is trying to load from a local drive 'C:/'. is your local drive labelled as 'C' and do you have Archicad 26 full version installed for Archicad to be able to find that Library? You also have the Library PLA file loaded which will be triggering your duplicates issue as the libraries within the pla are likey the same as the linked libraries you have loaded. If the other user has sent you the PLA you can open that and read the elements directly from the Archive. If you are both using Archicad 26 then you just need to make sure your Libraries are linked to your versions on your local drive. the ones that seems to be linked with Archicad 26 Solo are working so it looks like you need to swap the Archicad Old Migration libraries that is loaded with your version from the Archicad 26 Solo folder. You likely do not have the Archicad 26 folder if you don't have Archicad 26 as well as Archicad 26 Solo installed. They are different programmes.

Lee Hankins
ArchiCAD 4.5 - Archicad 26UKI Apple Silicon 4032
macOS Ventura (13.1)

Yes I know 2 different softwates (tomato potato) so I am the one with the Solo while the other one with full version. And the person saved everything in files where everything should be extracted or at least opened, which is not happening. Any file won’t open showing all files whether I extract folder or read elements in file …. This is not the first time having this problem in fact it’s repetitive problem that I have on every single collaboration    

MetalFingerz
Enthusiast

There seems to be different OS at play as well ? There are some Mac and Windows file paths on the screencap, maybe that is part of the issue ?

Yes we work on different computers/OS , I would think that at 2023 that should not be an issue with this expensive software?  I mean I guess everything is possible but I would just hope that this would not be the thing. 
i never explore this issue in sketch up, revit or auto cad … and the libraries, that truly is just archicad thing. In other softwares all loads without having even a library of each archicad version 

Lee Hankins
Mentor

You can’t expect the software to know where the libraries are stored on two different versions of the software and two different operating systems. Graphisoft recommend using BIMcloud for the Libraries so it doesn’t matter where they are stored locally or what OS you use. All you need to do is remove the Old Migration Library and then re-add it but from your Archicad 26 Solo folder on your Mac and everything will work. Also remove the Library PLA. 

Lee Hankins
ArchiCAD 4.5 - Archicad 26UKI Apple Silicon 4032
macOS Ventura (13.1)

Hi! It is not that I expect the software to know where are libraries on 2 computers, however, if I suppose to extract the folder with all libraries, then it should load (after uploading it again). Which did not.I kept removing and adding folders as you suggested ...nothing work. But this worked.... however I don't believe that this should be the correct solution...

 

1. I removed all libraries & instead of adding folders with libraries, I added the libraries files directly (lcf file). I had to found these files, and it had been around 20, so pretty clickable fun! Like I said, I don't believe this should be a standard solution for loading libraries that are extracted. I believe a folder with where the libraries should be enough, for example folder Archicad 26 library would load the library folder, without looking for lcf file.. 

Lee Hankins
Mentor

That shouldn’t be the case. You should be able to add the folders which contain the libraries. It may be caused y the fact that you are using the solo version and the other person you are collaborating with is using the full version and the libraries do differ. 

Lee Hankins
ArchiCAD 4.5 - Archicad 26UKI Apple Silicon 4032
macOS Ventura (13.1)

Who knows... maybe. At the end, this is one software that should be prepared for team work whether one has solo and one full version. Both are paid so there should be prepared for it 

AllanP
Booster

Hi,

the 1st problem i see...

lots of duplicates.

never load repeats of libraries.

 

 

the 2nd problem i see

migration library missing.

it looks like your version of the file was upgraded from an earlier version, this is bad practice for a job, and where unexpected errors start happening.

the missing "old archicad migration libraries" are very old

AllanP_1-1674166096203.png

you should not be including/using anything from these libraries, as these parts are 15+ years old.

there should be current library parts that are in the archicad 26 library that should be used.

 

most of the library errors i encounter are to do with upgrading files, the most dramatic one was all the windows in an apartment building were replaced with toilets (in archicad 10).

 

 

the 3rd problem i see

the .pla file is too small...228MB

the pla should be saved with "all loaded libraries"...about 1.5GB

AllanP_0-1674165680560.png

then all the other libraries you load will be unnecessary, and you should not get any missing library part errors.

 

it is pointless to use a pla file as a library unless

1. the include "Loaded Libaries" is ticked,

or

2. you have someone "making and embedding" library parts.

 

i think you should get help setting up your libraries so you have the same library on each computer,

or so you should have a better work flow that does not include ancient libraries.

 

i don't know if this helps.

I am up to page 4,078 of Archicad 26 Reference Guide, (Worksheet and Detail Tool Settings), but i got to read it all 😞

Didn't find the answer? Start a new discussion

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!