Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Version 22: Large parts of the model disappear in 3d explore mode

David Collins
Booster
I previously complained about shadows disappearing in 3d explore mode with ArchiCAD 22, but now I see that the memory issues are much worse than just the shadows. I'm working with fairly complex models but ArchiCAD 21 handled them easily. In 22 large parts of the same models simply disappear when I try to walk through them in 3d explore mode. I've checked the memory settings in the WE and updated the driver for the GeForce GTX 750 card I'm using, to no avail.

Is anyone else seeing this?
David Collins
Win10 64bit Intel i7 6700 3.40 Ghz 32 Gb RAM
AC 24.0 (3022 INT FULL)
1 ACCEPTED SOLUTION

Solution
David Collins
Booster
For the record this issue was resolved with ArchiCAD 22 update 4023.
See https://www.graphisoft.com/downloads/archicad/updates/AC22/ImprovementsList.html
Thank you Graphisoft !
David Collins
Win10 64bit Intel i7 6700 3.40 Ghz 32 Gb RAM
AC 24.0 (3022 INT FULL)

View solution in original post

12 REPLIES 12

sea_brue
Newcomer
Not sure if it's related but when I enter the edit mode of a curtain wall in 3D, the model disappears completly. Everything is white. It only happens with some curtain wall elements.

Barry Kelly
Moderator
David wrote:
I previously complained about shadows disappearing in 3d explore mode with ArchiCAD 22, but now I see that the memory issues are much worse than just the shadows. I'm working with fairly complex models but ArchiCAD 21 handled them easily. In 22 large parts of the same models simply disappear when I try to walk through them in 3d explore mode. I've checked the memory settings in the WE and updated the driver for the GeForce GTX 750 card I'm using, to no avail.

Is anyone else seeing this?
Is it only when in explore mode?
Is navigating in the 3D window OK?

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Barry Kelly
Moderator
sea_brue wrote:
Not sure if it's related but when I enter the edit mode of a curtain wall in 3D, the model disappears completly. Everything is white. It only happens with some curtain wall elements.
The same thing happens when editing stairs and railings as well.
The surrounding environment becomes a ghost image or can be turned off completely in the editor settings dialogue (top left when in edit mode).

Only the curtain wall, stair or railing that you are editing will be active.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

David Collins
Booster
Barry wrote:
Is it only when in explore mode?
Is navigating in the 3D window OK?
Now that you mention it... The 3d window displays everything correctly as long as it remains static. If I change the view point, either with Orbit or Explore, objects, doors and windows will disappear. Only basic elements like walls and slabs display. Stopping either "explore" or "orbit" restores the complete model to view.

Most of the objects in these models are custom GDL that I've created. I wonder if these old Cookbook level scripts are missing something new in this version?
David Collins
Win10 64bit Intel i7 6700 3.40 Ghz 32 Gb RAM
AC 24.0 (3022 INT FULL)

Barry Kelly
Moderator
Try playing with the frame rate settings in the 3D style settings.
I am not sure what the defaults are, but this is what mine was set to.

Higher frame rates will make some elements disappear during navigation.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Erwin Edel
Mentor
Everything going white with editing, sounds like the grid is no longer transparant.

View > Grid & Editing Plane Options > Grids & Backgrounds

Check the opacity sliders for the background and grid lines.
Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-24 NED FULL
Windows 10 Pro
Adobe Design Premium CS5

David Collins
Booster
Barry wrote:
Try playing with the frame rate settings in the 3D style settings.
Thanks Barry. That was a good thought, but unfortunately made no difference in the Mysterious Case of the Disapperaing Model in Explore Mode. Somehow OpenGL is not getting enough memory to do its job here. The maddening thing is that ArchiCAD 21 on the same computer handles the those models with no problem at all.
David Collins
Win10 64bit Intel i7 6700 3.40 Ghz 32 Gb RAM
AC 24.0 (3022 INT FULL)

JaredBanks
Participant
I was seeing the same issue. I dropped the frame rate from 10 to 7 and it fixed the issue. No more disappearing stuff in 3D in ARCHICAD 22. To be safe, I moved my default to 5 in my template. I'm guessing it has to do with model complexity? I wasn't seeing the issue on a smaller model.
Jared Banks, AIA

ArchiCAD blog: www.shoegnome.com
ArchiCAD tutorial videos: https://www.youtube.com/shoegnome

JaredBanks
Participant
follow up: That change fixed it temporarily. More research to do.
Jared Banks, AIA

ArchiCAD blog: www.shoegnome.com
ArchiCAD tutorial videos: https://www.youtube.com/shoegnome

David Collins
Booster
David wrote:
Is anyone else seeing this?
JaredBanks wrote:
I was seeing the same issue.
That is some comfort, at least. I'm still puzzling over this myself.
David Collins
Win10 64bit Intel i7 6700 3.40 Ghz 32 Gb RAM
AC 24.0 (3022 INT FULL)

David Collins
Booster
Jared- It turns out this issue was addressed over on this thread:
https://archicad-talk.graphisoft.com/viewtopic.php?f=13&t=61681
Scroll down to Laszlo's post.

Something called "Incremental Drawing" is turned on by default in version 22. In previous versions it was turned off. Going into the Registry and creating an entry to turn it off seems to have resolved this problem for me.
See this article:
https://helpcenter.graphisoft.com/knowledgebase/84288/

3d navigation is now a lot (a LOT) jerkier than it was in version 21, but at least the entire model remains visible. I'm guessing Graphisoft reallocated memory resources in this version and 3d openGL got short-changed as a result. Personally, if I had to chose between version 22's smooth 2d zooming and the really smooth 3d navigation I was seeing in version 21, the 3d would win every time.
David Collins
Win10 64bit Intel i7 6700 3.40 Ghz 32 Gb RAM
AC 24.0 (3022 INT FULL)

Solution
David Collins
Booster
For the record this issue was resolved with ArchiCAD 22 update 4023.
See https://www.graphisoft.com/downloads/archicad/updates/AC22/ImprovementsList.html
Thank you Graphisoft !
David Collins
Win10 64bit Intel i7 6700 3.40 Ghz 32 Gb RAM
AC 24.0 (3022 INT FULL)

View solution in original post

Didn't find the answer? Start a new discussion

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!