Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Wall Ends merging, reference line extending

Anonymous
Not applicable
Hi All,

I am having a problem where (if the reference lines touch) a walls reference line will extend to touch the edge of the wall it is perpendicular to. Please see attachment for visuals.
Both images are in plan. In "before.png" I have 3 walls selected. The white wall is 1/16" away from the topmost wall. All the reference lines are the correct lengths. In "after.png" I have moved the white wall 1/16" up to touch the topmost wall, and now it's reference line is longer , and a host of other small changes have occured.

How do I stop this?? What is causing it? How do I control when it happens?

I have looked on this forum and had a very hard time finding an answer as to why archicad does this. The closest I found was junction order and that did not seem to solve the problem. White wall has a junction order of 0 and top wall was junction order of 8. In options I have auto intersect turned off. The two walls have different structures, but are on the same layer.

Still new to archicad, and this has been a mystery to me for a while now.....

Before
After
2 REPLIES 2

Barry Kelly
Moderator
Nothing to do with junction order in this case.
It is the strengths of the building materials you have used for the walls.

The white wall is stronger than the top wall.
They will automatically trim to each other as soon as the reference lines touch (Archicad automatically does this).
The white wall is stronger so it will trim away the top wall.

There are a few ways to fix this.
The easiest is to use a building material (structure) for the two corner walls that is stronger than the white wall, or use one for the white wall that is weaker than the other walls.
This may require duplicating one of the building materials and making a weaker/stronger version of it.
So you can keep the original building material as well as you may need to use it in other locations with the strength it currently has.

If that is not an option then you can swap the reference line of the top wall so it is on the other side of the wall.
Then you can trim (split) the white wall to the inside of the top wall and delete the intersecting part.
This will manually override the automatic connection, but if you edit the white wall it may automatically re-trim and you will have to split it again.

There is another option using layers with different intersection priority numbers.
Walls in layers that have different numbers will not trim with each other.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
Hi Barry,

Thank you so much! This makes a lot of sense, and it was a setting I had not understood before.

-SJ

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!