cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Design forum

complex 3D

Anonymous
Not applicable
When I am using complex 3D modelling (using third party models, like intensive foliage), after a certain number of polygons, ArchiCAD OpenGL takes way too much time to build the model. Yet the same 3D scene works flawlessly in say Rhino or 3DStudio. Is there any way to fasten this process or simplify the OpenGL engine? Accuracy is less important here than speed.

Hardware improvement is off the table, as this also happens on high-end setups. (2xquadcore CPU, crossfired-ati4850)

Also, if any developer reads this, I would recommend 3D building a low priority process, because after running into such deadend, there s no way to stop the immensely long process, as hitting the "stop" button has absolutely no effect. (so one has to terminate ArchiCAD altogether)
5 REPLIES 5

Thomas Holm
Booster
OpenGL doesn't build the model in Archicad, it just displays it after it's built by the CPU. So a better graphics card will just let you navigate the model faster.

To get an updated model in the 3D window faster (after design changes etc.), you'll have to upgrade to AC 12 which can utilize up to 4 CPU cores. Remember Archicad's parametric intelligent building information model is something quite different from any graphics-only 3D software. If you don't need Archicad's intelligence, simply don't waste your money on it.

Also beware of cracked copies. No support, no bugfix updates, no upgrades, and often hangs to the point of force-quit.
AC4.1-AC24SWE-25INT; OSX11.5; MP5,1+MBP16,1

Dwight
Newcomer
You can reduce the OpenGL demands by reducing options.

3D Window Settings.
opengl.jpg
Dwight Atkinson

Anonymous
Not applicable
None of this actually works. The software is genuine, so this is not about being unpatched or buggy. 3D navigation is smooth, even with maximum settings. As an architect, because of the nature of my work, using third party sw. for modelling is not the best idea - even if AC12 has its limits. Actually, AC12 for me seems to be slower for model updating (even though I have 8 cores) than 10 (I skipped 11).

Karl Ottenstein
Moderator
Csaba,

You might download (Help > Goodies) the Polycount add-on if you do not already have it and check the number of polygons in your model. It could be that the stuff you downloaded is just too much for ArchiCAD.

ArchiCAD definitely bogs down much sooner than other 3D software with high polycount models. Things that get very slow in ArchiCAD are still very fast in Artlantis, for example. So, you may have to turn off trees, (or whatever the problem objects are), in the ArchiCAD 3D window except when you absolutely must see them.

Cheers,
Karl
One of the forum moderators   •   AC 26 USA and earlier   •   macOS Ventura 13.2, iMac Pro 10-Core, Radeon Pro Vega 64

Anonymous
Not applicable
Thank you for the tip. I know, that I am using way too many polygons, but still, when I insert a detailed car model for instance, it should not stagger like that. The strangest thing is that during such a model building phase, CPU usage never ever gets over 40 %, and is usually below 15 %. This is strange, and it is even more strange, that previous ArchiCAD versions (going as low as v9.0) handle these models fine. And importing a raw binary nonparametric data should not have this effect anyway. The only solution I had so far is to add a parametric switch to these items, showing only their bounding box when in 3D until the presentation phase.

Didn't find the answer? Start a new discussion

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!