Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

dwg/dxf to GDL underscaled?

Anonymous
Not applicable
I have a rather annoying problem concerning DWG/DXF object import to ArchiCAD. So, according to plan, I open the object (3D scene) as a library part - now there is the problem right away - the object size is way underscaled, some 1/10000 of the original. Ok, there is the ever returning (why, oh why can't developers ever fix it) different-unit problem, so, it is possible, that the DWG was saved in a mm-based scene, while the ArchiCAD plan is a meter-based. All attemts to change default object size in the GDL paragraph is futile, as ArchiCAD sets it immediately back when I attemt to save it. The problem, however, is that ALL 3D elements within the objects are described by so small coordinates, that it inherently causes 3D projection errors, and missing parts of the whole scene.

Example: 845132845123845.0000001, 845132845123845.0000002

If I have no access to the DWG to change its setting, is there any way to import the scene/objects correctly, with the right scale?
5 REPLIES 5

fuzzytnth3
Booster
You can set the units ArchiCAD uses to import the dxf file by clicking on the Settings button and selecting a suitable setting from the pop up

As you can see I have a set of translators already setup for most eventualities



AC versions 3.41 to 25 (UKI Full 5005).
Using AC25 5005 UKI FULL
Mac OSX 10.15.7 (19G2021) Mac Pro-2013 32gbRam AMD FirePro D500 3072 MB graphics

Anonymous
Not applicable
But does it apply to object importation as well? Actually I do not have any controll on how it translates a DWG to a GDL object, so no translator choices are available.

fuzzytnth3
Booster
Yes, when you open the DXF using the menu command Open Object.... and you change the file type to DXF the translator can be selected or created then.

AC versions 3.41 to 25 (UKI Full 5005).
Using AC25 5005 UKI FULL
Mac OSX 10.15.7 (19G2021) Mac Pro-2013 32gbRam AMD FirePro D500 3072 MB graphics

Anonymous
Not applicable
i haven't played with dxfs in ages.
You could try putting a MUL command at the start of the 3d script
eg. MUL 100, 100, 100
Would make the whole object 100 times bigger...

Anonymous
Not applicable
Thank you all for the answers, both solves the problem.

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!