Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

morph cover can't be done properly

tenak333
Newcomer
Does anyone know why can't I get a good cover for the morph?
I get either some weird surface or completely flat one.

Thank you!
Archicad 22 / Windows 10 / 64-bit
1 ACCEPTED SOLUTION

Solution
Laszlo Nagy
Community Admin
Community Admin
If you don't need a solid body, but a shell, try the Shell Tool's Ruled Geometry Method. You can define the Profiles at both ends. Then you can use the Set End Angle" Pet Palette command to change the end angle of both ends.
If you set the angle to 100 degrees, the other end is 80 degrees, if you want them to be parallel.
The reason this is good solution for this case is because the Shell Tool's Ruled Geometry Method properly connects the corresponding points of the two profile polygons and generates the surface correctly.
See the attached screenshot.
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

View solution in original post

9 REPLIES 9

Laszlo Nagy
Community Admin
Community Admin
The planes at the two ends of the top surface: are they the same geometry or different?
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

tenak333
Newcomer
They are the same geometry - they are arches converted to morphs, parallel to one another, moved to the side a bit (not one in front of another).
Archicad 22 / Windows 10 / 64-bit

Steve Jepson
Advisor
tenak333 wrote:
Does anyone know why can't I get a good cover for the morph?
I get either some weird surface or completely flat one.

Thank you!
By cover, do you mean roof? it is no problem to make two arches, offset them, and make use a morph to cover them if that what you mean. https://www.screencast.com/t/PcMe3UhMm

ArchiCAD 25 4013 USA - Windows 10 Pro 64x - Dell 7720 64 GB 2400MHz ECC - Xeon E3 1535M v6 4.20GHz - (2) 1TB M.2 PCIe Class 50 SSD's - 17.3" UHD IPS (3840x2160) - Nvidia Quadro P5000 16GB GDDR5 - Maxwell Studio/Render 5.2.1.49- Multilight 2

tenak333
Newcomer
Yes, like a roof for them.
I need something as shown in the image.
But I can't manage to create it.
Instead I get weird things as shown before.
Archicad 22 / Windows 10 / 64-bit

Solution
Laszlo Nagy
Community Admin
Community Admin
If you don't need a solid body, but a shell, try the Shell Tool's Ruled Geometry Method. You can define the Profiles at both ends. Then you can use the Set End Angle" Pet Palette command to change the end angle of both ends.
If you set the angle to 100 degrees, the other end is 80 degrees, if you want them to be parallel.
The reason this is good solution for this case is because the Shell Tool's Ruled Geometry Method properly connects the corresponding points of the two profile polygons and generates the surface correctly.
See the attached screenshot.
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

View solution in original post

tenak333
Newcomer
Thank you for your help!
It seems it worked with morph tool, but only when I created two very similar profiles (arches), covered them with smooth surface, and then afterwards I could modify them to get more different profiles as on the image.
Archicad 22 / Windows 10 / 64-bit

Steve Jepson
Advisor
just a tip about making things like that smooth- very smooth. If you start with one of the Basic Shape objects like Conoid 22 or Cylinder 22 you can set the Resolution to 9999 or something like that and the object will be smooth as babies behind. Then when you convert it into a morph it will be super smooth too. This is how you avoid some of the distortion you are seeing. Several other Objects have a Resolution setting as well. I really like it. I wish they all had that . I am using 64GB memory and a 16GB graphics card and I never experience any slow down for using the smoothest of everything I can get in ArchiCAD. Nothing is more annoying to me than the totally insufficient results we get for smooth curves in a Complex Profile. If it has curves, I do not consider a Complex Profile to even be a an option.

ArchiCAD 25 4013 USA - Windows 10 Pro 64x - Dell 7720 64 GB 2400MHz ECC - Xeon E3 1535M v6 4.20GHz - (2) 1TB M.2 PCIe Class 50 SSD's - 17.3" UHD IPS (3840x2160) - Nvidia Quadro P5000 16GB GDDR5 - Maxwell Studio/Render 5.2.1.49- Multilight 2

Laszlo Nagy
Community Admin
Community Admin
That 9999 resolution sound way too much to me. That means that a full circle is approximated using cca. 10000 lines, a half-cylinder is approximated using 5000 polygons, a half-dome is approximated using 5000x5000 polygons, just for a single object.

The default resolution in GDL is 36, so a resolution of 72 or 108 or 180 could be more than enough for display purposes.
Of course it also depends on the absolute size of the element. A 100 m element will need a higher resolution than a 10 m element.
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Steve Jepson
Advisor
LaszloNagy wrote:
That 9999 resolution sound way too much to me. That means that a full circle is approximated using cca. 10000 lines, a half-cylinder is approximated using 5000 polygons, a half-dome is approximated using 5000x5000 polygons, just for a single object.

The default resolution in GDL is 36, so a resolution of 72 or 108 or 180 could be more than enough for display purposes.
Of course it also depends on the absolute size of the element. A 100 m element will need a higher resolution than a 10 m element.
I assume that it doesn't matter too much because there is going to be a limit. Use all 1's if you like. Typing in a bunch of 9's is just a way to make sure you have reached it. For all I know 99 is enough I don't care, as long as I know I have made it as smooth as it cab be. And like I said, I never have any problems with making everything as smooth as I can. The idea is to just click one digit any digit not 0 a few times because we don't know what the limit is and 7777777777 or what ever will do the job.

ArchiCAD 25 4013 USA - Windows 10 Pro 64x - Dell 7720 64 GB 2400MHz ECC - Xeon E3 1535M v6 4.20GHz - (2) 1TB M.2 PCIe Class 50 SSD's - 17.3" UHD IPS (3840x2160) - Nvidia Quadro P5000 16GB GDDR5 - Maxwell Studio/Render 5.2.1.49- Multilight 2

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!