Developer forum
Showing results for 
Search instead for 
Did you mean: 

ArchiCAD 9 Developer Tools Available for Download

Ed Brown
Developer tools for ArchiCAD 9 are available for download. Please find detailed information and new feature list together with the tools to download at It is important to note that new compilers (CodeWarrior 9, .NET 2003) have to be used for creating Add-Ons compatible with ArchiCAD 9.
Graphisoft Technical Support

Ben Cohen
Hi Ed

Any idea when the ODBC drivers for version 9 will be released?


Ben Cohen

Mac and PC

Archicad (Latest Version) aus

Ed Brown
To Ben and all others waiting patiently for the ODBC driver.

The updated driver is now available at

Sorry for the delay,

Graphisoft Technical Support

Todd Cochrane
Hi , I've downloaded the ArchiCAD 9 API.

I asked for Visual Studio 2003 , but was given Visual Studio 2005.

Visual Studio 2005 converts the solutions OK, but can n't compile the resources. The following from DLL Test, but also tried another example and get stopped at the same point.

Error 1 fatal error RC1015: cannot open include file 'Dll_Test.grc.rc2'. c:\Program Files\Graphisoft\API Development Kit 6.1\Examples\Dll_Test\RFIX.WIN\Dll_Test.rc2 19

Error 2 error PRJ0019: A tool returned an error code from "Compiling the RC2 file..." Dll_Test

Has anyone used Visual Studion 2005 with the ArchiCAD 9 Developer Tools ?


Sorry, but I have the same problem while developing with DevKit 12 using MSVC8.

I was build some DevKit Examples successfully with my developing ID and load it to ArchiCAD 12.

Then I was create a new ArchiCAD Add-On project and just try to compile it.
The next error occur:

------ Rebuild All started: Project: ArchiCAD Add-On2, Configuration: Debug Win32 ------
Deleting intermediate and output files for project 'ArchiCAD Add-On2', configuration 'Debug|Win32'
Compiling the RC2 file...
External build tool process set to low priority...
d:\work\archicad\ArchiCAD Add-On2\ArchiCAD Add-On2\Make.Win\..\RFIX.WIN\ArchiCADAddOn2.rc2(15) : fatal error RC1015: cannot open include file '..\Debug\ArchiCADAddOn2.grc.rc2'.
Project : error PRJ0019: A tool returned an error code from "Compiling the RC2 file..."
Creating browse information file...
External build tool process set to low priority...
Microsoft Browse Information Maintenance Utility Version 8.00.50727
Copyright (C) Microsoft Corporation. All rights reserved.
BSCMAKE: error BK1506 : cannot open file '.\debug\ArchiCADAddOn2.sbr': No such file or directory
Build Time 0:00
Build log was saved at "file://d:\work\archicad\ArchiCAD Add-On2\ArchiCAD Add-On2\Make.Win\Debug\BuildLog.htm"
ArchiCAD Add-On2 - 3 error(s), 0 warning(s)
========== Rebuild All: 0 succeeded, 1 failed, 0 skipped ==========

Please, show me my error.

Karl Ottenstein
Sounds like the project template (used for New Project) does not have the proper settings for invoking the resource compiler. And/or you saved the project somewhere else on your disk and the project settings use relative paths, such as ../.. to find things.

First, try copying your entire new project folder to be inside the Examples folder. If that builds, then it is indeed just an issue of the build settings using relative paths.

If that still does not work, then since the examples build for you, just copy and example, and replace the source files for it with yours and go from there....unless you feel like digging into all of the build settings to track it down the problem...

One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.1, iMac Pro

Thanks, Karl

Karl Ottenstein
You're welcome ... please post what eventually solves the problem for you.

One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.1, iMac Pro

Oh, sorry.

I use example project as base for my Add-On.


I just tried to compile the 64-bit version of my add-on and it doesnt work. Im using MSVC 2005 and devKit 13 (latest).

If I compile the 32-bit version, everything goes right, build succeeds and add-on is working.

But when I switch the libraries to x64 and switch the compiler to x64, it stops on the error mentioned previously:
"fatal error RC1015: cannot open include file 'Selection_Manager.grc.rc2'." and so on.

Any idea where the problem could be? Thanks


I tried clean devkit examples: it is the same - win32 compiling ok, x64 with 64bit libraries has error

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!