Developer forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Error with Visual C++ 2005 and AddOnAdmin

Anonymous
Not applicable
Hi guys,

First of all, sorry for english. So, i'm starting to review the examples provided with (API Development Kit 15.2702), to understand how to make my onw Add-on.

And there are some difficulties and errors that i'm facing:

1º - following the link ( http://www.archicadwiki.com/Developer/Getting%20Started%20with%20the%20API%20DevKit?highlight=%28Kar... ), where there was a summary to how to start with the API DevKit. I can't do the topic 5 - The MDID Resource and Generating an Add-On ID (AddOnAdmin), because i can´t execute the AddOnAdmin.exe in the Support/Tools - it says that is missing the UsageLogger.dll, there is any solution for this problem?

2º - Having the Visual C++ 2005 installed in my Windows 7 x64, i begin to study the examples that were provided with the DevKit, so i open the GSRoot_Test (for start) and when i start to debug, (selected Debug Win32) there ocour some errors that i can't understand:

1>------ Build started: Project: GSRoot_Test, Configuration: Debug Win32 ------
1>Compiling the localized GRC file...
1>O sistema não conseguiu localizar o caminho especificado.
1>Project : error PRJ0019: A tool returned an error code from "Compiling the localized GRC file..."
1>Creating browse information file...
1>Microsoft Browse Information Maintenance Utility Version 8.00.50727
1>Copyright (C) Microsoft Corporation. All rights reserved.
1>BSCMAKE: error BK1506 : cannot open file '.\debug\GSRoot_Test.sbr': No such file or directory
1>Build log was saved at "file://c:\Users\Pedro Daniel\Downloads\UNIVERSIDADE\Disciplinas\5º ano\TESE\ARCHICAD\EXEMPLOS API\Examples\GSRoot_Test2\Debug\BuildLog.htm"
1>GSRoot_Test - 2 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========


What am I doing wrong, for happenig this errors? Also i'm starting to understant Visual C++ (i'm not a programmer). what's the next steps to follow?

I need some help as soon as possible

thanks in advance,
Best regards,

Peter_D
5 REPLIES 5

Anonymous
Not applicable
Copy UsageLogger.dll of the archicad directory, it works for me in the win xp 32 bits edition, in the 64 bits edition i doesnt work for me, i think that addon management its for 32 bits only at least the version i can download.

Anonymous
Not applicable
Jose wrote:
Copy UsageLogger.dll of the archicad directory, it works for me in the win xp 32 bits edition, in the 64 bits edition i doesnt work for me, i think that addon management its for 32 bits only at least the version i can download.
Thanks for the help

I already tried that, and it´s like you said, i doesn't work in my Windows 7 x64 bits. In the other topic that i saw for AddOnAdmin, they said that there is other version of addOnAdmin (but i don't known if there was to x64 bit or to mac users), but i think that the link is off.

Here is the link to the topic: http://archicad-talk.graphisoft.com/viewtopic.php?t=38026

I already send a P.M. to the person in that topic that spoke on the new version of AddOnAdmin and i have to waiting for.

Best Regards,

Peter_D

Ralph Wessel
Mentor
peter_D wrote:
some errors that i can't understand:
1>O sistema não conseguiu localizar o caminho especificado.
We will deal with the errors one by one - sometimes an early error is also responsible for later ones.

The error message is occurring at a stage where the add-on resources are prepared. Because ArchiCAD is cross-platform, Graphisoft has devised a platform-neutral description of resources (GRC) which is converted to platform-specific resources during the build process by the GRC converter (ResConv). The error indicates that a path to something is wrong, but I can't tell whether this is the path to ResConv or the file to convert.

When you installed the API devkit, did you move or rename any of the directories it created? The examples should typically compile directly as they are installed. If you have changed anything, I suggest reinstalling first.
peter_D wrote:
(i'm not a programmer).
You will need to be one if you plan to use the API. It's a bit like saying that you intend to get your drivers license but don't know how to drive. Step 1 is to learn - you have no chance otherwise.
Ralph Wessel BArch

Akos Somorjai
Graphisoft
Graphisoft
peter_D wrote:
Jose wrote:
Copy UsageLogger.dll of the archicad directory, it works for me in the win xp 32 bits edition, in the 64 bits edition i doesnt work for me, i think that addon management its for 32 bits only at least the version i can download.
Thanks for the help

I already tried that, and it´s like you said, i doesn't work in my Windows 7 x64 bits. In the other topic that i saw for AddOnAdmin, they said that there is other version of addOnAdmin (but i don't known if there was to x64 bit or to mac users), but i think that the link is off.

Here is the link to the topic: http://archicad-talk.graphisoft.com/viewtopic.php?t=38026

I already send a P.M. to the person in that topic that spoke on the new version of AddOnAdmin and i have to waiting for.

Best Regards,

Peter_D
I'll try to upload a better version when I get a decent internet access, here it is:

https://graphisoft.sharefile.com/d/s0438fc70f644341b

Good luck, Ákos

Akos Somorjai
Graphisoft
Graphisoft
peter_D wrote:
Hi guys,

First of all, sorry for english. So, i'm starting to review the examples provided with (API Development Kit 15.2702), to understand how to make my onw Add-on.

And there are some difficulties and errors that i'm facing:

1º - following the link ( http://www.archicadwiki.com/Developer/Getting%20Started%20with%20the%20API%20DevKit?highlight=%28Kar... ), where there was a summary to how to start with the API DevKit. I can't do the topic 5 - The MDID Resource and Generating an Add-On ID (AddOnAdmin), because i can´t execute the AddOnAdmin.exe in the Support/Tools - it says that is missing the UsageLogger.dll, there is any solution for this problem?

2º - Having the Visual C++ 2005 installed in my Windows 7 x64, i begin to study the examples that were provided with the DevKit, so i open the GSRoot_Test (for start) and when i start to debug, (selected Debug Win32) there ocour some errors that i can't understand:

1>------ Build started: Project: GSRoot_Test, Configuration: Debug Win32 ------
1>Compiling the localized GRC file...
1>O sistema não conseguiu localizar o caminho especificado.
1>Project : error PRJ0019: A tool returned an error code from "Compiling the localized GRC file..."
1>Creating browse information file...
1>Microsoft Browse Information Maintenance Utility Version 8.00.50727
1>Copyright (C) Microsoft Corporation. All rights reserved.
1>BSCMAKE: error BK1506 : cannot open file '.\debug\GSRoot_Test.sbr': No such file or directory
1>Build log was saved at "file://c:\Users\Pedro Daniel\Downloads\UNIVERSIDADE\Disciplinas\5º ano\TESE\ARCHICAD\EXEMPLOS API\Examples\GSRoot_Test2\Debug\BuildLog.htm"
1>GSRoot_Test - 2 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========


What am I doing wrong, for happenig this errors? Also i'm starting to understant Visual C++ (i'm not a programmer). what's the next steps to follow?

I need some help as soon as possible

thanks in advance,
Best regards,

Peter_D
The other error might come from a couple of sources:

- the devkit is not installed correctly (I noticed a 'Downloads' folder in the path)
- the devkit files/ folders might be read-only, so please make the folders/files writeable
- the example projects are setup to look for devkit components at given relative paths, so if you create an example somewhere else, then you'll have to adjust the paths as well.

Best, Ákos

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!