Developer forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Multiple add-ons not loading

dushyant
Booster

Hi

I created two add-ons, each having its own unique 'Local ID', and my developer ID. Each works fine when loaded independently at a time in Archicad 25. But when I try to load both of them in the same instance of Archicad, only one works.

Could it be because of the 32500 resource ID in both the add-ons? I don't see any other similar resource which could cause a clash.

Considering the two add-ons are:

1. Addon-A

2. Addon-B

Both of the add-ons are palette-based. Both of their menus get loaded. But only the palette of Addon-B opens on clicking its menu-item.

Addon-A's palette never opens when Addon-B is loaded (palette-B open or not open, in either case).

Addon-B uses BrowserControl.

Sometimes Archicad crashes when I try to open the palette of Addon-A.

Addon-A's palette does not open even when Addon-B is unloaded and the project is reloaded. It only opens when Archicad is restarted (after unloading Addon-B).

 

Why is this happening?

 

Thanks.

 

1 ACCEPTED SOLUTION

Solution
Viktor Kovacs
Graphisoft Alumni
Graphisoft Alumni

I'd check if the guids are different for the palettes in the DG::Palette constructor call.

View solution in original post

4 REPLIES 4

Solution
Viktor Kovacs
Graphisoft Alumni
Graphisoft Alumni

I'd check if the guids are different for the palettes in the DG::Palette constructor call.

View solution in original post

dushyant
Booster

Yes, you are right, the guids of both the palettes are the same.

I don't know how to create a guid, so I copied.

 

How do you create a new guid for a palette?

Viktor Kovacs
Graphisoft Alumni
Graphisoft Alumni

With any guid generator, for example this one: https://www.guidgenerator.com/

Thanks a lot! That solved it!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!