Developer forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Unfold Parameters in UI

Martin Walter
Participant
When I open the UI the parameters are always folded up this way:
  •  
but I like to have them unfolded, without clicking every arrow, like this:
  •  
AC23, Windows 10, i7-6700HQ, 8Gb RAM, 500Gb SSD
4 REPLIES 4

Barry Kelly
Moderator
You have to click the arrows I am afraid.

Unless you edit the library parts, and turn of the dependency buttons for all of the parameters in the parameter list.
But if you are using standard Graphisoft objects, that is not a wise thing to do.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Lingwisyer
Virtuoso
Since they are just headers, you could swap to using the Title parameter type instead of using the parameter group(?) function. That is if you want to remove the collapsible function all together.



Ling.
AC18-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200

Barry Kelly
Moderator
Lingwisyer wrote:
Since they are just headers, you could swap to using the Title parameter type instead of using the parameter group(?) function. That is if you want to remove the collapsible function all together.

It doesn't matter what the parameter type is - title, length, boolean, etc.
It is the dependency switch that controls the expanding arrow.
A dependent parameter will automatically make the parent parameter BOLD as if it was a title type, but it can still be any type.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

They probably can stay unfolded as a default if You use the ui script and ui_listfield command

instead of the plain vanilla parameters view...yet the hideparameter all, (_list of ones not to hide_)

has to be in use not to show the parameters themselves

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!