Developer forum
cancel
Showing results for 
Search instead for 
Did you mean: 

What is needed for ArchiCAD to use the plugin?

Anonymous
Not applicable
i have downloaded the latest API and have ArchiCAD running in DEMO mode (graphisoft hasnt given me my id yet) and after compiling the addon which compiles with only one warning:

ACAP_STAT.lib(ACAPlib.obj) : warning LNK4099: PDB 'api_c.pdb' was not found with '\Program Files\Graphisoft\API Development Kit 6.1\Support\Lib\Win\ACAP_STAT.lib' or at 'c:\Documents and Settings\matthew\My Documents\Visual Studio Projects\ArchiCAD Add-On1\Make.Win\Debug\api_c.pdb'; linking object as if no debug info

the add-on manager gives me this message:

The file is an outdated Add-On that cannot be used with this ArchiCAD version.

shouldnt the examples compile as a demo add-on out of the box without changing anything? If it helps to know, im on Windows XP SP2, using visual studio 2003

-- Matthew Peychich
1 REPLY 1

Andras Babos
Graphisoft Alumni
Graphisoft Alumni
Strange. You should be able to use the default Add-On in the DEMO version.

Try opening the compiled Add-On with Visual Studio as a resource and check whether it has a 'VERS' and an 'MDID' resource in it. (It should have a 'VERS' resource for version 9.0 and an 'MDID' resource of 1 and 1.) If it doesn't then try again with a new project without touching the GRC files at all first.

... and just an other thought: make sure that the Visual Studio AC Add-On AppWizard uses the correct API DevKit directory to compile your Add-On.

HTH:
Andras.

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!