Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

A section view got rotated - how did this happen?

Ignacio
Enthusiast
This is a file I didn't start, so I don't know the history of this section. But I don't think I ever saw this and I can't understand how it happened. It is a view that takes me to section viewpoint —it is not a worksheet which is what I first thought.
The file has rotated plan views, and may have once had rotated drawings, and I was thinking that maybe redirecting a drawing, or transferring settings, resulted in this. But I get the same thing on the viewpoint, and as a way out I can only think of creating a new section.

Edit: I created a new section, view and drawing, starting off settings in marker and views of a section that is doing fine, and I get the same thing. All the other sections and elevations are doing fine.

Edit 2: I unrotated the plan view back to 0, created the section marker with that view active, opened with current settings and it looked fine, opened another section view which was fine, in Organizer dragged the new section viewpoint to the View Map and the new View still appears rotated.

Edit 3: it is happening with whatever settings I create the view —dragged in Organizer with elevation views active, with schedule views active.

Edit 4: at some point a few days ago I copypasted a section marker from some other file, in order to extract-inject its settings. It is likely that I copied it from an unrotated plan view and pasted it into a rotated plan view.

Edit 5: I unrotated the plan view, copypasted a section marker from the other file, extracted settings from it, created a new section marker, opened viewpoint and created views and drawings with no problem. So there is something that had got messed up with that straight-to-rotated section marker copypaste.
16 REPLIES 16

Laszlo Nagy
Community Admin
Community Admin
That is pretty curious, I will report this to GRAPHISOFT.
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hi Ignacio,

Thank you for your question and I am very sorry about the issue!

From your description and screenshot, I believe this is similar to a known defect in ARCHICAD 23 build 3003. As of now, we haven't released a fix to stop it from happening, but the rotated section can be repaired by using Open & Repair function with build 4006. This will reset the corrupted section to correct orientation.

Thank you for your understanding! Let me know if this helps!

Best regards,
Minh.

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Ignacio
Enthusiast
I tried Open & Repair, I am on 4006. This was a bimserver file, so it involved saving as pln, O&R, reuploading to bimserver. After a few days I got auto-rebuild elevations converted to independent drawings (https://archicad-talk.graphisoft.com/viewtopic.php?f=20&t=42172), and after finding no solution for that, I deleted elevation markers and created new ones, which again appear rotated.

I saved that to pln, open-and-repaired, and that is not doing the job either.

This is a significant disaster.

Edit:
After several trials and errors I fixed a rotated elevation view by
- activating the plan viewpoint,
- rotating the plan viewpoint to 0,
- without opening the view, clicking on the view name on the navigator and “replace with current settings”.
That unrotated the elevation view.

vdentello
Contributor
Ignacio wrote:
I tried Open & Repair, I am on 4006. This was a bimserver file, so it involved saving as pln, O&R, reuploading to bimserver. After a few days I got auto-rebuild elevations converted to independent drawings (https://archicad-talk.graphisoft.com/viewtopic.php?f=20&t=42172), and after finding no solution for that, I deleted elevation markers and created new ones, which again appear rotated.

I saved that to pln, open-and-repaired, and that is not doing the job either.

This is a significant disaster.

Edit:
After several trials and errors I fixed a rotated elevation view by
- activating the plan viewpoint,
- rotating the plan viewpoint to 0,
- without opening the view, clicking on the view name on the navigator and “replace with current settings”.
That unrotated the elevation view.
That happened with a customer here before. The exact same issue, and looks like it passes the rotation value from a planview to the section, even though the section doens't have this option. I believe this was reported at that time, but i couldn't find the original e-mail.
Archicad User Since 2013
GDL Developer
Experimenting with API
from Brazil

Ignacio
Enthusiast
Whoever is working on fixing this must probably be aware already but just in case: the same happens with 3D documents.

Anonymous
Not applicable
Hi,

Having the same problem here....
Any news on this issue?
Build 3003 still and right now wouldn't like to change it.

Anonymous
Not applicable
Have updated to AC23 4004 and it seems to have fixed it thankfully

edit: issue still persists in teamwork file (though seems to be fixed in solo file)

Anonymous
Not applicable
Attached is plan view of IE and also the four separate IE drawings. Two of them are coming in rotated, the other two fine. The IE was drawn whilst the plan was rotated and IE A & IE B is rotated by the same angle

Edit: Seems like I can't post more than four attachments at a time, but IE A is basically have the same issue as IE B

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
benjamin_chan wrote:
Attached is plan view of IE and also the four separate IE drawings. Two of them are coming in rotated, the other two fine. The IE was drawn whilst the plan was rotated and IE A & IE B is rotated by the same angle

Edit: Seems like I can't post more than four attachments at a time, but IE A is basically have the same issue as IE B
Hi Benjamin,

Thank you for sharing the issue and I am very sorry about the experience!

At the moment, the second update for Archicad 23 (build 5005) has been released, that should be able to fix this issue without using Open & Repair. I'm wondering if it is possible to install this update?

The issue happened with previous Archicad 23 build when you create a view and uncheck "Ignore zoom and rotation when opening this view". Have you tried what Ignacio suggested to fix the elevation?

If the above suggestions do not help with the issue, could you share the file with us in PLN format for further investigation? If you can include a method to reproduce the issue, that would be even better! Let me know if you need a secure link to forward the file to us.

Looking forward to hearing from you!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Anonymous
Not applicable
I confirm. 4006 fixes the bug but only after repairing the file. Great news indeed.

Barry Kelly
Moderator
afaria wrote:
I confirm. 4006 fixes the bug but only after repairing the file. Great news indeed.

And even better build 5005 is supposed to fix it without need for a rebuild.

https://archicad-talk.graphisoft.com/viewtopic.php?f=11&t=69736#p313677

Are you able to try it?


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
Hi Barry,

I am afraid I cannot at this point because 5003 is still not available in french. I am working out from Geneva Switzerland. If I try I would have to do it and then downgrade. Anyway, how problematic is it to install the INT version on a FRA? We have been told to wait by local reseller.

Barry Kelly
Moderator
afaria wrote:
Hi Barry,

I am afraid I cannot at this point because 5003 is still not available in french. I am working out from Geneva Switzerland. If I try I would have to do it and then downgrade. Anyway, how problematic is it to install the INT version on a FRA? We have been told to wait by local reseller.

I believe you can install the INT version with any other language version, but you can not mix different language versions.
Different language versions will not run on the same license - you need separate licenses for each language.

See... https://archicad-talk.graphisoft.com/viewtopic.php?f=5&t=66189&hilit=french#p294380

If you do want to install INT as well as your French version, I would rename you current Archicad program folder so the new installation does not overwrite the existing installation.
Or I think you may have a choice to install to a new location.
This way you can have both versions running at once.

But it is probably better to wait a while until the French update is released.
I don't know when that will be but it shouldn't be too long I hope.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

I did an open and repair with AC23 build 4006, and only the story level markers got horizontal. Everything else is still rotated
Mac OSX 10.14.6 | AC 24 INT 3008 FULL

Barry Kelly
Moderator
Achille wrote:
I did an open and repair with AC23 build 4006, and only the story level markers got horizontal. Everything else is still rotated

Try the latest build 5005.
It might be better.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
We also had problems with other files after recovering. However, I believe views created with the option "ignore zoom and rotation....." cause less error. But honestly I haven't completely got this issue sorted out.

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!