Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

AC23: Keyboard shortcuts won't allow Ctrl-M to be redefined

Paul King
Expert

In Archicad 23 (which I am still forced to use by company policy) I have been trying to edit keyboard shortcuts to get Ctrl+M to mirror text item positions about a centre line (oddly, the default looks to be to mirror 'non text' items only, even though Shift+Ctrl+M will work perfectly well with text items).

 

For this command, if I happen to delete the current binding, I can't then reinstate it. 

I can unbind then reinstate or otherwise redefine with any other Ctrl-letter combination for this or other commands but just cannot use Ctrl-M;  the mirror command appears to have a unique problem.

 

Toggling between non text only, and global modes for the command makes no difference either - there is simply no way permitted use mirror to relocate a text item - which is massively counterintuitive since mirror a copy does mirror text items as one would intuitively expect

 

Is there a known fix for this?

Is it a known bug?

 

I am using a standard US English Keyboard, and while Windows has my language set as New Zealand English, the keyboard is identical between languages.   Ctrl+M works normally outside of Archicad

 

PAUL KING
https://www.prime.net.nz
ArchiCAD 8-25
Octane Render Plugin for ArchiCAD
Twinmotion 2022
Windoze 11
Intel Core i9 10900K
Nvidia Gforce RTX 3080
32 Gb DDR3
2x4K monitor extended desktop
1 ACCEPTED SOLUTION

Solution

You could have some high priority software running in the background which has that Ctrl+M shortcut registered. Try to stop some background apps and try it again.

It could also be a physical problem. Try to connect another keyboard.

You should have the default shortcuts scheme loaded in Options > Work Environment > Shortcut Schemes menu. If you don't, there should be one in the Archicad Installation folder ...GRAPHISOFT\Archicad 23\Defaults\Archicad\WorkEnvironment\Shortcuts (INT Version), which you can import. I could send you the default one if you can't find it.

Archicad 4.55 - 25 | HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Nvidia Quadro M5000 @ Windows 10 Pro x64

View solution in original post

8 REPLIES 8

I have no problems using CTRL + M and text on AC23. I have been importing my keyboard shortcuts from version to version probably since AC10 though. I wonder when this was introduced.

 

I you have an older work environment (AC22 or earlier) with keybinding that work, you should be able to just import these into a work environment for testing.

 

The only thing I know off that can't be mirrored are placed drawings.

Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-24 NED FULL
Windows 10 Pro
Adobe Design Premium CS5

Miha_M
Expert

I checked this in v23 and don't have any problems re-assigning the Ctrl+M. I detached the shortcut, closed the UI, opened the UI again and attached the Ctrl+M again. No problems.

The non-text or global options are not for text items on your plans, but control the behavior of shortcuts in different windows  - Shortcut Customization Dialog Box (graphisoft.com).

I never use the Shift+Ctrl combo for duplitacing items as a double Ctrl click does the same job.

I don't think this is a bug, maybe you have some other issue on your computer. Try to solve your problem with importing a shortcut scheme from Archicad on a different computer.

Archicad 4.55 - 25 | HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Nvidia Quadro M5000 @ Windows 10 Pro x64

Paul King
Expert

Thanks guys.

 

I don't have an older keyboard shortcut file to import, but I note that for me the same issue applies to Archicad 24 and Archicad 25 with default settings. 

I am wondering if there is some sort of highly specific conflict with Windows 10 reserved keyboard shortcuts introduced with latest release 21H1 19043.1202

 

Of possible relevance is that the keyboard ascii code for Ctrl+M is the same as for Carriage Return?

 

In fact Ctrl+M now simply seems to do nothing in any Archicad version for me - almost as if that key combination is simply not being detected at all in Archicad, though an online keypress detector I tested my keyboard with shows no problem (records both keys being pressed), and Shift+Ctrl+M works normally in Archicad.

PAUL KING
https://www.prime.net.nz
ArchiCAD 8-25
Octane Render Plugin for ArchiCAD
Twinmotion 2022
Windoze 11
Intel Core i9 10900K
Nvidia Gforce RTX 3080
32 Gb DDR3
2x4K monitor extended desktop

Solution

You could have some high priority software running in the background which has that Ctrl+M shortcut registered. Try to stop some background apps and try it again.

It could also be a physical problem. Try to connect another keyboard.

You should have the default shortcuts scheme loaded in Options > Work Environment > Shortcut Schemes menu. If you don't, there should be one in the Archicad Installation folder ...GRAPHISOFT\Archicad 23\Defaults\Archicad\WorkEnvironment\Shortcuts (INT Version), which you can import. I could send you the default one if you can't find it.

Archicad 4.55 - 25 | HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Nvidia Quadro M5000 @ Windows 10 Pro x64

Thanks Miha - you were exactly right about the background task. (see other reply)

PAUL KING
https://www.prime.net.nz
ArchiCAD 8-25
Octane Render Plugin for ArchiCAD
Twinmotion 2022
Windoze 11
Intel Core i9 10900K
Nvidia Gforce RTX 3080
32 Gb DDR3
2x4K monitor extended desktop

I've had weird bugs with WIN10 updates before. Not related to AC but with our printer printing half of the page with some software, which turned out to be caused by WIN10 update after a long troubleshooting process. It is certainly not the first thing you assume is causing problems.

 

My workstation is currently on 20H2 and I don't have these issues with AC23.

Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-24 NED FULL
Windows 10 Pro
Adobe Design Premium CS5

Paul King
Expert

Well, I am embarrassed to admit, but the problem must have been interference from something else running in the background, because a hard reboot and starting Archicad before anything else seems to have cleared the problem. 

 

I googled the issue, and read something about 'keyboard hooks' from background tasks or applications hijacking or disabling certain keys. 

 

Probably the only way to identify the specific culprit would be a lot of trial and error with starting a bunch of other frequently used apps before (or after) starting Archicad  - hopefully culprit is nothing mission critical. 

PAUL KING
https://www.prime.net.nz
ArchiCAD 8-25
Octane Render Plugin for ArchiCAD
Twinmotion 2022
Windoze 11
Intel Core i9 10900K
Nvidia Gforce RTX 3080
32 Gb DDR3
2x4K monitor extended desktop

Funny how a reboot is always the last thing we try and ussually fixes it!

 

Sounds very familiar!

Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-24 NED FULL
Windows 10 Pro
Adobe Design Premium CS5

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!