Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Angle dimension tool AC25 bug

R Muller
Booster

Archicad 25 build 3011:  Can't use decimal degrees to dimension an angle using the angle dimension tool.  "Project Preferences" for angle dimensions in "decimal degrees" gives erroneous choice of only fractions (1/2, 1/4, 1/8 etc.), not number of decimal places.  Decimal angle dimensions upgraded from AC24 as well as new decimal angle dimensions created in AC25 are rounded off to whole numbers. This must be a bug.

 

Dimensions using degrees and minutes work OK.

R Muller

AC 25 USA (20+ years on ArchiCAD)

MBP 16GB OS 10.15 Catalina
3 ACCEPTED SOLUTIONS

Solution
Duncan
Contributor

It's a Mac interface bug with a temporary workaround available. Start at the preferences for linear dimensions and change the system to metric, click on the angular dimension icon and you should see the integer count numbers, not fractions, select your desired precision unit for angular dim, return to the linear dimension and switch back to imperial. Save the dim style. The fractions will appear again when viewing angular settings, but it should function as previously set.

View solution in original post

Solution

Here's a screen shot of the problem.  Screen Shot 2021-10-18 at 11.46.39 AM.png

 

Duncan's workaround does work for me, if I follow it exactly- thank you, Duncan!  The preference for angular dimensions still looks messed up, but what I actually get on my floor plan is what I want.

R Muller

AC 25 USA (20+ years on ArchiCAD)

MBP 16GB OS 10.15 Catalina

View solution in original post

Solution
Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator

Hi Muller,

 

Thank you very much for the screenshot! It was very helpful for me!

 

I found that this issue was entered into our defect database already (please refer to it as DEF-6233). As it is a new entry, currently it is set to be fixed in Archicad 25 Update 3. As Duncan mentioned, this is the workaround in this case.

Once again, thank you very much for the report. Please let me know if you have any further questions!

 

Best regards,

Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

View solution in original post

6 REPLIES 6

Laszlo Nagy
Community Admin
Community Admin

I will report this to Graphisoft, but can you post a screenshot of the Preference Dialog and the result?

....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Solution
Duncan
Contributor

It's a Mac interface bug with a temporary workaround available. Start at the preferences for linear dimensions and change the system to metric, click on the angular dimension icon and you should see the integer count numbers, not fractions, select your desired precision unit for angular dim, return to the linear dimension and switch back to imperial. Save the dim style. The fractions will appear again when viewing angular settings, but it should function as previously set.

View solution in original post

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator

Hi Muller and Duncan,

 

Thank you very much for the report and I am very sorry for the experience!

 

I would be very grateful if we can see a quick video of the issue and how the workaround works? Is it a Mac-only issue?

 

Looking forward to hearing from you!

Best regards,

Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Solution

Here's a screen shot of the problem.  Screen Shot 2021-10-18 at 11.46.39 AM.png

 

Duncan's workaround does work for me, if I follow it exactly- thank you, Duncan!  The preference for angular dimensions still looks messed up, but what I actually get on my floor plan is what I want.

R Muller

AC 25 USA (20+ years on ArchiCAD)

MBP 16GB OS 10.15 Catalina

View solution in original post

Steve Jepson
Advisor

Works just as expected for me. 

 

2021-10-14_19-00-13.jpg

ArchiCAD 25 4013 USA - Windows 10 Pro 64x - Dell 7720 64 GB 2400MHz ECC - Xeon E3 1535M v6 4.20GHz - (2) 1TB M.2 PCIe Class 50 SSD's - 17.3" UHD IPS (3840x2160) - Nvidia Quadro P5000 16GB GDDR5 - Maxwell Studio/Render 5.2.1.49- Multilight 2 - Adobe Acrobat Pro

Solution
Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator

Hi Muller,

 

Thank you very much for the screenshot! It was very helpful for me!

 

I found that this issue was entered into our defect database already (please refer to it as DEF-6233). As it is a new entry, currently it is set to be fixed in Archicad 25 Update 3. As Duncan mentioned, this is the workaround in this case.

Once again, thank you very much for the report. Please let me know if you have any further questions!

 

Best regards,

Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

View solution in original post

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!